fwknop-2.6.5-alt1_2.i586.rpm


Advertisement

Description

fwknop - A Single Packet Authorization (SPA) implementation

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports i586
Package name fwknop
Package version 2.6.5
Package release alt1_2
Package architecture i586
Package type rpm
Installed size 432.00 KB
Download size 432.00 KB
Official Mirror ftp.altlinux.org
fwknop implements an authorization scheme known as Single Packet
Authorization (SPA) that requires only a single encrypted packet to
communicate various pieces of information including desired access through an
iptables policy and/or specific commands to execute on the target system.
The main application of this program is to protect services such as SSH with
an additional layer of security in order to make the exploitation of
vulnerabilities (both 0-day and unpatched code) much more difficult.  The
authorization server passively monitors authorization packets via libpcap and
hence there is no "server" to which to connect in the traditional sense.  Any
service protected by fwknop is inaccessible (by using iptables to
intercept packets within the kernel) before authenticating; anyone scanning for
the service will not be able to detect that it is even listening.  This
authorization scheme offers many advantages over port knocking, include being
non-replayable, much more data can be communicated, and the scheme cannot be
broken by simply connecting to extraneous ports on the server in an effort to
break knock sequences.  The authorization packets can easily be spoofed as
well, and this makes it possible to make it appear as though, say,
www.yahoo.com is trying to authenticate to a target system but in reality the
actual connection will come from a seemingly unrelated IP. Although the
default data collection method is to use libpcap to sniff packets off the
wire, fwknop can also read packets out of a file that is written by the
iptables ulogd pcap writer or by a separate sniffer process.

Alternatives

Package Version Architecture Repository
fwknop-2.6.5-alt1_2.x86_64.rpm 2.6.5 x86_64 Autoimports
fwknop - - -

Requires

Name Value
/lib/ld-linux.so.2 -
/usr/sbin/post_service -
/usr/sbin/preun_service -
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.11) -
libc.so.6(GLIBC_2.15) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.2.5) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libc.so.6(GLIBC_2.7) -
libgpgme.so.11 -
libgpgme.so.11(GPGME_1.0) -
libgpgme.so.11(GPGME_1.1) -
libgpgme.so.11(GPGME_1.2) -
libpcap.so.0.8 -
logrotate -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -
systemd -

Provides

Name Value
fwknop = 2.6.5-alt1_2
libfko.so.2 -

Download

Type URL
Binary Package fwknop-2.6.5-alt1_2.i586.rpm
Source Package fwknop-2.6.5-alt1_2.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus i586 autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install fwknop rpm package:
    # sudo apt-get install fwknop

Files

Path
/etc/fwknop/access.conf
/etc/fwknop/fwknopd.conf
/lib/systemd/system/fwknopd.service
/usr/bin/fwknop
/usr/lib/libfko.so.2
/usr/lib/libfko.so.2.0.3
/usr/sbin/fwknopd
/usr/share/doc/fwknop-2.6.5/COPYING
/usr/share/doc/fwknop-2.6.5/CREDITS
/usr/share/doc/fwknop-2.6.5/ChangeLog
/usr/share/doc/fwknop-2.6.5/README
/usr/share/man/man8/fwknop.8.bz2
/usr/share/man/man8/fwknopd.8.bz2

See Also

Package Description
g-wrap-1.9.14-alt1_2.i586.rpm A tool for creating Scheme interfaces to C libraries
g-wrap-devel-1.9.14-alt1_2.i586.rpm Include files and libraries needed for g-wrap development
g2clib-devel-1.6.0-alt1_5.i586.rpm Development files for g2clib
galois-0.6-alt1_1.i586.rpm Extended falling blocks game with many different geometries
gambas1-gb-compress-1.0.19-alt1_17.i586.rpm Gambas component package for compress
gambas1-gb-db-1.0.19-alt1_17.i586.rpm Gambas component package for db
gambas1-gb-eval-1.0.19-alt1_17.i586.rpm Gambas component package for eval
gambas1-gb-net-1.0.19-alt1_17.i586.rpm Gambas component package for net
gambas1-gb-net-curl-1.0.19-alt1_17.i586.rpm Gambas component package for net.curl
gambas1-gb-qt-1.0.19-alt1_17.i586.rpm Gambas component package for qt
gambas1-gb-qt-editor-1.0.19-alt1_17.i586.rpm Gambas component package for qt.editor
gambas1-gb-qt-ext-1.0.19-alt1_17.i586.rpm Gambas component package for qt.ext
gambas1-gb-qt-kde-1.0.19-alt1_17.i586.rpm Gambas component package for qt.kde
gambas1-gb-qt-kde-html-1.0.19-alt1_17.i586.rpm Gambas component package for qt.kde.html
gambas1-gb-sdl-1.0.19-alt1_17.i586.rpm Gambas component package for sdl
Advertisement
Advertisement