g-wrap-devel-1.9.14-alt1_2.i586.rpm


Advertisement

Description

g-wrap-devel - Include files and libraries needed for g-wrap development

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports i586
Package name g-wrap-devel
Package version 1.9.14
Package release alt1_2
Package architecture i586
Package type rpm
Installed size 42.07 KB
Download size 42.07 KB
Official Mirror ftp.altlinux.org
g-wrap-devel contains development libraries and headers for g-wrap.
You can provide access to a given C API by creating a specification
file describing the interface you want published at the Scheme level.
g-wrap will handle generating all the lower level library interface
code so that the C library shows up as a set of Scheme functions.
You should install g-wrap-devel if you need to compile programs that
need to use g-wrap C<->Scheme functionality

Alternatives

Package Version Architecture Repository
g-wrap-devel-1.9.14-alt1_2.x86_64.rpm 1.9.14 x86_64 Autoimports
g-wrap-devel - - -

Requires

Name Value
/usr/lib/pkgconfig -
automake -
g-wrap = 1.9.14-alt1_2
guile18-devel -
libffi-devel -
libgmp-devel -
libltdl7-devel -
pkg-config -
pkgconfig(libffi) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
g-wrap-devel = 1.9.14-alt1_2
pkgconfig(g-wrap-2.0-guile) = 1.9.14

Download

Type URL
Binary Package g-wrap-devel-1.9.14-alt1_2.i586.rpm
Source Package g-wrap-1.9.14-alt1_2.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus i586 autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install g-wrap-devel rpm package:
    # sudo apt-get install g-wrap-devel

Files

Path
/usr/bin/g-wrap-config
/usr/include/g-wrap-wct.h
/usr/include/g-wrap/core-runtime.h
/usr/include/g-wrap/ffi-support.h
/usr/include/g-wrap/guile-compatibility.h
/usr/include/g-wrap/guile-runtime.h
/usr/include/g-wrap/guile-wct.h
/usr/lib/libgwrap-core-runtime.so
/usr/lib/libgwrap-guile-runtime.so
/usr/lib/g-wrap/modules/libgw-guile-gw-glib.so
/usr/lib/g-wrap/modules/libgw-guile-standard.so
/usr/lib/pkgconfig/g-wrap-2.0-guile.pc
/usr/share/aclocal/g-wrap.m4
/usr/share/info/g-wrap.info.bz2

See Also

Package Description
g2clib-devel-1.6.0-alt1_5.i586.rpm Development files for g2clib
galois-0.6-alt1_1.i586.rpm Extended falling blocks game with many different geometries
gambas1-gb-compress-1.0.19-alt1_17.i586.rpm Gambas component package for compress
gambas1-gb-db-1.0.19-alt1_17.i586.rpm Gambas component package for db
gambas1-gb-eval-1.0.19-alt1_17.i586.rpm Gambas component package for eval
gambas1-gb-net-1.0.19-alt1_17.i586.rpm Gambas component package for net
gambas1-gb-net-curl-1.0.19-alt1_17.i586.rpm Gambas component package for net.curl
gambas1-gb-qt-1.0.19-alt1_17.i586.rpm Gambas component package for qt
gambas1-gb-qt-editor-1.0.19-alt1_17.i586.rpm Gambas component package for qt.editor
gambas1-gb-qt-ext-1.0.19-alt1_17.i586.rpm Gambas component package for qt.ext
gambas1-gb-qt-kde-1.0.19-alt1_17.i586.rpm Gambas component package for qt.kde
gambas1-gb-qt-kde-html-1.0.19-alt1_17.i586.rpm Gambas component package for qt.kde.html
gambas1-gb-sdl-1.0.19-alt1_17.i586.rpm Gambas component package for sdl
gambas1-gb-vb-1.0.19-alt1_17.i586.rpm Gambas component package for vb
gambas1-gb-xml-libxml-1.0.19-alt1_17.i586.rpm Gambas component package for xml.libxml
Advertisement
Advertisement