perl-FFI-Platypus-Lang-CPP-0.04-alt1.1.i586.rpm


Advertisement

Description

perl-FFI-Platypus-Lang-CPP - Documentation and tools for using Platypus with the C++ programming language

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports i586
Package filename perl-FFI-Platypus-Lang-CPP-0.04-alt1.1.i586.rpm
Package name perl-FFI-Platypus-Lang-CPP
Package version 0.04
Package release alt1.1
Package architecture i586
Package type rpm
Category Development/Perl
Homepage -
License -
Maintainer -
Download size 41.67 KB
Installed size 41.67 KB
This module provides some hooks for Platypus so that C++ names can be
mangled for you.  It uses the same primitive types as C.  This document
also documents issues and caveats that I have discovered in my attempts
to work with C++ and FFI.
This module is somewhat experimental.  It is also available for adoption
for anyone either sufficiently knowledgable about C++ or eager enough to
learn enough about C++.  If you are interested, please send me a pull
request or two on the project's GitHub.
There are numerous difficulties and caveats involved in using C++
libraries from Perl via FFI.  This document is intended to enlighten on
that subject.
Note that in addition to using pre-compiled C++ libraries you can bundle
C++ code with your Perl distribution using the Module::Build::FFI manpage.  For a
complete example, which attempts to address the caveats listed below you
can take a look at this sample distro on GitHub:
https://github.com/plicease/Color-FFI

Alternatives

Package Version Architecture Repository
perl-FFI-Platypus-Lang-CPP-0.04-alt1.1.x86_64.rpm 0.04 x86_64 Autoimports
perl-FFI-Platypus-Lang-CPP - - -

Requires

Name Value
/usr/share/perl5 -
perl(FFI/ExtractSymbols.pm) -
perl(FFI/Platypus.pm) >= 0.180
perl(FFI/Platypus/Lang/C.pm) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(FFI/Platypus/Lang/CPP.pm) = 0.040
perl-FFI-Platypus-Lang-CPP = 0.04-alt1.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-FFI-Platypus-Lang-CPP-0.04-alt1.1.i586.rpm
Source Package perl-FFI-Platypus-Lang-CPP-0.04-alt1.1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus i586 autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-FFI-Platypus-Lang-CPP rpm package:
    # sudo apt-get install perl-FFI-Platypus-Lang-CPP

Files

Path
/usr/share/doc/perl-FFI-Platypus-Lang-CPP-0.04/Changes
/usr/share/doc/perl-FFI-Platypus-Lang-CPP-0.04/LICENSE
/usr/share/doc/perl-FFI-Platypus-Lang-CPP-0.04/README
/usr/share/doc/perl-FFI-Platypus-Lang-CPP-0.04/examples/basic.cpp
/usr/share/doc/perl-FFI-Platypus-Lang-CPP-0.04/examples/basic.pl
/usr/share/perl5/FFI/
/usr/share/perl5/FFI/Platypus/
/usr/share/perl5/FFI/Platypus/Lang/CPP.pm

See Also

Package Description
perl-FFI-Platypus-Lang-CPP-Demangle-XS-0.03-alt1.1.i586.rpm Demangle C++ symbols using the C++ ABI API
perl-FFI-Platypus-Legacy-Raw-0.06-alt1.i586.rpm Perl bindings to the portable FFI library (libffi)
perl-FFI-Raw-0.32-alt4.1.i586.rpm Perl bindings to the portable FFI library (libffi)
perl-FFI-Util-0.17-alt1.i586.rpm Some useful pointer utilities when writing FFI modules (Deprecated)
perl-FastSearch-1.0-alt4.1.i586.rpm perl module FastSearch
perl-Fcntl-Packer-0.03-alt4.1.i586.rpm Build packed structures for passing into fcntl
perl-Feersum-1.406-alt1.1.i586.rpm A PSGI engine for Perl based on EV/libev
perl-Feersum-scripts-1.406-alt1.1.i586.rpm Feersum scripts
perl-File-BSDGlob-0.94-alt4.1.i586.rpm Perl extension for BSD glob routine
perl-File-BSED-0.67-alt4.1.i586.rpm Search/Replace in Binary Files
perl-File-BSED-scripts-0.67-alt4.1.i586.rpm File-BSED scripts
perl-File-CachingFind-0.67-alt4.1.i586.rpm find files within cached search paths (e.g. include files)
perl-File-Checksum-0.01-alt4.1.i586.rpm perl module File-Checksum
perl-File-Defrag-0.03-alt4.1.i586.rpm perl module File-Defrag
perl-File-Defrag-scripts-0.03-alt4.1.i586.rpm File-Defrag scripts
Advertisement
Advertisement