perl-Lua-API-0.04-alt1.i586.rpm


Advertisement

Description

perl-Lua-API - interface to Lua's embedding API

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports i586
Package filename perl-Lua-API-0.04-alt1.i586.rpm
Package name perl-Lua-API
Package version 0.04
Package release alt1
Package architecture i586
Package type rpm
Category Development/Perl
Homepage -
License -
Maintainer -
Download size 299.56 KB
Installed size 299.56 KB
Lua is a simple, expressive, extension programming language that is
easily embeddable.  Lua::API provides Perl bindings to Lua's
C-based embedding API.  It allows Perl routines to be called from Lua
as if they were written in C, and allows Perl routines to directly
manipulate the Lua interpreter and its environment.  It presents a
very low-level interface (essentially equivalent to the C interface),
so is aimed at developers who need that sort of access.
Lua::API is not the first place to turn to if you need a simple, more
Perl-ish interface; for that, try Inline::Lua, which takes a much
higher level approach and masks most of the underlying complexity in
communicating between Lua and Perl.  Unfortunately by hiding the
complexity, this approach also prevents full operability.  For
Inline::Lua this is a necessary tradeoff, but it does mean that you
cannot create as tight an integration with Lua.

Alternatives

Package Version Architecture Repository
perl-Lua-API-0.04-alt1.x86_64.rpm 0.04 x86_64 Autoimports
perl-Lua-API - - -

Requires

Name Value
/usr/lib/perl5 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.4) -
liblua-5.1.so.0 -
libperl-5.28.so -
libpthread.so.0(GLIBC_2.0) -
perl(XSLoader.pm) >= 0.100
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
perl(Lua/API.pm) = 0.040
perl-Lua-API = 0.04-alt1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-Lua-API-0.04-alt1.i586.rpm
Source Package perl-Lua-API-0.04-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus i586 autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Lua-API rpm package:
    # sudo apt-get install perl-Lua-API

Files

Path
/usr/lib/perl5/Lua/API.pm
/usr/lib/perl5/Lua/bootstrap.pod
/usr/lib/perl5/auto/Lua/
/usr/lib/perl5/auto/Lua/API/API.so
/usr/share/doc/perl-Lua-API-0.04/ChangeLog
/usr/share/doc/perl-Lua-API-0.04/Changes
/usr/share/doc/perl-Lua-API-0.04/LICENSE
/usr/share/doc/perl-Lua-API-0.04/README
/usr/share/doc/perl-Lua-API-0.04/examples/lua.pl

See Also

Package Description
perl-Lucy-0.6.2-alt1.1.i586.rpm Apache Lucy search engine library
perl-Lufs-0.21-alt4.1.i586.rpm Perl plug for lufs
perl-MIDI-ALSA-1.22-alt2_5.i586.rpm ALSA library access for Perl, plus some interface functions
perl-MIDI-Music-0.01-alt4.1.i586.rpm Perl interface to /dev/music
perl-MMapDB-0.15-alt4.1.i586.rpm a simple database in shared memory
perl-MMapDB-scripts-0.15-alt4.1.i586.rpm MMapDB scripts
perl-MP3-Cut-Gapless-0.03-alt4.1.i586.rpm Split an MP3 file without gaps (based on pcutmp3)
perl-MP3-ID3Lib-0.12-alt4.1.i586.rpm ID3v1/ID3v2 Tagging of MP3 files
perl-MP3-Mplib-0.02-alt4.1.i586.rpm perl module MP3-Mplib
perl-Magical-Hooker-Decorate-0.03-alt4.1.i586.rpm Decorate an SV using magic hooks
perl-Mail-Box-Parser-C-3.010-alt3_4.i586.rpm Parsing folders for MailBox with C routines
perl-Mail-Summary-0.02-alt4.1.i586.rpm scan read your mail!
perl-Manip-END-0.08-alt4.1.i586.rpm perl module Manip-END
perl-Marpa-XS-1.008000-alt9_23.i586.rpm Language grammar parser module for Perl
perl-MarpaX-ESLIF-3.0.10-alt1.i586.rpm ESLIF is Extended ScanLess InterFace
Advertisement
Advertisement