perl-Net-AMQP-RabbitMQ-2.30000-alt1.i586.rpm


Advertisement

Description

perl-Net-AMQP-RabbitMQ - interact with RabbitMQ over AMQP using librabbitmq

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports i586
Package filename perl-Net-AMQP-RabbitMQ-2.30000-alt1.i586.rpm
Package name perl-Net-AMQP-RabbitMQ
Package version 2.30000
Package release alt1
Package architecture i586
Package type rpm
Category Development/Perl
Homepage -
License -
Maintainer -
Download size 236.28 KB
Installed size 236.28 KB
`Net::AMQP::RabbitMQ' provides a simple wrapper around the librabbitmq library
that allows connecting, declaring exchanges and queues, binding and unbinding
queues, publishing, consuming and receiving events.
Error handling in this module is primarily achieve by Perl_croak (die). You
should be making good use of eval around these methods to ensure that you
appropriately catch the errors.

Alternatives

Package Version Architecture Repository
perl-Net-AMQP-RabbitMQ-2.30000-alt1.x86_64.rpm 2.30000 x86_64 Autoimports
perl-Net-AMQP-RabbitMQ - - -

Requires

Name Value
/usr/lib/perl5 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libcrypto.so.1.1 -
libcrypto.so.1.1(OPENSSL_1_1_0) -
libperl-5.28.so -
libpthread.so.0(GLIBC_2.0) -
librt.so.1(GLIBC_2.2) -
libssl.so.1.1 -
libssl.so.1.1(OPENSSL_1_1_0) -
perl(Scalar/Util.pm) -
perl(XSLoader.pm) -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
perl(Net/AMQP/RabbitMQ.pm) = 2.300
perl-Net-AMQP-RabbitMQ = 2.30000-alt1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-Net-AMQP-RabbitMQ-2.30000-alt1.i586.rpm
Source Package perl-Net-AMQP-RabbitMQ-2.30000-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus i586 autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Net-AMQP-RabbitMQ rpm package:
    # sudo apt-get install perl-Net-AMQP-RabbitMQ

Files

Path
/usr/lib/perl5/Net/
/usr/lib/perl5/Net/AMQP/RabbitMQ.pm
/usr/lib/perl5/auto/Net/
/usr/lib/perl5/auto/Net/AMQP/
/usr/lib/perl5/auto/Net/AMQP/RabbitMQ/RabbitMQ.so
/usr/share/doc/perl-Net-AMQP-RabbitMQ-2.30000/Changes
/usr/share/doc/perl-Net-AMQP-RabbitMQ-2.30000/LICENSE
/usr/share/doc/perl-Net-AMQP-RabbitMQ-2.30000/LICENSE-MIT

See Also

Package Description
perl-Net-Bluetooth-0.41-alt3_10.i586.rpm Net::Bluetooth - Perl Bluetooth Interface
perl-Net-CIDR-Compare-0.03-alt4.1.i586.rpm perl module Net-CIDR-Compare
perl-Net-Connection-Sniffer-0.36-alt5.1.i586.rpm - gather stats on network connections
perl-Net-Curl-0.39-alt2.1.i586.rpm Perl interface for libcurl
perl-Net-DBus-GLib-0.33.0-alt10_30.i586.rpm Perl extension for the DBus GLib bindings
perl-Net-DNS-Native-0.20-alt1.1.i586.rpm non-blocking system DNS resolver
perl-Net-DirectConnect-TigerHash-0.09-alt3.1.i586.rpm Perl extension for calculating tiger hashes from files or strings
perl-Net-Fix-Checksum-XS-0.03-alt2.1.i586.rpm Fast FIX Checksum calculations from Perl
perl-Net-FreeDB-0.10-alt3.1.i586.rpm OOP Interface to FreeDB Server(s)
perl-Net-Gadu-1.9-alt3_20.i586.rpm Perl module to support Gadu-Gadu protocol
perl-Net-IP-CMatch-0.02-alt9_37.i586.rpm Efficiently match IP addresses against IP ranges with C
perl-Net-IP-Match-Bin-0.14-alt4.1.i586.rpm Perl extension for match IP addresses against Net ranges
perl-Net-IP-Match-Trie-1.00-alt4.1.i586.rpm Efficiently match IP addresses against IP ranges with Trie (prefix tree)
perl-Net-IP-Match-XS-0.03-alt4.1.i586.rpm perl module Net-IP-Match-XS
perl-Net-IP-Util-1.03-alt4.1.i586.rpm perl module Net-IP-Util
Advertisement
Advertisement