perl-threads-lite-0.034-alt6_18.i586.rpm


Advertisement

Description

perl-threads-lite - Actor model threading for Perl

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports i586
Package filename perl-threads-lite-0.034-alt6_18.i586.rpm
Package name perl-threads-lite
Package version 0.034
Package release alt6_18
Package architecture i586
Package type rpm
Category Development/Other
Homepage -
License -
Maintainer -
Download size 83.33 KB
Installed size 83.33 KB
This module implements threads for perl. One crucial difference with
threads.pm threads is that the threads are disconnected, except by message
queues. It thus facilitates a message passing style of multi-threading.

Alternatives

Package Version Architecture Repository
perl-threads-lite-0.034-alt6_18.x86_64.rpm 0.034 x86_64 Autoimports
perl-threads-lite - - -

Requires

Name Value
/usr/lib/perl5 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.11) -
libc.so.6(GLIBC_2.4) -
libperl-5.28.so -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.3.2) -
perl(Scalar/Util.pm) -
perl(Storable.pm) >= 2.050
perl(XSLoader.pm) -
perl(constant.pm) -
perl(experimental.pm) -
perl(feature.pm) -
perl(overload.pm) -
perl-base >= 1:5.10.1
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
perl(threads/lite.pm) = 0.034
perl(threads/lite/list.pm) = 0.034
perl(threads/lite/queue.pm) = 0.034
perl(threads/lite/tid.pm) = 0.034
perl-threads-lite = 0.034-alt6_18

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-threads-lite-0.034-alt6_18.i586.rpm
Source Package perl-threads-lite-0.034-alt6_18.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus i586 autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-threads-lite rpm package:
    # sudo apt-get install perl-threads-lite

Files

Path
/usr/lib/perl5/auto/threads/
/usr/lib/perl5/auto/threads/lite/lite.so
/usr/lib/perl5/threads/lite.pm
/usr/lib/perl5/threads/lite/list.pm
/usr/lib/perl5/threads/lite/queue.pm
/usr/lib/perl5/threads/lite/tid.pm
/usr/share/doc/perl-threads-lite-0.034/Changes
/usr/share/doc/perl-threads-lite-0.034/LICENSE
/usr/share/doc/perl-threads-lite-0.034/README
/usr/share/doc/perl-threads-lite-0.034/examples/chameneos
/usr/share/doc/perl-threads-lite-0.034/examples/reader.pl

See Also

Package Description
perl-threads-posix-0.003-alt3.1.i586.rpm more POSIX correct threads
perl-true-1.0.1-alt1_3.i586.rpm Automatically return a true value when a file is required
perl-uplug-main-0.3.8-alt3.1.i586.rpm a toolbox for processing (parallel) text corpora
perl-uplug-main-scripts-0.3.8-alt3.1.i586.rpm uplug-main scripts
perl-warnings-unused-0.06-alt4.1.i586.rpm Produces warnings when unused variables are detected
pgdbf-0.6.2-alt1_6.i586.rpm Convert XBase / FoxPro databases to PostgreSQL
pgsphere-1.1.1-alt1_22.i586.rpm Spherical data types, functions, and operators for PostgreSQL
phalanx-22-alt1_14.i586.rpm A Chess Engine
photoqt-1.7.1-alt1_4.i586.rpm A fast Qt image viewer
pianobooster-0.6.4b-alt1_21.i586.rpm A MIDI file player that teaches you how to play the piano
picprog-1.9.1-alt1_12.i586.rpm Microchip PIC serial programmer software
pidgin-awayonlock-0.5.2-alt1_5.i586.rpm Away-on-Lock is simple plugin for Pidgin
pidgin-chime-1.2-alt1_2.i586.rpm Pidgin/libpurple protocol plugin for Amazon Chime
pidgin-gpg-0.9-alt1_8.i586.rpm GPG plugin for pidgin
pidgin-groupchat-typing-notifications-3-alt1_3.i586.rpm Adds typing notifications for group chats in Pidgin
Advertisement
Advertisement