easybashgui-6.0.1-alt1_1.noarch.rpm


Advertisement

Description

easybashgui - Bash function library

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package name easybashgui
Package version 6.0.1
Package release alt1_1
Package architecture noarch
Package type rpm
Installed size 277.83 KB
Download size 277.83 KB
Official Mirror ftp.altlinux.org
EasyBashGUI is a bash function library that aims to give simple GUI functions
using gtkdialog, kdialog, zenity, Xdialog, dialog, or whiptail depending on
KDE or GNOME running or not, Gtkdialog or Xdialog installed or not and X server
running or not ( (c)dialog or whiptail is the minimum ). So, if bash programmer
writes: "message 'Thanks for using this program' ", he has not to worry in which
environment his program runs: it is enough there is at least (c)dialog or
whiptail installed, and program will work as expected. Obviously, if user has
KDE, GNOME, or gtkdialog/Xdialog also installed ( and he's in a X session ),
program will have "an other look", but logical flow is *exactly* the same. In
EasyBashGUI "suite" there are a library ( "easybashgui_X.X.X" ), a script to
quick test it ( "easybashgui_test.sh" ), and a stand-alone script to create
dialog boxes externally ( "easydialog.sh" ).

Alternatives

Package Version Architecture Repository
easybashgui - - -

Requires

Name Value
/usr/bin/env -
Xdialog -
bash -
coreutils -
dialog -
grep -
kde4base-kdialog -
less -
rpmlib(PayloadIsLzma) -
termutils -
zenity -

Provides

Name Value
easybashgui = 6.0.1-alt1_1

Download

Type URL
Binary Package easybashgui-6.0.1-alt1_1.noarch.rpm
Source Package easybashgui-6.0.1-alt1_1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install easybashgui rpm package:
    # sudo apt-get install easybashgui

Files

Path
/usr/bin/easybashgui
/usr/bin/easydialog.sh
/usr/lib/easybashgui/easybashgui_6.0.1.lib
/usr/lib/easybashgui/easybashlib
/usr/share/doc/easybashgui-6.0.1/EasyBashGUI-license
/usr/share/doc/easybashgui-6.0.1/EasyBashGUI-readme
/usr/share/doc/easybashgui-6.0.1/easybashgui_test.sh
/usr/share/easybashgui/Attenzione.xpm
/usr/share/easybashgui/Ok.xpm

See Also

Package Description
echo-artist-0.1.1-alt1_15.noarch.rpm Automation tools for echo-icon-theme artists
editarea-0.8.2-alt1_15.noarch.rpm A replacement for the HTML textarea tag
edugraphe-1.1-alt1_13.noarch.rpm Graph editor written in Java
eg-1.7.5.2-alt1_17.noarch.rpm Git for mere mortals
egd-0.9-alt1_18.noarch.rpm Entropy Gathering Daemon
egoboo-data-2.8.1-alt1_7.noarch.rpm Data files for egoboo
egtk-common-4.0.6-alt1_1.noarch.rpm Files common to eGTK themes
egtk-gtk2-theme-4.0.6-alt1_1.noarch.rpm The eGTK theme for GTK+2
egtk-gtk3-theme-4.0.6-alt1_1.noarch.rpm The eGTK theme for GTK+3
egtk-metacity-theme-4.0.6-alt1_1.noarch.rpm The eGTK theme for Metacity
egtk-xfwm4-theme-3.1-alt1_1.noarch.rpm The eGTK theme for Xfwm4 (legacy)
emacs-htmlize-1.34-alt1_16.noarch.rpm Convert buffer text and decorations to HTML
emacs-htmlize-el-1.34-alt1_16.noarch.rpm Emacs Lisp source files for emacs-htmlize
emacs-irsim-mode-0.1-alt1_18.noarch.rpm Irsim mode for emacs
emacs-irsim-mode-el-0.1-alt1_18.noarch.rpm Source files for Emacs-irsim-mode under GNU Emacs
Advertisement
Advertisement