nodejs-request-2.67.0-alt1_12.noarch.rpm


Advertisement

Description

nodejs-request - Simplified HTTP request client

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package filename nodejs-request-2.67.0-alt1_12.noarch.rpm
Package name nodejs-request
Package version 2.67.0
Package release alt1_12
Package architecture noarch
Package type rpm
Category Development/Other
Homepage -
License -
Maintainer -
Download size 123.26 KB
Installed size 123.26 KB
Request is designed to be the simplest way possible to make HTTP calls. It
supports HTTPS and follows redirects by default.
You can stream any response to a file stream. You can also stream a file to a
PUT or POST request.  It also supports a few simple server and proxy functions.

Alternatives

Package Version Architecture Repository
nodejs-request - - -

Requires

Name Value
/usr/lib/node_modules/aws-sign2 -
/usr/lib/node_modules/bl -
/usr/lib/node_modules/caseless -
/usr/lib/node_modules/combined-stream -
/usr/lib/node_modules/extend -
/usr/lib/node_modules/forever-agent -
/usr/lib/node_modules/form-data -
/usr/lib/node_modules/har-validator -
/usr/lib/node_modules/hawk -
/usr/lib/node_modules/http-signature -
/usr/lib/node_modules/is-typedarray -
/usr/lib/node_modules/isstream -
/usr/lib/node_modules/json-stringify-safe -
/usr/lib/node_modules/mime-types -
/usr/lib/node_modules/node-uuid -
/usr/lib/node_modules/oauth-sign -
/usr/lib/node_modules/qs -
/usr/lib/node_modules/stringstream -
/usr/lib/node_modules/tough-cookie -
/usr/lib/node_modules/tunnel-agent -
nodejs(engine) >= 0.8.0
rpmlib(PayloadIsLzma) -

Provides

Name Value
nodejs-request = 2.67.0-alt1_12
npm(request) = 2.67.0

Download

Type URL
Mirror ftp.altlinux.org
Binary Package nodejs-request-2.67.0-alt1_12.noarch.rpm
Source Package nodejs-request-2.67.0-alt1_12.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install nodejs-request rpm package:
    # sudo apt-get install nodejs-request

Files

Path
/usr/lib/node_modules/request/index.js
/usr/lib/node_modules/request/package.json
/usr/lib/node_modules/request/request.js
/usr/lib/node_modules/request/lib/auth.js
/usr/lib/node_modules/request/lib/cookies.js
/usr/lib/node_modules/request/lib/getProxyFromURI.js
/usr/lib/node_modules/request/lib/har.js
/usr/lib/node_modules/request/lib/helpers.js
/usr/lib/node_modules/request/lib/multipart.js
/usr/lib/node_modules/request/lib/oauth.js
/usr/lib/node_modules/request/lib/querystring.js
/usr/lib/node_modules/request/lib/redirect.js
/usr/lib/node_modules/request/lib/tunnel.js
/usr/lib/node_modules/request/node_modules/aws-sign2
/usr/lib/node_modules/request/node_modules/bl
/usr/lib/node_modules/request/node_modules/caseless
/usr/lib/node_modules/request/node_modules/combined-stream
/usr/lib/node_modules/request/node_modules/extend
/usr/lib/node_modules/request/node_modules/forever-agent
/usr/lib/node_modules/request/node_modules/form-data
/usr/lib/node_modules/request/node_modules/har-validator
/usr/lib/node_modules/request/node_modules/hawk
/usr/lib/node_modules/request/node_modules/http-signature
/usr/lib/node_modules/request/node_modules/is-typedarray
/usr/lib/node_modules/request/node_modules/isstream
/usr/lib/node_modules/request/node_modules/json-stringify-safe
/usr/lib/node_modules/request/node_modules/mime-types
/usr/lib/node_modules/request/node_modules/node-uuid
/usr/lib/node_modules/request/node_modules/oauth-sign
/usr/lib/node_modules/request/node_modules/qs
/usr/lib/node_modules/request/node_modules/stringstream
/usr/lib/node_modules/request/node_modules/tough-cookie
/usr/lib/node_modules/request/node_modules/tunnel-agent
/usr/share/doc/nodejs-request-2.67.0/LICENSE
/usr/share/doc/nodejs-request-2.67.0/README.md

See Also

Package Description
nodejs-requestretry-1.4.0-alt1_7.noarch.rpm Request-retry wrap nodejs request to retry http(s) requests in case of error
nodejs-require-all-2.0.0-alt1_7.noarch.rpm Require all files within a directory
nodejs-require-cs-0.4.4-alt1_10.noarch.rpm An AMD loader plugin for CoffeeScript
nodejs-require-directory-2.1.1-alt1_7.noarch.rpm Recursively iterates over specified directory, require()'ing each file
nodejs-require-inject-1.2.0-alt1_7.noarch.rpm A simple mock injector needing no instrumentation in the libraries being tested
nodejs-require-main-filename-1.0.1-alt1_3.noarch.rpm Shim for require.main.filename() that works in as many environments as possible
nodejs-require-relative-0.8.7-alt1_3.noarch.rpm Require and resolve modules relative to a path of your choice
nodejs-require-uncached-1.0.3-alt1_6.noarch.rpm Require a module bypassing the cache
nodejs-require-yaml-0.0.1-alt1_6.noarch.rpm Lets you load YAML/YML files using require syntax
nodejs-requirejs-2.1.11-alt1_10.noarch.rpm Node.js adapter for RequireJS, for loading AMD modules
nodejs-resolve-1.7.1-alt1_3.noarch.rpm Resolve like require.resolve() on behalf of files asynchronously/synchronously
nodejs-resolve-cwd-2.0.0-alt1_5.noarch.rpm Like require.resolve() but from current working directory
nodejs-resolve-from-4.0.0-alt1_4.noarch.rpm Resolve the path of a module like require.resolve() but from a given path
nodejs-resolve-pkg-1.0.0-alt1_5.noarch.rpm Resolve the path of a package regardless of it having an entry
nodejs-resolve-url-0.2.1-alt1_4.noarch.rpm Like Node.jsa.' `path.resolve`/`url.resolve` for the browser
Advertisement
Advertisement