perl-Acme-Beamerang-Logger-0.001000-alt1.noarch.rpm


Advertisement

Description

perl-Acme-Beamerang-Logger - A Simple per-class clan warnlogger loader

Distribution: ALT Linux Sisyphus
Repository: Autoimports noarch
Package name: perl-Acme-Beamerang-Logger
Package version: 0.001000
Package release: alt1
Package architecture: noarch
Package type: rpm
Installed size: 4.64 KB
Download size: 4.64 KB
Official Mirror: ftp.altlinux.org
This class is a convenience layer to tie the Log::Contextual::WarnLogger::Fancy manpage into the `Acme::Beamerang' project space. This is very experiemental and is a research project ( hence `Acme::' ). This would otherwise be part of the other `Acme::Beamerang' things that are still yet to materialise, but the inversion control this project entails means directly coupling this component with either of those parts would lead to a dependency graph that would defeat the point of the control inversion. This tool otherwise loads up `Log::Contextual' with a nice default logger, with all the glue in place to be convenient for this project, while still having an open door to a real logger.

Alternatives

Requires

Provides

  • perl(Acme/Beamerang/Logger.pm) = 0.001
  • perl-Acme-Beamerang-Logger = 0.001000-alt1

    Install Howto

    1. Add the following line to /etc/apt/sources.list:
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
      
    2. Update the package index:
      # sudo apt-get update
    3. Install perl-Acme-Beamerang-Logger rpm package:
      # sudo apt-get install perl-Acme-Beamerang-Logger

    Files

    • /usr/share/doc/perl-Acme-Beamerang-Logger-0.001000/Changes
    • /usr/share/perl5/Acme/
    • /usr/share/perl5/Acme/Beamerang/Logger.pm
    Advertisement
    Advertisement