perl-Acme-Cant-0.01-alt1.noarch.rpm


Advertisement

Description

perl-Acme-Cant - Determine whether your object can B<NOT> call a given method

Distribution: ALT Linux Sisyphus
Repository: Autoimports noarch
Package name: perl-Acme-Cant
Package version: 0.01
Package release: alt1
Package architecture: noarch
Package type: rpm
Installed size: 2.70 KB
Download size: 2.70 KB
Official Mirror: ftp.altlinux.org
This module allows a programer to determine whether on not their objects have the ability to call a given method. This sort of test can be useful to programatically enforce interface implementation. This allows for much cleaner code than using unless and can.

Alternatives

Requires

Provides

  • perl(Acme/Can/t.pm)
  • perl-Acme-Cant = 0.01-alt1

    Install Howto

    1. Add the following line to /etc/apt/sources.list:
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
      
    2. Update the package index:
      # sudo apt-get update
    3. Install perl-Acme-Cant rpm package:
      # sudo apt-get install perl-Acme-Cant

    Files

    • /usr/share/doc/perl-Acme-Cant-0.01/Changes
    • /usr/share/doc/perl-Acme-Cant-0.01/README
    • /usr/share/perl5/Acme/
    • /usr/share/perl5/Acme/Can/t.pm
    Advertisement
    Advertisement