perl-Acme-UseStrict-1.235-alt1.noarch.rpm


Advertisement

Description

perl-Acme-UseStrict - use strict constantly

Distribution: ALT Linux Sisyphus
Repository: Autoimports noarch
Package name: perl-Acme-UseStrict
Package version: 1.235
Package release: alt1
Package architecture: noarch
Package type: rpm
Installed size: 25.09 KB
Download size: 25.09 KB
Official Mirror: ftp.altlinux.org
ECMAScript 5.1 (i.e. Javascript) introduces a "strict mode" similar in.spirit to Perl's strict mode. Usually you enable Perl's strict mode like this: use strict; But in ECMAScript it must be a quoted string: "use strict"; It is received wisdom that Perl has an ugly syntax, so it naturally follows that any change to make Perl's syntax closer to Javascript will be welcome. This module allows you use use strict by simply including the string constant "use strict" anywhere in a scope. sub do_stuff { warn "use strict"; *{"do_more_stuff"} = sub { }; # dies because of strict refs. }

Alternatives

Requires

Provides

  • perl(Acme/UseStrict.pm) = 1.235
  • perl-Acme-UseStrict = 1.235-alt1

    Install Howto

    1. Add the following line to /etc/apt/sources.list:
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
      
    2. Update the package index:
      # sudo apt-get update
    3. Install perl-Acme-UseStrict rpm package:
      # sudo apt-get install perl-Acme-UseStrict

    Files

    • /usr/share/doc/perl-Acme-UseStrict-1.235/COPYRIGHT
    • /usr/share/doc/perl-Acme-UseStrict-1.235/Changes
    • /usr/share/doc/perl-Acme-UseStrict-1.235/LICENSE
    • /usr/share/doc/perl-Acme-UseStrict-1.235/README
    • /usr/share/perl5/Acme/UseStrict.pm
    Advertisement
    Advertisement