perl-Acme-Web20-Validator-0.01-alt1.noarch.rpm


Advertisement

Description

perl-Acme-Web20-Validator - Web 2.0 Validation

Distribution: ALT Linux Sisyphus
Repository: Autoimports noarch
Package name: perl-Acme-Web20-Validator
Package version: 0.01
Package release: alt1
Package architecture: noarch
Package type: rpm
Installed size: 12.87 KB
Download size: 12.87 KB
Official Mirror: ftp.altlinux.org
Acme::Web20::Validator is a Web 2.0 Validation module for your website. This module is inspired from Web 2.0 Validator (http://web2.0validator.com/). The definition of web 2.0 changes on a daily basis but currently supports are: UsePrototype UseCatalyst UseRails MentionsWeb20 UseLighttpd HasAnyFeeds ReferToDelicious XHtmlStrict UseCSS UseFeedBurner HasTrackbackURI And the Rule is also pluggable with Module::Pluggable, so you can add any rules by yourself. For example: package Acme::Web20::Validator::Rule::MyRule; use strict; use warnings; use base qw (Acme::Web20::Validator::Rule); __PACKAGE__->name('Your rule's description'); sub validate { my $self = shift; my $res = shift; ## HTTP::Response via LWP ... $self->is_ok(1) if ...; } 1;

Alternatives

Provides

  • perl(Acme/Web20/Validator.pm) = 0.010
  • perl(Acme/Web20/Validator/Rule.pm)
  • perl(Acme/Web20/Validator/Rule/HasAnyFeeds.pm)
  • perl(Acme/Web20/Validator/Rule/HasTrackbackURI.pm)
  • perl(Acme/Web20/Validator/Rule/MentionsWeb20.pm)
  • perl(Acme/Web20/Validator/Rule/ReferToDelicious.pm)
  • perl(Acme/Web20/Validator/Rule/UseCSS.pm)
  • perl(Acme/Web20/Validator/Rule/UseCatalyst.pm)
  • perl(Acme/Web20/Validator/Rule/UseFeedBurner.pm)
  • perl(Acme/Web20/Validator/Rule/UseLighttpd.pm)
  • perl(Acme/Web20/Validator/Rule/UsePrototype.pm)
  • perl(Acme/Web20/Validator/Rule/UseRails.pm)
  • perl(Acme/Web20/Validator/Rule/XHtmlStrict.pm)
  • perl-Acme-Web20-Validator = 0.01-alt1

    Install Howto

    1. Add the following line to /etc/apt/sources.list:
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
      
    2. Update the package index:
      # sudo apt-get update
    3. Install perl-Acme-Web20-Validator rpm package:
      # sudo apt-get install perl-Acme-Web20-Validator

    Files

    • /usr/share/doc/perl-Acme-Web20-Validator-0.01/Changes
    • /usr/share/doc/perl-Acme-Web20-Validator-0.01/README
    • /usr/share/perl5/Acme/
    • /usr/share/perl5/Acme/Web20/Validator.pm
    • /usr/share/perl5/Acme/Web20/Validator/Rule.pm
    • /usr/share/perl5/Acme/Web20/Validator/Rule/HasAnyFeeds.pm
    • /usr/share/perl5/Acme/Web20/Validator/Rule/HasTrackbackURI.pm
    • /usr/share/perl5/Acme/Web20/Validator/Rule/MentionsWeb20.pm
    • /usr/share/perl5/Acme/Web20/Validator/Rule/ReferToDelicious.pm
    • /usr/share/perl5/Acme/Web20/Validator/Rule/UseCSS.pm
    • /usr/share/perl5/Acme/Web20/Validator/Rule/UseCatalyst.pm
    • /usr/share/perl5/Acme/Web20/Validator/Rule/UseFeedBurner.pm
    • /usr/share/perl5/Acme/Web20/Validator/Rule/UseLighttpd.pm
    • /usr/share/perl5/Acme/Web20/Validator/Rule/UsePrototype.pm
    • /usr/share/perl5/Acme/Web20/Validator/Rule/UseRails.pm
    • /usr/share/perl5/Acme/Web20/Validator/Rule/XHtmlStrict.pm
    Advertisement
    Advertisement