perl-Alvis-NLPPlatform-0.6-alt1.noarch.rpm


Advertisement

Description

perl-Alvis-NLPPlatform - Perl extension for linguistically annotating XML documents in Alvis

Distribution: ALT Linux Sisyphus
Repository: Autoimports noarch
Package name: perl-Alvis-NLPPlatform
Package version: 0.6
Package release: alt1
Package architecture: noarch
Package type: rpm
Installed size: 331.75 KB
Download size: 331.75 KB
Official Mirror: ftp.altlinux.org
This module is the main part of the Alvis NLP platform. It provides overall methods for the linguistic annotation of web documents. Linguistic annotations depend on the configuration variables and dependencies between linguistic steps. Input documents are assumed to be in the ALVIS XML format (`standalone_main') or to be loaded in a hashtable (`client_main'). The annotated document is recorded in the given descriptor (`standalone_main') or returned as a hashtable (`client_main'). The ALVIS format is described here: http://www.alvis.info/alvis/Architecture_2fFormats?action=show&redirect=architecture%2Fformats#documents The DTD and XSD are provied in etc/alvis-nlpplatform.

Alternatives

Provides

  • perl(Alvis/NLPPlatform.pm) = 0.600
  • perl(Alvis/NLPPlatform/Annotation.pm) = 0.600
  • perl(Alvis/NLPPlatform/Canonical.pm) = 0.600
  • perl(Alvis/NLPPlatform/Convert.pm) = 0.600
  • perl(Alvis/NLPPlatform/Document.pm) = 0.600
  • perl(Alvis/NLPPlatform/MyReceiver.pm) = 0.600
  • perl(Alvis/NLPPlatform/NLPWrappers.pm) = 0.600
  • perl(Alvis/NLPPlatform/ParseConstituents.pm) = 0.600
  • perl(Alvis/NLPPlatform/UserNLPWrappers-template.pm)
  • perl(Alvis/NLPPlatform/UserNLPWrappers.pm) = 0.600
  • perl(Alvis/NLPPlatform/XMLEntities.pm) = 0.600
  • perl-Alvis-NLPPlatform = 0.6-alt1

    Install Howto

    1. Add the following line to /etc/apt/sources.list:
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
      
    2. Update the package index:
      # sudo apt-get update
    3. Install perl-Alvis-NLPPlatform rpm package:
      # sudo apt-get install perl-Alvis-NLPPlatform

    Files

    • /usr/share/doc/perl-Alvis-NLPPlatform-0.6/Changes
    • /usr/share/doc/perl-Alvis-NLPPlatform-0.6/LICENSE
    • /usr/share/doc/perl-Alvis-NLPPlatform-0.6/README
    • /usr/share/doc/perl-Alvis-NLPPlatform-0.6/TODO
    • /usr/share/doc/perl-Alvis-NLPPlatform-0.6/examples/InputDocument.xml
    • /usr/share/doc/perl-Alvis-NLPPlatform-0.6/examples/NLP-standalone
    • /usr/share/doc/perl-Alvis-NLPPlatform-0.6/examples/load_config
    • /usr/share/doc/perl-Alvis-NLPPlatform-0.6/examples/nlpplatform-test.rc
    • /usr/share/perl5/Alvis/NLPPlatform.pm
    • /usr/share/perl5/Alvis/NLPPlatform/Annotation.pm
    • /usr/share/perl5/Alvis/NLPPlatform/Canonical.pm
    • /usr/share/perl5/Alvis/NLPPlatform/Convert.pm
    • /usr/share/perl5/Alvis/NLPPlatform/Document.pm
    • /usr/share/perl5/Alvis/NLPPlatform/MyReceiver.pm
    • /usr/share/perl5/Alvis/NLPPlatform/NLPWrappers.pm
    • /usr/share/perl5/Alvis/NLPPlatform/ParseConstituents.pm
    • /usr/share/perl5/Alvis/NLPPlatform/UserNLPWrappers-template.pm
    • /usr/share/perl5/Alvis/NLPPlatform/UserNLPWrappers.pm
    • /usr/share/perl5/Alvis/NLPPlatform/XMLEntities.pm
    Advertisement
    Advertisement