perl-Any-Renderer-1.014-alt1.noarch.rpm


Advertisement

Description

perl-Any-Renderer - Common API for modules that convert data structures into strings

Distribution: ALT Linux Sisyphus
Repository: Autoimports noarch
Package name: perl-Any-Renderer
Package version: 1.014
Package release: alt1
Package architecture: noarch
Package type: rpm
Installed size: 65.14 KB
Download size: 65.14 KB
Official Mirror: ftp.altlinux.org
A renderer in this context is something that turns a data structure into a string. This includes templating engines, serialisers etc. This module provides a consistent API to these services so that your application can generate output in an extensible variety of formats. Formats currently supported include: _- XML (via XML::Simple) _- XML+XSLT _- Data::Dumper _- Javascript, Javascript::Anon & JSON _- UrlEncoded _- The formats supported by Data::Serializer (e.g. Config::General and Config::Wrest) _- Any templating language supported by Any::Template The module will discover any backend modules and offer up their formats. Once loaded, Any::Renderer will look for a module to handle any new formats it doesn't know about, so adding new formats in a persistent environment won't require the module to be reloaded. However if you CHANGE which module provides a format you will need to reload Any::Renderer (e.g. send a SIGHUP to modperl).

Alternatives

Provides

  • perl(Any/Renderer.pm) = 1.014
  • perl(Any/Renderer/Data/Dumper.pm) = 1.009
  • perl(Any/Renderer/Data/Serializer.pm) = 1.005
  • perl(Any/Renderer/JavaScript.pm) = 1.008
  • perl(Any/Renderer/JavaScript/Anon.pm) = 1.009
  • perl(Any/Renderer/Template.pm) = 1.021
  • perl(Any/Renderer/UrlEncoded.pm) = 1.011
  • perl(Any/Renderer/XML.pm) = 1.008
  • perl(Any/Renderer/XSLT.pm) = 1.014
  • perl-Any-Renderer = 1.014-alt1

    Install Howto

    1. Add the following line to /etc/apt/sources.list:
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
      
    2. Update the package index:
      # sudo apt-get update
    3. Install perl-Any-Renderer rpm package:
      # sudo apt-get install perl-Any-Renderer

    Files

    • /usr/share/doc/perl-Any-Renderer-1.014/COPYING
    • /usr/share/doc/perl-Any-Renderer-1.014/Changes
    • /usr/share/doc/perl-Any-Renderer-1.014/README
    • /usr/share/perl5/Any/Renderer.pm
    • /usr/share/perl5/Any/Renderer/JavaScript.pm
    • /usr/share/perl5/Any/Renderer/Template.pm
    • /usr/share/perl5/Any/Renderer/UrlEncoded.pm
    • /usr/share/perl5/Any/Renderer/XML.pm
    • /usr/share/perl5/Any/Renderer/XSLT.pm
    • /usr/share/perl5/Any/Renderer/Data/Dumper.pm
    • /usr/share/perl5/Any/Renderer/Data/Serializer.pm
    • /usr/share/perl5/Any/Renderer/JavaScript/Anon.pm
    Advertisement
    Advertisement