perl-AnyLoader-0.04-alt1.noarch.rpm


Advertisement

Description

perl-AnyLoader - Automagically loads modules for fully qualified functions

Distribution: ALT Linux Sisyphus
Repository: Autoimports noarch
Package name: perl-AnyLoader
Package version: 0.04
Package release: alt1
Package architecture: noarch
Package type: rpm
Installed size: 4.95 KB
Download size: 4.95 KB
Official Mirror: ftp.altlinux.org
AnyLoader will automagically load the module and import the function.for any fully qualified function call. Essentially, this means you can just call functions without worrying about loading the module first. In the example above, AnyLoader does the equivalent of "require Carp" before the call to Carp::carp(). This should be useful for the many cases where one does: if($error) { require Carp; Carp::croak($error); } to avoid loading Carp at startup. AnyLoader is package scoped.

Alternatives

Requires

Provides

  • perl(AnyLoader.pm) = 0.040
  • perl-AnyLoader = 0.04-alt1

    Install Howto

    1. Add the following line to /etc/apt/sources.list:
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
      
    2. Update the package index:
      # sudo apt-get update
    3. Install perl-AnyLoader rpm package:
      # sudo apt-get install perl-AnyLoader

    Files

    • /usr/share/doc/perl-AnyLoader-0.04/Changes
    • /usr/share/perl5/AnyLoader.pm
    Advertisement
    Advertisement