perl-App-EUMM-Upgrade-1.0-alt1.noarch.rpm


Advertisement

Description

perl-App-EUMM-Upgrade - Perl tool to upgrade ExtUtils::MakeMaker-based Makefile.PL

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package filename perl-App-EUMM-Upgrade-1.0-alt1.noarch.rpm
Package name perl-App-EUMM-Upgrade
Package version 1.0
Package release alt1
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage -
License -
Maintainer -
Download size 20.32 KB
Installed size 20.32 KB
eumm-upgrade is a tool to allow using new features of ExtUtils::MakeMaker without losing.
compatibility with older versions. It adds compatibility code to Makefile.PL and
tries to automatically detect some properties like license, minimum Perl version required and
repository used.
Just run eumm-upgrade.pl in directory with Makefile.PL. Old file will be copied to Makefile.PL.bak.
If you use Github, Internet connection is required.
You need to check resulting Makefile.PL manually as transformation is done
with regular expressions.
If you need to declare number of spaces in indent in Makefile.PL, use following string at start of
it (set 'c-basic-offset' to your value):

Alternatives

Package Version Architecture Repository
perl-App-EUMM-Upgrade - - -

Requires

Name Value
/usr/share/perl5 -
perl(File/Slurp.pm) -
perl(Getopt/Long.pm) -
perl(List/Util.pm) -
perl(Perl/Meta.pm) >= 0.030
perl(Text/FindIndent.pm) >= 0.080
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(App/EUMM/Upgrade.pm) = 1.0
perl(App/EUMM/eumm-upgrade.pl) -
perl-App-EUMM-Upgrade = 1.0-alt1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-App-EUMM-Upgrade-1.0-alt1.noarch.rpm
Source Package perl-App-EUMM-Upgrade-1.0-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-App-EUMM-Upgrade rpm package:
    # sudo apt-get install perl-App-EUMM-Upgrade

Files

Path
/usr/share/doc/perl-App-EUMM-Upgrade-1.0/Changes
/usr/share/doc/perl-App-EUMM-Upgrade-1.0/README
/usr/share/perl5/App/
/usr/share/perl5/App/EUMM/Upgrade.pm
/usr/share/perl5/App/EUMM/eumm-upgrade.pl

See Also

Package Description
perl-App-EUMM-Upgrade-scripts-1.0-alt1.noarch.rpm App-EUMM-Upgrade scripts
perl-App-Edge-0.03-alt1.noarch.rpm show the edge of logs with conditional grep
perl-App-Edge-scripts-0.03-alt1.noarch.rpm App-Edge scripts
perl-App-EditorTools-1.00-alt1.noarch.rpm Command line tool for Perl code refactoring
perl-App-EditorTools-scripts-1.00-alt1.noarch.rpm App-EditorTools scripts
perl-App-Eduard-0.001002-alt1.noarch.rpm GnuPG email sign/encrypt testing bot
perl-App-Eduard-scripts-0.001002-alt1.noarch.rpm perl-App-Eduard scripts
perl-App-Egaz-0.2.4-alt1.noarch.rpm Backend of B<E>asy B<G>enome B<A>ligner
perl-App-ElasticSearch-Utilities-7.3-alt1.noarch.rpm perl module App-ElasticSearch-Utilities
perl-App-ElasticSearch-Utilities-scripts-7.3-alt1.noarch.rpm App-ElasticSearch-Utilities scripts
perl-App-Elog-0.07-alt1.noarch.rpm An Apache error log viewer
perl-App-Env-0.34-alt1.noarch.rpm manage application specific environments
perl-App-Env-scripts-0.34-alt1.noarch.rpm App-Env scripts
perl-App-Environ-0.22-alt1.noarch.rpm Simple environment to build applications using service locator pattern
perl-App-Environ-ClickHouse-0.2-alt1.noarch.rpm get instance of HTTP::ClickHouse in App::Environ environment
Advertisement
Advertisement