perl-App-Module-Lister-0.15-alt1.noarch.rpm


Advertisement

Description

perl-App-Module-Lister - List the Perl modules in @INC

Distribution: ALT Linux Sisyphus
Repository: Autoimports noarch
Package name: perl-App-Module-Lister
Package version: 0.15
Package release: alt1
Package architecture: noarch
Package type: rpm
Installed size: 7.58 KB
Download size: 7.58 KB
Official Mirror: ftp.altlinux.org
This is a program to list all of the Perl modules it finds in `@INC' for a no-shell web hosting account. It has these explicit design goals: =over 4 =item * Is a single file FTP upload such that it's ready to run (no archives) =item * Runs as a CGI script =item * Runs on a standard Perl 5.004 system with no non-core modules =item * Does not use CPAN.pm (which can't easly be configured without the shell) =back If you have a shell account, you should just use `CPAN.pm''s autobundle feature. You do not need to install this module. You just need the `.pm' file. The rest of the distribution is there to help me give it to other people and test it. You might have to modify the shebang line (the first line in the file) to point to Perl. Your web hoster probably has instructions on what that should be. As shipped, this program uses the `env' trick described in the perlrun manpage. If that doesn't work for you, you'll probably see an error like: _ /usr/bin/env: bad interpreter: No such file or directory _ That's similar to the error you'll see if you have the wrong path to `perl'. The program searches each entry in `@INC' individually and outputs modules as it finds them.

Alternatives

Requires

Provides

  • perl(App/Module/Lister.pm) = 0.150
  • perl-App-Module-Lister = 0.15-alt1

    Install Howto

    1. Add the following line to /etc/apt/sources.list:
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
      
    2. Update the package index:
      # sudo apt-get update
    3. Install perl-App-Module-Lister rpm package:
      # sudo apt-get install perl-App-Module-Lister

    Files

    • /usr/share/doc/perl-App-Module-Lister-0.15/Changes
    • /usr/share/doc/perl-App-Module-Lister-0.15/LICENSE
    • /usr/share/doc/perl-App-Module-Lister-0.15/README
    • /usr/share/doc/perl-App-Module-Lister-0.15/examples/placeholder.pl
    • /usr/share/perl5/App/
    • /usr/share/perl5/App/Module/Lister.pm
    Advertisement
    Advertisement