perl-App-opan-0.002002-alt1.noarch.rpm


Advertisement

Description

perl-App-opan - A CPAN overlay for darkpan and pinning purposes

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package name perl-App-opan
Package version 0.002002
Package release alt1
Package architecture noarch
Package type rpm
Installed size 41.87 KB
Download size 41.87 KB
Official Mirror ftp.altlinux.org
Two basic approaches to using this thing. First, if you're using carton, you
can probably completely ignore the pinning system, so just do:
$ opan init
$ opan add ./My-DarkPan-Dist-1.23.tar.gz
$ git add pans/; git commit -m 'fresh opan'
$ opan carton install
You can reproduce this install with simply:
$ opan carton install --deployment
When you want to update to a new version of the cpan index (assuming you
already have an additional requirement that's too old in your current
snapshot):
$ opan pull
$ git add pans/; git commit -m 'update pans'
$ opan carton install
Second, if you're not using carton, but you want reproducible installs, you
can still mostly ignore the pinning system by doing:
$ opan init
$ opan add ./My-DarkPan-Dist-1.23.tar.gz
$ opan cpanm --autopin --installdeps .
$ git add pans/; git commit -m 'opan with current version pinning'
Your reproducible install is now:
$ opan cpanm --installdeps .
When you want to update to a new version of the cpan index (assuming you
already have an additional requirement that's too old in your current
snapshot):
$ opan pull
$ opan cpanm --autopin --installdeps .
$ git add pans/; git commit -m 'update pans'
To update a single dist in this system, the easy route is:
$ opan unpin Thingy-1.23.tar.gz
$ opan cpanm Thingy
Fetching http://www.cpan.org/authors/id/S/SO/SOMEONE/Thingy-1.25.tar.gz
...
$ opan pin SOMEONE/Thing-1.25.tar.gz
This will probably make more sense if you read the the Commands entry elsewhere in this document and the PANs entry elsewhere in this document
documentation following before trying to set things up.

Alternatives

Package Version Architecture Repository
perl-App-opan - - -

Requires

Name Value
/usr/bin/perl -
/usr/share/perl5 -
perl(Dist/Metadata.pm) >= 0.926
perl(File/Copy.pm) -
perl(File/Glob.pm) -
perl(File/Open.pm) >= 1.0.100
perl(File/Path.pm) -
perl(File/Spec.pm) -
perl(IPC/System/Simple.pm) >= 1.210
perl(Import/Into.pm) >= 1.002.004
perl(List/UtilsBy.pm) >= 0.090
perl(Mojo/File.pm) -
perl(Mojo/IOLoop/Server.pm) -
perl(Mojo/Util.pm) -
perl(Mojolicious/Lite.pm) -
perl(strictures.pm) >= 2.0
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(App/opan.pm) = 0.002.002
perl-App-opan = 0.002002-alt1

Download

Type URL
Binary Package perl-App-opan-0.002002-alt1.noarch.rpm
Source Package perl-App-opan-0.002002-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-App-opan rpm package:
    # sudo apt-get install perl-App-opan

Files

Path
/usr/bin/opan
/usr/share/doc/perl-App-opan-0.002002/Changes
/usr/share/doc/perl-App-opan-0.002002/README
/usr/share/man/man1/opan.1.xz
/usr/share/perl5/App/opan.pm

See Also

Package Description
perl-App-org2wp-0.007-alt1.noarch.rpm Publish Org document to WordPress as blog post
perl-App-orgdaemon-1.04-alt1.noarch.rpm watch for appointments in org-mode files
perl-App-orgsel-0.006-alt1.noarch.rpm Select Org document elements using CSel (CSS-selector-like) syntax
perl-App-osnames-0.10-alt1.noarch.rpm List possible $^O ($OSNAME) values
perl-App-osnames-scripts-0.10-alt1.noarch.rpm App-osnames scripts
perl-App-otfile-0.07-alt1.noarch.rpm Serve a single file, once, via HTTP over the local network
perl-App-otfile-scripts-0.07-alt1.noarch.rpm App-otfile scripts
perl-App-p-0.0400-alt1.noarch.rpm Steroids for your perl one-liners
perl-App-p-scripts-0.0400-alt1.noarch.rpm App-p scripts
perl-App-p5stack-0.004-alt1.noarch.rpm manage your dependencies and perl requirements locally
perl-App-p5stack-scripts-0.004-alt1.noarch.rpm App-p5stack scripts
perl-App-padconsole-0.11-alt1.noarch.rpm A console to manage your etherpad instance
perl-App-padconsole-scripts-0.11-alt1.noarch.rpm App-padconsole scripts
perl-App-palien-0.03-alt1.noarch.rpm Command line interface to Alien::Base
perl-App-palien-scripts-0.03-alt1.noarch.rpm App-palien scripts
Advertisement
Advertisement