perl-CGI-ValidOp-0.56-alt1.noarch.rpm


Advertisement

Description

perl-CGI-ValidOp - Simple validation of CGI parameters and runmodes

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package name perl-CGI-ValidOp
Package version 0.56
Package release alt1
Package architecture noarch
Package type rpm
Installed size 110.59 KB
Download size 110.59 KB
Official Mirror ftp.altlinux.org
CGI::ValidOp is a CGI parameter validator that also helps you manage runmodes.
Its aims are similar to Perl's: make the easy jobs easy and the complex jobs
possible.  CGI parameter validation is boring, and precisely for that reason
it's easy to get wrong or ignore.  CGI::ValidOp takes as much of the repetition
as possible out of this job, replacing it with a simple interface.

Alternatives

Package Version Architecture Repository
perl-CGI-ValidOp - - -

Requires

Name Value
/usr/bin/perl -
/usr/share/perl5 -
perl(CGI.pm) -
perl(Data/Dumper.pm) -
perl(HTML/Entities.pm) -
perl(Pod/Simple/HTMLBatch.pm) -
perl(Storable.pm) -
perl(Test/More.pm) -
perl(Test/Taint.pm) -
perl(base.pm) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(CGI/ValidOp.pm) = 0.560
perl(CGI/ValidOp/Base.pm) -
perl(CGI/ValidOp/Check.pm) -
perl(CGI/ValidOp/Check/alternative.pm) -
perl(CGI/ValidOp/Check/checkbox.pm) -
perl(CGI/ValidOp/Check/date.pm) -
perl(CGI/ValidOp/Check/demographics.pm) -
perl(CGI/ValidOp/Check/email.pm) -
perl(CGI/ValidOp/Check/length.pm) -
perl(CGI/ValidOp/Check/number.pm) -
perl(CGI/ValidOp/Check/required_if.pm) -
perl(CGI/ValidOp/Check/sql.pm) -
perl(CGI/ValidOp/Check/text.pm) -
perl(CGI/ValidOp/Object.pm) -
perl(CGI/ValidOp/Op.pm) -
perl(CGI/ValidOp/Param.pm) -
perl(CGI/ValidOp/Test.pm) -
perl(CGI/pod2html.pl) -
perl-CGI-ValidOp = 0.56-alt1

Download

Type URL
Binary Package perl-CGI-ValidOp-0.56-alt1.noarch.rpm
Source Package perl-CGI-ValidOp-0.56-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-CGI-ValidOp rpm package:
    # sudo apt-get install perl-CGI-ValidOp

Files

Path
/usr/share/doc/perl-CGI-ValidOp-0.56/Changes
/usr/share/doc/perl-CGI-ValidOp-0.56/LICENSE
/usr/share/doc/perl-CGI-ValidOp-0.56/README
/usr/share/doc/perl-CGI-ValidOp-0.56/TODO
/usr/share/perl5/CGI/ValidOp.pm
/usr/share/perl5/CGI/pod2html.pl
/usr/share/perl5/CGI/ValidOp/Base.pm
/usr/share/perl5/CGI/ValidOp/Check.pm
/usr/share/perl5/CGI/ValidOp/Object.pm
/usr/share/perl5/CGI/ValidOp/Op.pm
/usr/share/perl5/CGI/ValidOp/Param.pm
/usr/share/perl5/CGI/ValidOp/Test.pm
/usr/share/perl5/CGI/ValidOp/Check/alternative.pm
/usr/share/perl5/CGI/ValidOp/Check/checkbox.pm
/usr/share/perl5/CGI/ValidOp/Check/date.pm
/usr/share/perl5/CGI/ValidOp/Check/demographics.pm
/usr/share/perl5/CGI/ValidOp/Check/email.pm
/usr/share/perl5/CGI/ValidOp/Check/length.pm
/usr/share/perl5/CGI/ValidOp/Check/number.pm
/usr/share/perl5/CGI/ValidOp/Check/required_if.pm
/usr/share/perl5/CGI/ValidOp/Check/sql.pm
/usr/share/perl5/CGI/ValidOp/Check/text.pm

See Also

Package Description
perl-CGI-Validate-2.000-alt1.noarch.rpm Advanced CGI form parser and type validation
perl-CGI-WML-0.09-alt1.noarch.rpm perl module CGI-WML
perl-CGI-WebGzip-0.14-alt1.noarch.rpm perl module CGI-WebGzip
perl-CGI-WebIn-2.03-alt1.noarch.rpm perl module CGI-WebIn
perl-CGI-WebOut-2.25-alt1.noarch.rpm perl module CGI-WebOut
perl-CGI-WebToolkit-0.08-alt1.noarch.rpm Website Toolkit
perl-CGI-Widget-0.15-alt1.noarch.rpm perl module CGI-Widget
perl-CGI-Widget-DBI-Search-0.31-alt1.noarch.rpm Database search widget
perl-CGI-Widget-Path-0.01-alt1.noarch.rpm Simple HTML navigation path bar builder
perl-CGI-Widget-Tabs-1.14-alt1.noarch.rpm Create tab widgets in HTML
perl-CGI-Wiki-0.63-alt1.noarch.rpm A toolkit for building Wikis
perl-CGI-Wiki-Formatter-Multiple-0.02-alt1.noarch.rpm perl module CGI-Wiki-Formatter-Multiple
perl-CGI-Wiki-Formatter-Pod-0.03-alt1.noarch.rpm A Pod to HTML formatter for CGI::Wiki
perl-CGI-Wiki-Formatter-UseMod-0.18-alt1.noarch.rpm UseModWiki-style formatting for CGI::Wiki
perl-CGI-Wiki-Plugin-Categoriser-0.02-alt1.noarch.rpm Category management for CGI::Wiki
Advertisement
Advertisement