perl-Cisco-SNMP-1.05-alt1.noarch.rpm


Advertisement

Description

perl-Cisco-SNMP - Interface for Cisco Management

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package name perl-Cisco-SNMP
Package version 1.05
Package release alt1
Package architecture noarch
Package type rpm
Installed size 171.99 KB
Download size 171.99 KB
Official Mirror ftp.altlinux.org
Cisco::SNMP is a class implementing several management functions
for Cisco devices - mostly via SNMP.  Cisco::SNMP uses the
Net::SNMP module to do the SNMP calls.
Cisco::SNMP is the successor to the now deprecated Cisco::Management.
Cisco::SNMP supports IPv6 on systems with IPv6 configured but
requires Socket version 1.94 or greater.  This may cause issues on
Perl versions less than 5.14, where the default Socket module
is of a lesser version.  The requirement stems from the use of the
`getaddrinfo()' and `getnameinfo()' functions not available on older
versions of Socket.

Alternatives

Package Version Architecture Repository
perl-Cisco-SNMP - - -

Requires

Name Value
/usr/share/perl5 -
perl(Net/SNMP.pm) -
perl(Socket.pm) -
perl(Sys/Hostname.pm) -
perl(version.pm) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Cisco/SNMP.pm) = 1.050
perl(Cisco/SNMP/ARP.pm) = 1.050
perl(Cisco/SNMP/CPU.pm) = 1.050
perl(Cisco/SNMP/Config.pm) = 1.050
perl(Cisco/SNMP/Entity.pm) = 1.050
perl(Cisco/SNMP/IP.pm) = 1.050
perl(Cisco/SNMP/Image.pm) = 1.050
perl(Cisco/SNMP/Interface.pm) = 1.050
perl(Cisco/SNMP/Line.pm) = 1.050
perl(Cisco/SNMP/Memory.pm) = 1.050
perl(Cisco/SNMP/Password.pm) = 1.050
perl(Cisco/SNMP/ProxyPing.pm) = 1.050
perl(Cisco/SNMP/Sensor.pm) = 1.050
perl(Cisco/SNMP/System.pm) = 1.050
perl-Cisco-SNMP = 1.05-alt1

Download

Type URL
Binary Package perl-Cisco-SNMP-1.05-alt1.noarch.rpm
Source Package perl-Cisco-SNMP-1.05-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Cisco-SNMP rpm package:
    # sudo apt-get install perl-Cisco-SNMP

Files

Path
/usr/share/doc/perl-Cisco-SNMP-1.05/Changes
/usr/share/doc/perl-Cisco-SNMP-1.05/README
/usr/share/perl5/Cisco/SNMP.pm
/usr/share/perl5/Cisco/SNMP/ARP.pm
/usr/share/perl5/Cisco/SNMP/CPU.pm
/usr/share/perl5/Cisco/SNMP/Config.pm
/usr/share/perl5/Cisco/SNMP/Entity.pm
/usr/share/perl5/Cisco/SNMP/IP.pm
/usr/share/perl5/Cisco/SNMP/Image.pm
/usr/share/perl5/Cisco/SNMP/Interface.pm
/usr/share/perl5/Cisco/SNMP/Line.pm
/usr/share/perl5/Cisco/SNMP/Memory.pm
/usr/share/perl5/Cisco/SNMP/Password.pm
/usr/share/perl5/Cisco/SNMP/ProxyPing.pm
/usr/share/perl5/Cisco/SNMP/Sensor.pm
/usr/share/perl5/Cisco/SNMP/System.pm

See Also

Package Description
perl-Cisco-SNMP-scripts-1.05-alt1.noarch.rpm Cisco-SNMP scripts
perl-Cisco-UCS-0.51-alt1.noarch.rpm A Perl interface to the Cisco UCS XML API
perl-Cisco-Version-0.02-alt1.noarch.rpm perl module Cisco-Version
perl-Citizen3540-0.61-alt1.noarch.rpm perl module Citizen3540
perl-Citrix-0.25-alt1.noarch.rpm Query and Control UNIX Citrix Sessions
perl-CiviCRM-Client-REST-0.01-alt1.noarch.rpm Client library for the CiviCRM REST API
perl-ClamAV-Client-0.11-alt1_17.noarch.rpm Client class for the ClamAV clamd virus scanner daemon
perl-Clamd-1.04-alt1.noarch.rpm perl module Clamd
perl-Clarion-1.02-alt1.noarch.rpm Perl module for reading CLARION 2.1 data files
perl-ClarionUnlock-1.0-alt1.noarch.rpm perl module ClarionUnlock
perl-Clarity-XOG-Merge-1.001-alt1.noarch.rpm Merge several Clarity XML Open Gateway (XOG) files
perl-Clarity-XOG-Merge-scripts-1.001-alt1.noarch.rpm Clarity-XOG-Merge scripts
perl-Class-Accessor-Array-0.031-alt1.noarch.rpm Generate accessors/constructor for array-based object
perl-Class-Accessor-Array-Glob-0.01-alt1.noarch.rpm Generate accessors/constructor for array-based object (supports globbing attribute)
perl-Class-Accessor-Array-Slurpy-0.020-alt1.noarch.rpm Generate accessors/constructor for array-based object (supports slurpy attribute)
Advertisement
Advertisement