perl-Config-LNPath-0.01-alt1.noarch.rpm


Advertisement

Description

perl-Config-LNPath - Currently just a Simple YAML Config Reader

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package name perl-Config-LNPath
Package version 0.01
Package release alt1
Package architecture noarch
Package type rpm
Installed size 7.68 KB
Download size 7.68 KB
Official Mirror ftp.altlinux.org
use Config::LNPath;
_our $conf = Config::LNPath->new({
_config => ['one.yml', 'two.yml'],
__merge => {
___unique_hash => 1,
___unique_array => 1,
__}
_});
_...
_$conf->find('/path/to/important/thing');

Alternatives

Package Version Architecture Repository
perl-Config-LNPath - - -

Requires

Name Value
/usr/share/perl5 -
perl(Blessed/Merge.pm) >= 0.050
perl(Data/LNPath.pm) >= 0.040
perl(YAML/XS.pm) >= 0.660
perl-base >= 1:5.10.0
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Config/LNPath.pm) = 0.010
perl-Config-LNPath = 0.01-alt1

Download

Type URL
Binary Package perl-Config-LNPath-0.01-alt1.noarch.rpm
Source Package perl-Config-LNPath-0.01-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Config-LNPath rpm package:
    # sudo apt-get install perl-Config-LNPath

Files

Path
/usr/share/doc/perl-Config-LNPath-0.01/Changes
/usr/share/doc/perl-Config-LNPath-0.01/README
/usr/share/doc/perl-Config-LNPath-0.01/ignore.txt
/usr/share/perl5/Config/LNPath.pm

See Also

Package Description
perl-Config-Lite-0.03-alt1.noarch.rpm Load config from file to hash
perl-Config-Loader-1.12-alt1.noarch.rpm (DEPRECATED) Replaced by Config::Merge
perl-Config-Locale-0.05-alt1.noarch.rpm Load and merge locale-specific configuration files
perl-Config-MVP-BundleInspector-0.001-alt1.noarch.rpm Determine prereqs and INI string from PluginBundles
perl-Config-MVP-Writer-INI-0.005-alt1.noarch.rpm Build an INI file for Config::MVP
perl-Config-Magic-0.801-alt1.noarch.rpm perl module Config-Magic
perl-Config-Maker-0.007-alt1.noarch.rpm File (especialy config) generation library
perl-Config-Maker-scripts-0.007-alt1.noarch.rpm perl-Config-Maker scripts
perl-Config-Merge-1.04-alt1.noarch.rpm load a configuration directory tree containing
perl-Config-Merge-Dynamic-0.141-alt1.noarch.rpm load a configuration directory tree containing
perl-Config-Merged-0.05-alt1.noarch.rpm Load and merge configuration from different file formats, transparently
perl-Config-MethodProxy-0.02-alt1.noarch.rpm Integrate dynamic logic with static configuration
perl-Config-Micro-0.02-alt1.noarch.rpm micro config loader
perl-Config-Model-2.126-alt1_1.noarch.rpm Framework to create configuration validation tools and editors
perl-Config-Model-Approx-1.011-alt1.noarch.rpm Approx configuration file editor
Advertisement
Advertisement