perl-Dancer2-Plugin-Cart-1.0001-alt1.noarch.rpm


Advertisement

Description

perl-Dancer2-Plugin-Cart - Cart Plugin for Dancer2 app

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package name perl-Dancer2-Plugin-Cart
Package version 1.0001
Package release alt1
Package architecture noarch
Package type rpm
Installed size 53.43 KB
Download size 53.43 KB
Official Mirror ftp.altlinux.org
This plugin provides a easy way to manage a shopping cart in dancer2.  All the information and data structure of the plugin will be manage by the session, so a good idea is to use a plugin in order to store the session data in the database.
It was designed to be used on new or existing database, providing a lot of hooks in order to fit customizable solutions.
By default, the plugin is going to search default templates on the views directory, if the view doesn't exists, the plugin will render and inline templates provided by the plugin.
An script file has been added in order to generate the template views of each stage of a checkout, and the user will be able to adapt it to their needs.
The script is create_cart_views and needs to be run on the root directory of the dancer2 app.  The default views assume that you are using "Template Toolkit" as the template engine.
=encoding utf8

Alternatives

Package Version Architecture Repository
perl-Dancer2-Plugin-Cart - - -

Requires

Name Value
/usr/share/perl5 -
perl(Dancer2/Plugin.pm) -
perl(JSON.pm) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Dancer2/Plugin/Cart.pm) = 1.0.100
perl(Dancer2/Plugin/Cart/InlineViews.pm) -
perl-Dancer2-Plugin-Cart = 1.0001-alt1

Download

Type URL
Binary Package perl-Dancer2-Plugin-Cart-1.0001-alt1.noarch.rpm
Source Package perl-Dancer2-Plugin-Cart-1.0001-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Dancer2-Plugin-Cart rpm package:
    # sudo apt-get install perl-Dancer2-Plugin-Cart

Files

Path
/usr/share/doc/perl-Dancer2-Plugin-Cart-1.0001/Changes
/usr/share/doc/perl-Dancer2-Plugin-Cart-1.0001/LICENSE
/usr/share/doc/perl-Dancer2-Plugin-Cart-1.0001/README
/usr/share/doc/perl-Dancer2-Plugin-Cart-1.0001/README.md
/usr/share/perl5/Dancer2/
/usr/share/perl5/Dancer2/Plugin/Cart.pm
/usr/share/perl5/Dancer2/Plugin/Cart/InlineViews.pm

See Also

Package Description
perl-Dancer2-Plugin-Cart-scripts-1.0001-alt1.noarch.rpm Dancer2-Plugin-Cart scripts
perl-Dancer2-Plugin-Chain-0.08-alt1.noarch.rpm Dancer2 add-on for route chaining
perl-Dancer2-Plugin-ConditionalCaching-0.001-alt1.noarch.rpm RFC7234 Caching
perl-Dancer2-Plugin-DBIC-0.0100-alt1.noarch.rpm DBIx::Class interface for Dancer2 applications
perl-Dancer2-Plugin-DataTransposeValidator-0.101-alt1.noarch.rpm Data::Transpose::Validator plugin for Dancer2
perl-Dancer2-Plugin-Database-2.17-alt1.noarch.rpm easy database connections for Dancer2 applications
perl-Dancer2-Plugin-DebugDump-0.41-alt1.noarch.rpm Modified debug behavior to create multi-line output that's easier for mere mortals to parse
perl-Dancer2-Plugin-Deferred-0.007017-alt1.noarch.rpm Defer messages or data across redirections
perl-Dancer2-Plugin-EditFile-0.005-alt1.noarch.rpm Edit a text file from Dancer2
perl-Dancer2-Plugin-ElasticSearch-0.004-alt1.noarch.rpm Dancer2 plugin for obtaining Search::Elasticsearch handles
perl-Dancer2-Plugin-Email-0.0202-alt1.noarch.rpm Simple email sending for Dancer2 applications
perl-Dancer2-Plugin-Emailesque-0.03-alt1.noarch.rpm Simple Emailesque support for Dancer2
perl-Dancer2-Plugin-EncryptID-0.03-alt1.noarch.rpm Obfuscate IDs/string in URLs
perl-Dancer2-Plugin-Etcd-0.011-alt1.noarch.rpm Access to etcd v3 API via Dancer2
perl-Dancer2-Plugin-Etcd-scripts-0.011-alt1.noarch.rpm Dancer2-Plugin-Etcd scripts
Advertisement
Advertisement