perl-Data-Sah-CoerceRule-array-str_int_range-0.004-alt1.noarch.rpm


Advertisement

Description

perl-Data-Sah-CoerceRule-array-str_int_range - Coerce array of ints from string in the form of "INT1-INT2"

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package filename perl-Data-Sah-CoerceRule-array-str_int_range-0.004-alt1.noarch.rpm
Package name perl-Data-Sah-CoerceRule-array-str_int_range
Package version 0.004
Package release alt1
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage -
License -
Maintainer -
Download size 23.94 KB
Installed size 23.94 KB
This distribution contains Data::Sah coercion rule to coerce array of ints from
string in the form of "INT1-INT2" string. The rule is not enabled by default.
You can enable it in a schema using e.g.:
["array*", of=>"int", "x.coerce_rules"=>["str_int_range"]]

Alternatives

Package Version Architecture Repository
perl-Data-Sah-CoerceRule-array-str_int_range - - -

Requires

Name Value
/usr/share/perl5 -
perl-base >= 1:5.10.1
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Data/Sah/Coerce/perl/array/str_int_range.pm) = 0.004
perl(Data/Sah/CoerceRule/array/str_int_range.pm) = 0.004
perl-Data-Sah-CoerceRule-array-str_int_range = 0.004-alt1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-Data-Sah-CoerceRule-array-str_int_range-0.004-alt1.noarch.rpm
Source Package perl-Data-Sah-CoerceRule-array-str_int_range-0.004-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Data-Sah-CoerceRule-array-str_int_range rpm package:
    # sudo apt-get install perl-Data-Sah-CoerceRule-array-str_int_range

Files

Path
/usr/share/doc/perl-Data-Sah-CoerceRule-array-str_int_range-0.004/Changes
/usr/share/doc/perl-Data-Sah-CoerceRule-array-str_int_range-0.004/LICENSE
/usr/share/doc/perl-Data-Sah-CoerceRule-array-str_int_range-0.004/README
/usr/share/perl5/Data/
/usr/share/perl5/Data/Sah/
/usr/share/perl5/Data/Sah/Coerce/
/usr/share/perl5/Data/Sah/Coerce/perl/
/usr/share/perl5/Data/Sah/Coerce/perl/array/str_int_range.pm
/usr/share/perl5/Data/Sah/CoerceRule/
/usr/share/perl5/Data/Sah/CoerceRule/array/str_int_range.pm

See Also

Package Description
perl-Data-Sah-CoerceRule-array-str_int_range_and_comma_sep-0.004-alt1.noarch.rpm Coerce array of ints from comma-separated ints/int ranges
perl-Data-Sah-Format-0.003-alt1.noarch.rpm Formatter for Data::Sah
perl-Data-Sah-Format-perl-boolstr-0.002-alt1.noarch.rpm Format boolean as yes/no, etc
perl-Data-Sah-Format-perl-sci2dec-0.001-alt1.noarch.rpm Format scientific notation number as decimal number
perl-Data-Sah-From-JSONSchema-0.02-alt1.noarch.rpm Convert JSON schema to Sah schema
perl-Data-Sah-JS-0.87-alt1.noarch.rpm Some functions to use JavaScript Sah validator code from Perl
perl-Data-Sah-MoreUtils-0.01-alt1.noarch.rpm More utility functions related to Data::Sah
perl-Data-Sah-Normalize-0.050-alt1.noarch.rpm Normalize Sah schema
perl-Data-Sah-Object-0.02-alt1.noarch.rpm Object-oriented interface for Sah schemas
perl-Data-Sah-Params-0.003-alt1.noarch.rpm Validate function arguments using Sah schemas
perl-Data-Sah-Resolve-0.007-alt1.noarch.rpm Resolve Sah schema
perl-Data-Sah-Schema-DefHash-0.01-alt1.noarch.rpm Sah schema
perl-Data-Sah-Schema-TableSpec-0.01-alt1.noarch.rpm Sah schemas to validate TableSpec
perl-Data-Sah-Terse-0.02-alt1.noarch.rpm Make human-readable terse representation of Sah schema
perl-Data-Sah-Util-Subschema-0.004-alt1.noarch.rpm Extract subschemas from a schema
Advertisement
Advertisement