perl-Data-Validate-MySQL-0.03-alt1.noarch.rpm


Advertisement

Description

perl-Data-Validate-MySQL - validate against MySQL data types

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package filename perl-Data-Validate-MySQL-0.03-alt1.noarch.rpm
Package name perl-Data-Validate-MySQL
Package version 0.03
Package release alt1
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage -
License -
Maintainer -
Download size 77.85 KB
Installed size 77.85 KB
This module collects common validation routines to check suspect values against
MySQL column types.  For example, you can check to make sure your integer values
are within range, your strings aren't too big, and that your dates and times
look vaguely ISO-ish.  Validating your values before trying to insert them
into MySQL is critical, particularly since MySQL is very tolerant of bad data
by default, so you may end up with useless values in your tables even if
the database doesn't complain.
All functions return an untainted value if the test passes, and undef if
it fails.  This means that you should always check for a defined status explicitly.
Don't assume the return will be true. (e.g. is_integer('0'))
The value to test is always the first (and often only) argument.

Alternatives

Package Version Architecture Repository
perl-Data-Validate-MySQL - - -

Requires

Name Value
/usr/share/perl5 -
perl(AutoLoader.pm) -
perl(Data/Validate.pm) >= 0.060
perl(Math/BigFloat.pm) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Data/Validate/MySQL.pm) = 0.030
perl-Data-Validate-MySQL = 0.03-alt1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-Data-Validate-MySQL-0.03-alt1.noarch.rpm
Source Package perl-Data-Validate-MySQL-0.03-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Data-Validate-MySQL rpm package:
    # sudo apt-get install perl-Data-Validate-MySQL

Files

Path
/usr/share/doc/perl-Data-Validate-MySQL-0.03/Changes
/usr/share/doc/perl-Data-Validate-MySQL-0.03/README
/usr/share/perl5/Data/
/usr/share/perl5/Data/Validate/MySQL.pm
/usr/share/perl5/auto/Data/
/usr/share/perl5/auto/Data/Validate/
/usr/share/perl5/auto/Data/Validate/MySQL/_parse_datetime.al
/usr/share/perl5/auto/Data/Validate/MySQL/_parse_time.al
/usr/share/perl5/auto/Data/Validate/MySQL/_validate_date.al
/usr/share/perl5/auto/Data/Validate/MySQL/_validate_time.al
/usr/share/perl5/auto/Data/Validate/MySQL/autosplit.ix
/usr/share/perl5/auto/Data/Validate/MySQL/is_bigint.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_binary.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_bit.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_blob.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_boolean.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_char.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_date.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_datetime.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_decimal.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_double.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_enum.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_float.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_int.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_longblob.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_longtext.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_mediumblob.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_mediumint.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_mediumtext.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_set.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_smallint.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_text.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_time.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_timestamp.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_tinyblob.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_tinyint.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_tinytext.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_varbinary.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_varchar.al
/usr/share/perl5/auto/Data/Validate/MySQL/is_year.al
/usr/share/perl5/auto/Data/Validate/MySQL/new.al

See Also

Package Description
perl-Data-Validate-Perl-0.02-alt1.noarch.rpm validates in-memory perl data using a specification
perl-Data-Validate-Perl-scripts-0.02-alt1.noarch.rpm Data-Validate-Perl scripts
perl-Data-Validate-Sanctions-0.11-alt1.noarch.rpm Validate a name against sanctions lists
perl-Data-Validate-Sanctions-scripts-0.11-alt1.noarch.rpm Data-Validate-Sanctions scripts
perl-Data-Validate-Struct-0.1-alt2.noarch.rpm Validate recursive Hash Structures
perl-Data-Validate-Type-1.6.0-alt1_10.noarch.rpm Public interface to Params::Util offering data type validation functions
perl-Data-Validate-UUID-0.1.1-alt1.noarch.rpm Data Validator to check for well formed UUIDs
perl-Data-Validate-VIN-0.04-alt1.noarch.rpm Perl extension for basic validation of
perl-Data-Validate-WithYAML-0.18-alt1.noarch.rpm Validation framework that can be configured with YAML files
perl-Data-Validate-WithYAML-Plugin-Country-0.03-alt1.noarch.rpm check whether a given value is a valid country code
perl-Data-Validate-WithYAML-Plugin-EMail-0.04-alt1.noarch.rpm Plugin for Data::Validate::WithYAML to check email addresses
perl-Data-Validate-WithYAML-Plugin-IBAN-0.04-alt1.noarch.rpm check whether a given value is a valid IBAN
perl-Data-Validate-WithYAML-Plugin-NoSpam-0.04-alt1.noarch.rpm Plugin to check that a given text is no spam
perl-Data-Validate-WithYAML-Plugin-PasswordPolicy-0.03-alt1.noarch.rpm Plugin to check passwords against a policy
perl-Data-Validate-WithYAML-Plugin-Phone-0.06-alt1.noarch.rpm Plugin to check Phone numbers (basic check)
Advertisement
Advertisement