perl-Decision-Depends-0.21-alt1.noarch.rpm


Advertisement

Description

perl-Decision-Depends - Perform actions based upon file dependencies

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package filename perl-Decision-Depends-0.21-alt1.noarch.rpm
Package name perl-Decision-Depends
Package version 0.21
Package release alt1
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage -
License -
Maintainer -
Download size 102.94 KB
Installed size 102.94 KB
Decision::Depends is a module which simplifies the creation of
procedures with intermediate steps which can be skipped if certain
dependencies are met.  Think of it as a procedural version of make.
Decision::Depends is useful when there are several steps in a
process, each of which depends upon the last.  If the process is
interrupted, or if it is to be redone with changes to parameters in
later steps, and if intermediate results can be kept, then
Decision::Depends can insure that only the minimal number of steps
be redone.
Each step must result in a tangible product (a file).  For complicated
steps with many products the step's successful completion may be
indicated by creating an empty file whose existance indicates
completion.  This file (a `status' file in Decision::Depends
terminology) can be automatically created if requested.
Decision::Depends determines if the product for a given step is
older than any files required to produce it.  It can also check
whether the contents of a file have changed since the product was last
created.  This is useful in the case where a configuration file must
be created anew each time, but results in action only if changed since
the product was last created. Finally, it can determine if a
variable's value has changed since the product was last created.

Alternatives

Package Version Architecture Repository
perl-Decision-Depends - - -

Requires

Name Value
/usr/share/perl5 -
perl(Clone.pm) -
perl(Data/Compare.pm) -
perl(Digest/MD5.pm) -
perl(IO/File.pm) -
perl(Scalar/Util.pm) -
perl(Tie/IxHash.pm) -
perl(YAML.pm) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Decision/Depends.pm) = 0.210
perl(Decision/Depends/List.pm) = 0.200
perl(Decision/Depends/OO.pm) = 0.200
perl(Decision/Depends/Sig.pm) = 0.200
perl(Decision/Depends/State.pm) = 0.200
perl(Decision/Depends/Target.pm) = 0.200
perl(Decision/Depends/Time.pm) = 0.200
perl(Decision/Depends/Var.pm) = 0.200
perl-Decision-Depends = 0.21-alt1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-Decision-Depends-0.21-alt1.noarch.rpm
Source Package perl-Decision-Depends-0.21-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Decision-Depends rpm package:
    # sudo apt-get install perl-Decision-Depends

Files

Path
/usr/share/doc/perl-Decision-Depends-0.21/ChangeLog
/usr/share/doc/perl-Decision-Depends-0.21/Changes
/usr/share/doc/perl-Decision-Depends-0.21/LICENSE
/usr/share/doc/perl-Decision-Depends-0.21/README
/usr/share/perl5/Decision/Depends.pm
/usr/share/perl5/Decision/Depends/List.pm
/usr/share/perl5/Decision/Depends/OO.pm
/usr/share/perl5/Decision/Depends/Sig.pm
/usr/share/perl5/Decision/Depends/State.pm
/usr/share/perl5/Decision/Depends/Target.pm
/usr/share/perl5/Decision/Depends/Time.pm
/usr/share/perl5/Decision/Depends/Var.pm

See Also

Package Description
perl-Decision-Markov-0.03a-alt1.noarch.rpm Markov models for decision analysis
perl-Decision-ParseTree-0.041-alt1.noarch.rpm Replacing waterfall IF-ELSIF-ELSE blocks
perl-Decl-0.11-alt1.noarch.rpm Provides a declarative framework for Perl
perl-Declare-CLI-0.009-alt1.noarch.rpm Declarative command line interface builder
perl-Declare-Constraints-Simple-0.03-alt1_39.noarch.rpm Declarative Validation of Data Structures
perl-Decode-Source-1.01-alt1.noarch.rpm perl module Decode-Source
perl-Deeme-0.05-alt1.noarch.rpm a Database-agnostic driven Event Emitter
perl-Deeme-Backend-DBI-0.04-alt1.noarch.rpm DBI Backend for Deeme
perl-Deeme-Backend-Mango-0.02-alt1.noarch.rpm MongoDB Backend using Mango for Deeme
perl-Deeme-Backend-Meerkat-0.03-alt1.noarch.rpm MongoDB Backend using Meerkat for Deeme
perl-Deeme-Backend-SQLite-0.03-alt1.noarch.rpm SQLite Backend using DBI for Deeme
perl-Deep-Hash-Exists-0.22-alt1.noarch.rpm verify existence of keys hash
perl-Deep-Hash-Utils-0.04-alt2.noarch.rpm functions for iterating over and working with nested hashes
perl-DefHash-1.0.12-alt1.noarch.rpm Define things according to a specification, using hashes
perl-DefHash-Examples-0.002-alt1.noarch.rpm Example DefHash hashes
Advertisement
Advertisement