perl-Dist-Zilla-Plugin-MungeFile-0.009-alt1.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-MungeFile - Modify files in the build, with templates and arbitrary extra variables

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package filename perl-Dist-Zilla-Plugin-MungeFile-0.009-alt1.noarch.rpm
Package name perl-Dist-Zilla-Plugin-MungeFile
Package version 0.009
Package release alt1
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage -
License -
Maintainer -
Download size 5.90 KB
Installed size 5.90 KB
=for stopwords FileMunger
This is a FileMunger plugin for
the Dist::Zilla manpage that passes a file(s)
through a the Text::Template manpage.
The the Dist::Zilla manpage object (as `$dist') and this plugin (as `$plugin') are
also made available to the template, for extracting other information about
the build.
Additionally, any extra keys and values you pass to the plugin are passed
along in variables named for each key.
=for Pod::Coverage munge_files munge_file mvp_aliases

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-MungeFile - - -

Requires

Name Value
/usr/share/perl5 -
perl(Dist/Zilla/Role/FileFinderUser.pm) -
perl(Dist/Zilla/Role/FileMunger.pm) -
perl(Dist/Zilla/Role/TextTemplate.pm) -
perl(List/Util.pm) -
perl(Moose.pm) -
perl(MooseX/SlurpyConstructor.pm) >= 1.200
perl(Scalar/Util.pm) -
perl(namespace/autoclean.pm) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Dist/Zilla/Plugin/MungeFile.pm) = 0.009
perl-Dist-Zilla-Plugin-MungeFile = 0.009-alt1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-Dist-Zilla-Plugin-MungeFile-0.009-alt1.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-MungeFile-0.009-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Dist-Zilla-Plugin-MungeFile rpm package:
    # sudo apt-get install perl-Dist-Zilla-Plugin-MungeFile

Files

Path
/usr/share/doc/perl-Dist-Zilla-Plugin-MungeFile-0.009/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-MungeFile-0.009/README
/usr/share/perl5/Dist/
/usr/share/perl5/Dist/Zilla/
/usr/share/perl5/Dist/Zilla/Plugin/MungeFile.pm

See Also

Package Description
perl-Dist-Zilla-Plugin-MungeFile-WithConfigFile-0.005-alt1.noarch.rpm Modify files in the build, with templates and config data from a file
perl-Dist-Zilla-Plugin-MungeFile-WithDataSection-0.009-alt1.noarch.rpm Modify files in the build, with templates and DATA section
perl-Dist-Zilla-Plugin-NameFromDirectory-0.04-alt1.noarch.rpm Guess distribution name from the current directory
perl-Dist-Zilla-Plugin-NextRelease-Grouped-0.0200-alt1.noarch.rpm Simplify usage of a grouped changelog
perl-Dist-Zilla-Plugin-NextVersion-Semantic-0.2.5-alt1.noarch.rpm update the next version, semantic-wise
perl-Dist-Zilla-Plugin-NexusRelease-1.0.1-alt1.noarch.rpm Release a Dist::Zilla build to a Sonatype Nexus instance
perl-Dist-Zilla-Plugin-NoAutomatedTesting-0.08-alt2_6.noarch.rpm Avoid running under CPAN Testers
perl-Dist-Zilla-Plugin-NoSmartCommentsTests-0.009-alt1_3.noarch.rpm Make sure no Smart::Comments escape into the wild
perl-Dist-Zilla-Plugin-OSPrereqs-POSIX-0.01-alt1.noarch.rpm List prereqs for POSIX-compliant OSes
perl-Dist-Zilla-Plugin-OSPrereqs-Unix-0.01-alt1.noarch.rpm List prereqs for Unix OSes
perl-Dist-Zilla-Plugin-OnlyCorePrereqs-0.024-alt1.noarch.rpm Check that no prerequisites are declared that are not part of core
perl-Dist-Zilla-Plugin-OptionalFeature-0.023-alt1.noarch.rpm Specify prerequisites for optional features in your dist
perl-Dist-Zilla-Plugin-OurDate-0.03-alt1.noarch.rpm no line insertion and does Package release date with our
perl-Dist-Zilla-Plugin-OurDist-0.02-alt1.noarch.rpm Add a $DIST to your packages (no line insertion)
perl-Dist-Zilla-Plugin-OverridePkgVersion-0.002-alt1.noarch.rpm Override existing VERSION in a module
Advertisement
Advertisement