perl-Dist-Zilla-Plugin-PatchModule-0.002-alt1.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-PatchModule - Plugin to use when building patch modules

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package filename perl-Dist-Zilla-Plugin-PatchModule-0.002-alt1.noarch.rpm
Package name perl-Dist-Zilla-Plugin-PatchModule
Package version 0.002
Package release alt1
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage -
License -
Maintainer -
Download size 22.87 KB
Installed size 22.87 KB
This plugin is to be used when building patch modules (modules that use
the Module::Patch manpage to bundle a set of monkey patches, for example
the File::Which::Patch::Hide manpage or the LWP::UserAgent::Patch::FilterMirror manpage). It
currently does the following:
=over
=item * Check that distribution name is <TARGET_MODULE>-Patch-<DESCRIPTION>
=item * Check that a dependency to Module::Patch (at least 0.12) has been specified
=item * Check that a dependency to target module has been specified
=back
=for Pod::Coverage .+

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-PatchModule - - -

Requires

Name Value
/usr/share/perl5 -
perl(Dist/Zilla/Role/AfterBuild.pm) -
perl(Dist/Zilla/Role/BeforeBuild.pm) -
perl(Moose.pm) -
perl(namespace/autoclean.pm) -
perl-base >= 1:5.10.1
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Dist/Zilla/Plugin/PatchModule.pm) = 0.002
perl-Dist-Zilla-Plugin-PatchModule = 0.002-alt1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-Dist-Zilla-Plugin-PatchModule-0.002-alt1.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-PatchModule-0.002-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Dist-Zilla-Plugin-PatchModule rpm package:
    # sudo apt-get install perl-Dist-Zilla-Plugin-PatchModule

Files

Path
/usr/share/doc/perl-Dist-Zilla-Plugin-PatchModule-0.002/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-PatchModule-0.002/LICENSE
/usr/share/doc/perl-Dist-Zilla-Plugin-PatchModule-0.002/README
/usr/share/perl5/Dist/
/usr/share/perl5/Dist/Zilla/
/usr/share/perl5/Dist/Zilla/Plugin/PatchModule.pm

See Also

Package Description
perl-Dist-Zilla-Plugin-PerlStripper-0.01-alt1.noarch.rpm Strip your modules/scripts with Perl::Stripper
perl-Dist-Zilla-Plugin-PerlTidy-0.21-alt1_4.noarch.rpm Perltidy your dist
perl-Dist-Zilla-Plugin-PerlVersionPrereqs-0.01-alt1.noarch.rpm set additional prereqs for older perls
perl-Dist-Zilla-Plugin-Pinto-Add-0.088-alt1.noarch.rpm Ship your dist to a Pinto repository
perl-Dist-Zilla-Plugin-PkgAuthority-0.05-alt1.noarch.rpm Add a $AUTHORITY to your packages
perl-Dist-Zilla-Plugin-PkgVersion-Block-0.0200-alt1.noarch.rpm L<PkgVersion|Dist::Zilla::Plugin::PkgVersion> for block packages
perl-Dist-Zilla-Plugin-PkgVersionIfModuleWithPod-0.01-alt1.noarch.rpm Apply PkgVersion to .pm files with =pod sections
perl-Dist-Zilla-Plugin-Pod-Spiffy-1.001007-alt1.noarch.rpm make your documentation look spiffy as HTML
perl-Dist-Zilla-Plugin-Pod2Html-0.1.2-alt1.noarch.rpm create CSS-rich HTML pages from the POD-aware files
perl-Dist-Zilla-Plugin-Pod2Readme-0.004-alt1.noarch.rpm Generate README from Pod, as simply as possible
perl-Dist-Zilla-Plugin-PodInherit-0.007-alt1.noarch.rpm autogenerate inherited POD sections for Dist::Zilla distributions
perl-Dist-Zilla-Plugin-PodKnit-0.0.1-alt1.noarch.rpm craft from warm and fuzzy documentation for your Perl code
perl-Dist-Zilla-Plugin-PodLoom-5.00-alt1.noarch.rpm Dist::Zilla plugin for Pod::Loom
perl-Dist-Zilla-Plugin-PodPurler-0.093401-alt2_7.noarch.rpm Like PodWeaver, but more erratic and amateurish
perl-Dist-Zilla-Plugin-PodWeaverIfPod-0.02-alt1.noarch.rpm Apply PodWeaver if there is already Pod
Advertisement
Advertisement