perl-Dist-Zilla-Plugin-PodnameFromClassname-0.1100-alt1.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-PodnameFromClassname - Insert PODNAME for Moops classes

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package filename perl-Dist-Zilla-Plugin-PodnameFromClassname-0.1100-alt1.noarch.rpm
Package name perl-Dist-Zilla-Plugin-PodnameFromClassname
Package version 0.1100
Package release alt1
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage -
License -
Maintainer -
Download size 27.17 KB
Installed size 27.17 KB
Dist::Zilla::Plugin::PodnameFromClassname is useful together with the Moops manpage and the Pod::Weaver manpage. Since Moops classes generally don't also have a `package' statement `Pod::Weaver' can't pick up the module name.
Using this plugin and adding a `# PODCLASSNAME' directive fixes that. It replaces that directive with `# PODNAME: $classname'.
There are a few simple rules:
=over 4
=item *
There must be at least one line (of anything) before the `# PODCLASSNAME' directive.
=item *
There must be at least one line (of anything) between the `# PODCLASSNAME' directive and the `class' statement.
=item *
The `# PODCLASSNAME' directive must be before the `class' statement.
=back

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-PodnameFromClassname - - -

Requires

Name Value
/usr/share/perl5 -
perl(Dist/Zilla/Role/FileFinderUser.pm) >= 5.0
perl(Dist/Zilla/Role/FileMunger.pm) >= 5.0
perl(Moose.pm) >= 2.140.500
perl(namespace/autoclean.pm) >= 0.220
perl-base >= 1:5.10.0
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Dist/Zilla/Plugin/PodnameFromClassname.pm) = 0.110
perl-Dist-Zilla-Plugin-PodnameFromClassname = 0.1100-alt1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-Dist-Zilla-Plugin-PodnameFromClassname-0.1100-alt1.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-PodnameFromClassname-0.1100-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Dist-Zilla-Plugin-PodnameFromClassname rpm package:
    # sudo apt-get install perl-Dist-Zilla-Plugin-PodnameFromClassname

Files

Path
/usr/share/doc/perl-Dist-Zilla-Plugin-PodnameFromClassname-0.1100/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-PodnameFromClassname-0.1100/LICENSE
/usr/share/doc/perl-Dist-Zilla-Plugin-PodnameFromClassname-0.1100/README
/usr/share/perl5/Dist/
/usr/share/perl5/Dist/Zilla/
/usr/share/perl5/Dist/Zilla/Plugin/PodnameFromClassname.pm

See Also

Package Description
perl-Dist-Zilla-Plugin-PodnameFromFilename-0.02-alt1.noarch.rpm Fill out # PODNAME from filename
perl-Dist-Zilla-Plugin-PrePAN-0.02-alt1.noarch.rpm perl module Dist-Zilla-Plugin-PrePAN
perl-Dist-Zilla-Plugin-Precompute-0.03-alt1.noarch.rpm Precompute variable values during building
perl-Dist-Zilla-Plugin-PrecomputeVariable-0.04-alt1.noarch.rpm Precompute variable values during building
perl-Dist-Zilla-Plugin-Preload-0.01-alt1.noarch.rpm Preload modules on some condition
perl-Dist-Zilla-Plugin-Prepender-2.004-alt1_3.noarch.rpm prepend lines at the top of your perl files
perl-Dist-Zilla-Plugin-Prereqs-AuthorDeps-0.006-alt1.noarch.rpm Add Dist::Zilla authordeps to META files as develop prereqs
perl-Dist-Zilla-Plugin-Prereqs-CheckCircular-0.006-alt1.noarch.rpm Check for circular/recursive dependencies (using local CPAN mirror)
perl-Dist-Zilla-Plugin-Prereqs-DarkPAN-0.3.0-alt1.noarch.rpm Depend on things from arbitrary places-not-CPAN
perl-Dist-Zilla-Plugin-Prereqs-EnsureCoreOrPP-0.09-alt1.noarch.rpm Make sure that prereqs (and their deps) are all core/PP modules
perl-Dist-Zilla-Plugin-Prereqs-EnsureVersion-0.050-alt1.noarch.rpm Make sure that prereqs have minimum versions
perl-Dist-Zilla-Plugin-Prereqs-Floor-0.001-alt1.noarch.rpm Dist::Zilla plugin to set a minimum allowed version for prerequisites
perl-Dist-Zilla-Plugin-Prereqs-FromCPANfile-0.08-alt1.noarch.rpm Parse cpanfile for prereqs
perl-Dist-Zilla-Plugin-Prereqs-MatchInstalled-1.001003-alt1.noarch.rpm Depend on versions of modules the same as you have installed
perl-Dist-Zilla-Plugin-Prereqs-MatchInstalled-All-1.001001-alt1.noarch.rpm Upgrade ALL your dependencies to the ones you have installed
Advertisement
Advertisement