perl-Dist-Zilla-Plugin-PrecomputeVariable-0.04-alt1.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-PrecomputeVariable - Precompute variable values during building

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package filename perl-Dist-Zilla-Plugin-PrecomputeVariable-0.04-alt1.noarch.rpm
Package name perl-Dist-Zilla-Plugin-PrecomputeVariable
Package version 0.04
Package release alt1
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage -
License -
Maintainer -
Download size 24.97 KB
Installed size 24.97 KB
This plugin can be used to precompute variables values during build time and put
the resulting computed value into the built source code. This is useful in some
cases to reduce module startup time, especially if it takes some time to compute
the value.
=for Pod::Coverage .+

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-PrecomputeVariable - - -

Requires

Name Value
/usr/share/perl5 -
perl(Data/Dmp.pm) -
perl(Dist/Zilla/Role/FileFinderUser.pm) -
perl(Dist/Zilla/Role/FileMunger.pm) -
perl(Moose.pm) -
perl(namespace/autoclean.pm) -
perl-base >= 1:5.10.0
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Dist/Zilla/Plugin/PrecomputeVariable.pm) = 0.040
perl-Dist-Zilla-Plugin-PrecomputeVariable = 0.04-alt1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-Dist-Zilla-Plugin-PrecomputeVariable-0.04-alt1.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-PrecomputeVariable-0.04-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Dist-Zilla-Plugin-PrecomputeVariable rpm package:
    # sudo apt-get install perl-Dist-Zilla-Plugin-PrecomputeVariable

Files

Path
/usr/share/doc/perl-Dist-Zilla-Plugin-PrecomputeVariable-0.04/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-PrecomputeVariable-0.04/LICENSE
/usr/share/doc/perl-Dist-Zilla-Plugin-PrecomputeVariable-0.04/README
/usr/share/perl5/Dist/
/usr/share/perl5/Dist/Zilla/
/usr/share/perl5/Dist/Zilla/Plugin/PrecomputeVariable.pm

See Also

Package Description
perl-Dist-Zilla-Plugin-Preload-0.01-alt1.noarch.rpm Preload modules on some condition
perl-Dist-Zilla-Plugin-Prepender-2.004-alt1_3.noarch.rpm prepend lines at the top of your perl files
perl-Dist-Zilla-Plugin-Prereqs-AuthorDeps-0.006-alt1.noarch.rpm Add Dist::Zilla authordeps to META files as develop prereqs
perl-Dist-Zilla-Plugin-Prereqs-CheckCircular-0.006-alt1.noarch.rpm Check for circular/recursive dependencies (using local CPAN mirror)
perl-Dist-Zilla-Plugin-Prereqs-DarkPAN-0.3.0-alt1.noarch.rpm Depend on things from arbitrary places-not-CPAN
perl-Dist-Zilla-Plugin-Prereqs-EnsureCoreOrPP-0.09-alt1.noarch.rpm Make sure that prereqs (and their deps) are all core/PP modules
perl-Dist-Zilla-Plugin-Prereqs-EnsureVersion-0.050-alt1.noarch.rpm Make sure that prereqs have minimum versions
perl-Dist-Zilla-Plugin-Prereqs-Floor-0.001-alt1.noarch.rpm Dist::Zilla plugin to set a minimum allowed version for prerequisites
perl-Dist-Zilla-Plugin-Prereqs-FromCPANfile-0.08-alt1.noarch.rpm Parse cpanfile for prereqs
perl-Dist-Zilla-Plugin-Prereqs-MatchInstalled-1.001003-alt1.noarch.rpm Depend on versions of modules the same as you have installed
perl-Dist-Zilla-Plugin-Prereqs-MatchInstalled-All-1.001001-alt1.noarch.rpm Upgrade ALL your dependencies to the ones you have installed
perl-Dist-Zilla-Plugin-Prereqs-Plugins-1.003003-alt1.noarch.rpm Add all Dist::Zilla plugins presently in use as prerequisites
perl-Dist-Zilla-Plugin-Prereqs-Recommend-MatchInstalled-0.003003-alt1.noarch.rpm Advertise versions of things you have as soft dependencies
perl-Dist-Zilla-Plugin-Prereqs-SetMinimumVersion-FromPmVersions-0.001-alt1.noarch.rpm Set minimum version of prereqs from pmversions.ini
perl-Dist-Zilla-Plugin-Prereqs-Soften-0.006003-alt1.noarch.rpm Downgrade listed dependencies to recommendations if present
Advertisement
Advertisement