perl-Dist-Zilla-Plugin-Prereqs-EnsureVersion-0.050-alt1.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-Prereqs-EnsureVersion - Make sure that prereqs have minimum versions

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package filename perl-Dist-Zilla-Plugin-Prereqs-EnsureVersion-0.050-alt1.noarch.rpm
Package name perl-Dist-Zilla-Plugin-Prereqs-EnsureVersion
Package version 0.050
Package release alt1
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage -
License -
Maintainer -
Download size 24.31 KB
Installed size 24.31 KB
This plugin will check versions specified in prereqs. First you create
~/pmversions.ini containing list of modules and their mininum versions. Then,
the plugin will check all prereqs against this list. If minimum version is not
met (e.g. the prereq says 0 or a smaller version) then the build will be
aborted.
Ideas for future version: ability to blacklist certain versions, specify version
ranges, e.g.:
Module::Name = 1.00-2.00, != 1.93
=for Pod::Coverage .+

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-Prereqs-EnsureVersion - - -

Requires

Name Value
/usr/share/perl5 -
perl(Config/IOD/Reader.pm) >= 0.340
perl(Dist/Zilla/Role/AfterBuild.pm) -
perl(File/HomeDir.pm) -
perl(Moose.pm) -
perl(PMVersions/Util.pm) -
perl(namespace/autoclean.pm) -
perl-base >= 1:5.10.1
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Dist/Zilla/Plugin/Prereqs/EnsureVersion.pm) = 0.050
perl-Dist-Zilla-Plugin-Prereqs-EnsureVersion = 0.050-alt1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-Dist-Zilla-Plugin-Prereqs-EnsureVersion-0.050-alt1.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-Prereqs-EnsureVersion-0.050-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Dist-Zilla-Plugin-Prereqs-EnsureVersion rpm package:
    # sudo apt-get install perl-Dist-Zilla-Plugin-Prereqs-EnsureVersion

Files

Path
/usr/share/doc/perl-Dist-Zilla-Plugin-Prereqs-EnsureVersion-0.050/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-Prereqs-EnsureVersion-0.050/LICENSE
/usr/share/doc/perl-Dist-Zilla-Plugin-Prereqs-EnsureVersion-0.050/README
/usr/share/perl5/Dist/
/usr/share/perl5/Dist/Zilla/
/usr/share/perl5/Dist/Zilla/Plugin/
/usr/share/perl5/Dist/Zilla/Plugin/Prereqs/EnsureVersion.pm

See Also

Package Description
perl-Dist-Zilla-Plugin-Prereqs-Floor-0.001-alt1.noarch.rpm Dist::Zilla plugin to set a minimum allowed version for prerequisites
perl-Dist-Zilla-Plugin-Prereqs-FromCPANfile-0.08-alt1.noarch.rpm Parse cpanfile for prereqs
perl-Dist-Zilla-Plugin-Prereqs-MatchInstalled-1.001003-alt1.noarch.rpm Depend on versions of modules the same as you have installed
perl-Dist-Zilla-Plugin-Prereqs-MatchInstalled-All-1.001001-alt1.noarch.rpm Upgrade ALL your dependencies to the ones you have installed
perl-Dist-Zilla-Plugin-Prereqs-Plugins-1.003003-alt1.noarch.rpm Add all Dist::Zilla plugins presently in use as prerequisites
perl-Dist-Zilla-Plugin-Prereqs-Recommend-MatchInstalled-0.003003-alt1.noarch.rpm Advertise versions of things you have as soft dependencies
perl-Dist-Zilla-Plugin-Prereqs-SetMinimumVersion-FromPmVersions-0.001-alt1.noarch.rpm Set minimum version of prereqs from pmversions.ini
perl-Dist-Zilla-Plugin-Prereqs-Soften-0.006003-alt1.noarch.rpm Downgrade listed dependencies to recommendations if present
perl-Dist-Zilla-Plugin-Prereqs-SyncVersions-0.003002-alt1.noarch.rpm Homogenize prerequisites so dependency versions are consistent
perl-Dist-Zilla-Plugin-Prereqs-Upgrade-0.001001-alt1.noarch.rpm Upgrade existing prerequisites in place
perl-Dist-Zilla-Plugin-PurePerlTests-0.06-alt1_3.noarch.rpm Run all your tests twice, once with XS code and once with pure Perl
perl-Dist-Zilla-Plugin-RPM-0.015-alt1.noarch.rpm Build an RPM from your Dist::Zilla release
perl-Dist-Zilla-Plugin-RPM-Push-0.010-alt1.noarch.rpm Dist::Zilla plugin to build RPMs and push them into a repository
perl-Dist-Zilla-Plugin-Readme-Brief-0.003002-alt1.noarch.rpm Provide a short simple README with just the essentials
perl-Dist-Zilla-Plugin-ReadmeAddDevInfo-0.03-alt1.noarch.rpm Dist::Zilla::Plugin::ReadmeAddDevInfo - add info how to contribute to the project
Advertisement
Advertisement