perl-Dist-Zilla-Plugin-UseUnsafeInc-0.001-alt1.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-UseUnsafeInc - Indicates the value of PERL_USE_UNSAFE_INC to use during installation

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package name perl-Dist-Zilla-Plugin-UseUnsafeInc
Package version 0.001
Package release alt1
Package architecture noarch
Package type rpm
Installed size 4.39 KB
Download size 4.39 KB
Official Mirror ftp.altlinux.org
=for Pod::Coverage metadata after_build before_release
This is a the Dist::Zilla manpage plugin that populates the `x_use_unsafe_inc' key in your distribution metadata. This
indicates to components of the toolchain that `PERL_USE_UNSAFE_INC' should be set to a certain value during
installation and testing, overriding any previous setting e.g. from the environment or from other tools.
The environment variable is also set in the Dist::Zilla manpage while building and testing the distribution, to ensure
that local testing behaves in an expected fashion.
Additionally, the release must be performed using a Perl version that supports `PERL_USE_UNSAFE_INC', to further
guarantee test integrity.

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-UseUnsafeInc - - -

Requires

Name Value
/usr/share/perl5 -
perl(Dist/Zilla/Role/AfterBuild.pm) -
perl(Dist/Zilla/Role/BeforeRelease.pm) -
perl(Dist/Zilla/Role/MetaProvider.pm) -
perl(Moose.pm) -
perl(namespace/autoclean.pm) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Dist/Zilla/Plugin/UseUnsafeInc.pm) = 0.001
perl-Dist-Zilla-Plugin-UseUnsafeInc = 0.001-alt1

Download

Type URL
Binary Package perl-Dist-Zilla-Plugin-UseUnsafeInc-0.001-alt1.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-UseUnsafeInc-0.001-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Dist-Zilla-Plugin-UseUnsafeInc rpm package:
    # sudo apt-get install perl-Dist-Zilla-Plugin-UseUnsafeInc

Files

Path
/usr/share/doc/perl-Dist-Zilla-Plugin-UseUnsafeInc-0.001/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-UseUnsafeInc-0.001/README
/usr/share/perl5/Dist/
/usr/share/perl5/Dist/Zilla/
/usr/share/perl5/Dist/Zilla/Plugin/UseUnsafeInc.pm

See Also

Package Description
perl-Dist-Zilla-Plugin-VerifyPhases-0.016-alt1.noarch.rpm Compare data and files at different phases of the distribution build process
perl-Dist-Zilla-Plugin-Version-FromSubversion-1.000019-alt1.noarch.rpm Use the revision of the working directory
perl-Dist-Zilla-Plugin-Version-Git-Flowish-0.09-alt1.noarch.rpm Get a version number via git and a flow-inspired structure
perl-Dist-Zilla-Plugin-VersionFromMainModule-0.04-alt1.noarch.rpm Set the distribution version from your main module's $VERSION
perl-Dist-Zilla-Plugin-VersionFromScript-0.017-alt1.noarch.rpm run command line script to provide version number
perl-Dist-Zilla-Plugin-VersionFromScript-scripts-0.017-alt1.noarch.rpm Dist-Zilla-Plugin-VersionFromScript scripts
perl-Dist-Zilla-Plugin-WSDL-0.207-alt1.noarch.rpm WSDL to Perl classes when building your dist
perl-Dist-Zilla-Plugin-Web-0.0.10-alt1.noarch.rpm perl module Dist-Zilla-Plugin-Web
perl-Dist-Zilla-Plugin-WordList-0.054-alt1.noarch.rpm Plugin to use when building WordList::* distribution
perl-Dist-Zilla-Plugin-WordListC-0.001-alt1.noarch.rpm Plugin to use when building WordListC::* distribution
perl-Dist-Zilla-Plugin-WriteVersion-0.001-alt1.noarch.rpm Write the version to all Perl files and scripts
perl-Dist-Zilla-Plugin-XSVersion-0.01-alt1.noarch.rpm a thing
perl-Dist-Zilla-Plugin-if-0.002002-alt1.noarch.rpm Load a plugin only if a condition is true
perl-Dist-Zilla-Plugin-if-ENV-0.001001-alt1.noarch.rpm Load a plugin when an ENV key is true
perl-Dist-Zilla-Plugin-jQuery-0.05-alt1.noarch.rpm Include jQuery in your distribution
Advertisement
Advertisement