perl-Dist-Zilla-PluginBundle-BAREFOOT-0.06-alt1.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-PluginBundle-BAREFOOT - Dist::Zilla configuration the way BAREFOOT does it

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package filename perl-Dist-Zilla-PluginBundle-BAREFOOT-0.06-alt1.noarch.rpm
Package name perl-Dist-Zilla-PluginBundle-BAREFOOT
Package version 0.06
Package release alt1
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage -
License -
Maintainer -
Download size 29.95 KB
Installed size 29.95 KB
This is a the Dist::Zilla manpage PluginBundle.  It is roughly equivalent to the following dist.ini:
_; version provider
_; hopefully soemething here soon
_; choose files to include
_[GatherDir]_______; everything under top dir
_exclude_filename = README.pod__; skip this generated file
_exclude_filename = META.json__; skip this generated file
_;[PruneCruft]______; default stuff to skip
_;[ManifestSkip]______; if -f MANIFEST.SKIP, skip those, too
_; this should probably be moved to metadata section
_[AutoPrereqs]______; find prereqs from code
_skip = ^t::lib
_; file modifications
_[OurPkgVersion]______; add $VERSION = ... to all files
_;[InsertCopyright_____; add copyright at "# COPYRIGHT"
_[PodWeaver]_______; generate Pod
_config_plugin = @BAREFOOT___; allows Pod::WikiDoc and a few other bits and bobs
_; generated files
_[License]_______; boilerplate license
_[ReadmeAnyFromPod]_____; create README.pod in repo directory
_type = pod
_filename = README.pod
_location = root
_; should this be in metadata section?
_[Bugtracker]
_web = http://github.com/barefootcoder/%l/issues
_; xt tests
_;[Test::PodSpelling]_____; xt/author/pod-spell.t
_;[MetaTests]_______; xt/release/meta-yaml.t
_;[PodSyntaxTests]_____; xt/release/pod-syntax.t
_;[PodCoverageTests]_____; xt/release/pod-coverage.t
_;[Test::Version]______; xt/release/test-version.t
_; metadata
_;[MinimumPerl]______; determine minimum perl version
_[GithubMeta]
_remote = origin
_;[MetaYAML]_______; generate META.yml (v1.4)
_[MetaJSON]_______; generate META.json (v2)
_;[MetaNoIndex]______; sets 'no_index' in META
_;directory = t
_;directory = xt
_;directory = examples
_;directory = corpus
_;package = DB______; just in case
_; can't get this one to work right ATM
_; [MetaProvides::Package]___; add 'provides' to META files
_; meta_noindex = 1_____; respect prior no_index directives
_[MetaProvides::Class]____; add 'provides' to META files for classes
_inherit_version = 1 ____; use version from dis...

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-PluginBundle-BAREFOOT - - -

Requires

Name Value
/usr/share/perl5 -
perl(Dist/Zilla.pm) >= 4.300
perl(Dist/Zilla/Plugin/Bugtracker.pm) >= 1.102.670
perl(Dist/Zilla/Plugin/CheckChangesHasContent.pm) -
perl(Dist/Zilla/Plugin/CheckExtraTests.pm) -
perl(Dist/Zilla/Plugin/CheckPrereqsIndexed.pm) >= 0.002
perl(Dist/Zilla/Plugin/CheckVersionIncrement.pm) >= 0.121.750
perl(Dist/Zilla/Plugin/CopyFilesFromBuild.pm) -
perl(Dist/Zilla/Plugin/GithubMeta.pm) >= 0.100
perl(Dist/Zilla/Plugin/InsertCopyright.pm) >= 0.001
perl(Dist/Zilla/Plugin/MetaNoIndex.pm) -
perl(Dist/Zilla/Plugin/MetaProvides/Class.pm) >= 2.001
perl(Dist/Zilla/Plugin/MinimumPerl.pm) -
perl(Dist/Zilla/Plugin/OurPkgVersion.pm) >= 0.001.008
perl(Dist/Zilla/Plugin/PodWeaver.pm) -
perl(Dist/Zilla/Plugin/PodnameFromClassname.pm) -
perl(Dist/Zilla/Plugin/ReadmeAnyFromPod.pm) >= 0.120.051
perl(Dist/Zilla/Plugin/ReadmeFromPod.pm) -
perl(Dist/Zilla/Plugin/Test/PodSpelling.pm) >= 2.001.002
perl(Dist/Zilla/Plugin/Test/Version.pm) -
perl(Dist/Zilla/PluginBundle/Git.pm) >= 2.013
perl(List/MoreUtils.pm) -
perl(Method/Signatures/Modifiers.pm) -
perl(Moose.pm) -
perl(MooseX/ClassAttribute.pm) -
perl(MooseX/Declare.pm) -
perl(MooseX/Has/Sugar.pm) -
perl(MooseX/Types/Moose.pm) -
perl(PerlX/Maybe.pm) >= 0.003
perl(Pod/Elemental/Transformer/List.pm) >= 0.101.620
perl(Pod/Weaver.pm) >= 3.101.635
perl(Pod/Weaver/Config/Assembler.pm) -
perl(Pod/Weaver/Plugin/WikiDoc.pm) -
perl(Pod/Weaver/Section/Support.pm) >= 1.001
perl(autodie.pm) >= 2.0
perl(namespace/autoclean.pm) -
perl-base >= 1:5.12.0
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Dist/Zilla/PluginBundle/BAREFOOT.pm) -
perl(Pod/Weaver/PluginBundle/BAREFOOT.pm) -
perl(Pod/Weaver/Section/LegalWithAddendum.pm) -
perl-Dist-Zilla-PluginBundle-BAREFOOT = 0.06-alt1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-Dist-Zilla-PluginBundle-BAREFOOT-0.06-alt1.noarch.rpm
Source Package perl-Dist-Zilla-PluginBundle-BAREFOOT-0.06-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Dist-Zilla-PluginBundle-BAREFOOT rpm package:
    # sudo apt-get install perl-Dist-Zilla-PluginBundle-BAREFOOT

Files

Path
/usr/share/doc/perl-Dist-Zilla-PluginBundle-BAREFOOT-0.06/Changes
/usr/share/doc/perl-Dist-Zilla-PluginBundle-BAREFOOT-0.06/LICENSE
/usr/share/doc/perl-Dist-Zilla-PluginBundle-BAREFOOT-0.06/README.PATCHING
/usr/share/doc/perl-Dist-Zilla-PluginBundle-BAREFOOT-0.06/README.md
/usr/share/perl5/Dist/
/usr/share/perl5/Dist/Zilla/
/usr/share/perl5/Dist/Zilla/PluginBundle/BAREFOOT.pm
/usr/share/perl5/Pod/
/usr/share/perl5/Pod/Weaver/
/usr/share/perl5/Pod/Weaver/PluginBundle/BAREFOOT.pm
/usr/share/perl5/Pod/Weaver/Section/LegalWithAddendum.pm

See Also

Package Description
perl-Dist-Zilla-PluginBundle-BESSARABV-1.0.1-alt1.noarch.rpm configure Dist::Zilla the way BESSARABV does it
perl-Dist-Zilla-PluginBundle-BINGOS-0.20-alt1_4.noarch.rpm BeLike::BINGOS when you build your dists
perl-Dist-Zilla-PluginBundle-BerryGenomics-0.3.2-alt1.noarch.rpm Dist::Zilla::PluginBundle for BerryGenomics Bioinformatics Department
perl-Dist-Zilla-PluginBundle-BioPerl-0.27-alt1.noarch.rpm Build your distributions like Bioperl does
perl-Dist-Zilla-PluginBundle-Bioperl-0.01-alt1.noarch.rpm Build your distributions like Bioperl does
perl-Dist-Zilla-PluginBundle-CEBJYRE-0.4.0-alt1.noarch.rpm perl module Dist-Zilla-PluginBundle-CEBJYRE
perl-Dist-Zilla-PluginBundle-CHGOVUK-0.07-alt1.noarch.rpm Dist::Zilla plugin defaults for Companies House
perl-Dist-Zilla-PluginBundle-CJFIELDS-0.06-alt1.noarch.rpm Build your modules like CJFIELDS (not sure that's a recommendation)
perl-Dist-Zilla-PluginBundle-DAGOLDEN-0.079-alt1.noarch.rpm Dist::Zilla configuration the way DAGOLDEN does it
perl-Dist-Zilla-PluginBundle-DANIELP-1.04-alt1.noarch.rpm (you shouldn't) use Dist::Zilla like DANIELP
perl-Dist-Zilla-PluginBundle-DBR-0.024-alt1.noarch.rpm DBRs Dist::Zilla PluginBundle
perl-Dist-Zilla-PluginBundle-DOY-0.15-alt1.noarch.rpm Dist::Zilla plugins for me
perl-Dist-Zilla-PluginBundle-DPHYS-1-alt1.noarch.rpm standard Dist::Zilla plugins for DPHYS
perl-Dist-Zilla-PluginBundle-DROLSKY-0.07-alt1.noarch.rpm DROLSKY's plugin bundle
perl-Dist-Zilla-PluginBundle-Dancer-0.0013-alt1.noarch.rpm dzil plugins used by Dancer projects
Advertisement
Advertisement