perl-Module-Used-1.3.0-alt1_15.noarch.rpm


Advertisement

Description

perl-Module-Used - Find modules loaded by Perl code without running it

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package filename perl-Module-Used-1.3.0-alt1_15.noarch.rpm
Package name perl-Module-Used
Package version 1.3.0
Package release alt1_15
Package architecture noarch
Package type rpm
Category Development/Other
Homepage -
License -
Maintainer -
Download size 19.41 KB
Installed size 19.41 KB
Modules are found statically based upon use and require statements. If use
of the base or parent is found, both that module and the referenced ones
will be returned. If Moose or Moose::Role are found, this will look for
extends and with sugar will be looked for; presently, this will miss
modules listed in parentheses.

Alternatives

Package Version Architecture Repository
perl-Module-Used - - -

Requires

Name Value
/usr/bin/perl -
/usr/share/perl5 -
perl(Const/Fast.pm) -
perl(English.pm) -
perl(Exporter.pm) >= 5.570
perl(File/Next.pm) >= 1.020
perl(Module/Path.pm) >= 0.010
perl(PPI/Document.pm) >= 1.205
perl(utf8.pm) -
perl(version.pm) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Module/Used.pm) = 1.003
perl-Module-Used = 1.3.0-alt1_15

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-Module-Used-1.3.0-alt1_15.noarch.rpm
Source Package perl-Module-Used-1.3.0-alt1_15.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Module-Used rpm package:
    # sudo apt-get install perl-Module-Used

Files

Path
/usr/bin/modules-used
/usr/share/doc/perl-Module-Used-1.3.0/Changes
/usr/share/doc/perl-Module-Used-1.3.0/README
/usr/share/man/man1/modules-used.1.xz
/usr/share/perl5/Module/Used.pm

See Also

Package Description
perl-Module-Version-0.201-alt1.noarch.rpm Get module versions
perl-Module-Version-Loaded-0.000003-alt1.noarch.rpm Get a versioned list of currently loaded modules
perl-Module-Version-scripts-0.201-alt1.noarch.rpm Module-Version scripts
perl-Module-Want-0.6-alt1.noarch.rpm Check @INC once for modules that you want but may not have
perl-Module-Which-0.05-alt1.noarch.rpm Finds out which version of Perl modules are installed
perl-Module-Which-scripts-0.05-alt1.noarch.rpm Module-Which scripts
perl-Module-XSOrPP-0.11-alt1.noarch.rpm Determine if an installed module is XS or pure-perl
perl-ModuleBundle-0.01-alt1.noarch.rpm perl module ModuleBundle
perl-ModuleOrPrefix-Path-0.01-alt1.noarch.rpm Get the full path to a locally installed module or prefix
perl-ModuleUnderscore-0.4-alt1.noarch.rpm convert module name to underscore string name and underscore string name to module name
perl-Modulino-Demo-1.002-alt1.noarch.rpm A demonstration of various modulino ideas
perl-MogileFS-Client-1.17-alt1_16.noarch.rpm Client library for the MogileFS distributed file system
perl-MogileFS-Client-Async-0.031-alt1.noarch.rpm A non-blocking MogileFS client
perl-MogileFS-Client-FilePaths-0.02-alt1.noarch.rpm perl module MogileFS-Client-FilePaths
perl-MogileFS-Client-Fuse-0.05-alt1.noarch.rpm Fuse binding for MogileFS
Advertisement
Advertisement