perl-Perl-Critic-Lax-0.013-alt1_9.noarch.rpm


Advertisement

Description

perl-Perl-Critic-Lax - Policies that let you slide on common exceptions

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package filename perl-Perl-Critic-Lax-0.013-alt1_9.noarch.rpm
Package name perl-Perl-Critic-Lax
Package version 0.013
Package release alt1_9
Package architecture noarch
Package type rpm
Category Development/Other
Homepage -
License -
Maintainer -
Download size 44.78 KB
Installed size 44.78 KB
The Perl-Critic-Lax distribution includes versions of core Perl::Critic
modules with built-in exceptions. If you really like a Perl::Critic policy,
but find that you often violate it in a specific way that seems pretty darn
reasonable, maybe there's a Lax policy. If there isn't, send one in!

Alternatives

Package Version Architecture Repository
perl-Perl-Critic-Lax - - -

Requires

Name Value
/usr/share/perl5 -
perl(Perl/Critic.pm) >= 1.088
perl(Perl/Critic/Policy.pm) -
perl(Perl/Critic/Policy/ValuesAndExpressions/ProhibitLeadingZeros.pm) -
perl(Perl/Critic/Utils.pm) -
perl(Readonly.pm) -
perl(parent.pm) -
perl(utf8.pm) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Perl/Critic/Lax.pm) = 0.013
perl(Perl/Critic/Policy/Lax/ProhibitComplexMappings/LinesNotStatements.pm) = 0.013
perl(Perl/Critic/Policy/Lax/ProhibitEmptyQuotes/ExceptAsFallback.pm) = 0.013
perl(Perl/Critic/Policy/Lax/ProhibitLeadingZeros/ExceptChmod.pm) = 0.013
perl(Perl/Critic/Policy/Lax/ProhibitStringyEval/ExceptForRequire.pm) = 0.013
perl(Perl/Critic/Policy/Lax/RequireConstantOnLeftSideOfEquality/ExceptEq.pm) = 0.013
perl(Perl/Critic/Policy/Lax/RequireEndWithTrueConst.pm) = 0.013
perl(Perl/Critic/Policy/Lax/RequireExplicitPackage/ExceptForPragmata.pm) = 0.013
perl-Perl-Critic-Lax = 0.013-alt1_9

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-Perl-Critic-Lax-0.013-alt1_9.noarch.rpm
Source Package perl-Perl-Critic-Lax-0.013-alt1_9.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Perl-Critic-Lax rpm package:
    # sudo apt-get install perl-Perl-Critic-Lax

Files

Path
/usr/share/doc/perl-Perl-Critic-Lax-0.013/Changes
/usr/share/doc/perl-Perl-Critic-Lax-0.013/LICENSE
/usr/share/doc/perl-Perl-Critic-Lax-0.013/README
/usr/share/perl5/Perl/
/usr/share/perl5/Perl/Critic/Lax.pm
/usr/share/perl5/Perl/Critic/Policy/
/usr/share/perl5/Perl/Critic/Policy/Lax/RequireEndWithTrueConst.pm
/usr/share/perl5/Perl/Critic/Policy/Lax/ProhibitComplexMappings/LinesNotStatements.pm
/usr/share/perl5/Perl/Critic/Policy/Lax/ProhibitEmptyQuotes/ExceptAsFallback.pm
/usr/share/perl5/Perl/Critic/Policy/Lax/ProhibitLeadingZeros/ExceptChmod.pm
/usr/share/perl5/Perl/Critic/Policy/Lax/ProhibitStringyEval/ExceptForRequire.pm
/usr/share/perl5/Perl/Critic/Policy/Lax/RequireConstantOnLeftSideOfEquality/ExceptEq.pm
/usr/share/perl5/Perl/Critic/Policy/Lax/RequireExplicitPackage/ExceptForPragmata.pm

See Also

Package Description
perl-Perl-Critic-Lokku-0.003-alt1.noarch.rpm A collection of Perl::Critic policies from Lokku
perl-Perl-Critic-MergeProfile-0.003-alt1.noarch.rpm merge multiple Perl::Critic profiles into one
perl-Perl-Critic-Moose-1.05-alt1_10.noarch.rpm Policies for Perl::Critic concerned with using Moose
perl-Perl-Critic-More-1.003-alt1_16.noarch.rpm Supplemental policies for Perl::Critic
perl-Perl-Critic-Nits-1.0.0-alt1_24.noarch.rpm Policies of nits I like to pick
perl-Perl-Critic-OTRS-0.09-alt1.noarch.rpm A collection of handy Perl::Critic policies
perl-Perl-Critic-PetPeeves-JTRAMMELL-0.04-alt1_16.noarch.rpm Policies to prohibit/require my pet peeves
perl-Perl-Critic-Policy-BadStrings-1.000-alt1.noarch.rpm Search for bad strings in source files
perl-Perl-Critic-Policy-BuiltinFunctions-ProhibitDeleteOnArrays-0.02-alt1.noarch.rpm Do not use C<delete> on arrays
perl-Perl-Critic-Policy-BuiltinFunctions-ProhibitReturnOr-0.01-alt1.noarch.rpm Check for "return $x or ..."
perl-Perl-Critic-Policy-Catalyst-ProhibitUnreachableCode-0.02-alt1.noarch.rpm Don't write code after an unconditional Catalyst detach
perl-Perl-Critic-Policy-CodeLayout-ProhibitSpaceIndentation-1.02-alt1.noarch.rpm Use tabs instead of spaces for indentation
perl-Perl-Critic-Policy-CodeLayout-TabIndentSpaceAlign-1.1.0-alt1.noarch.rpm Use tabs for indenting, spaces for aligning
perl-Perl-Critic-Policy-CompileTime-0.03-alt1.noarch.rpm Find code that runs in compile-time blocks
perl-Perl-Critic-Policy-Documentation-RequirePod-0.005-alt1.noarch.rpm file requires POD
Advertisement
Advertisement