perl-Perl-Critic-More-1.003-alt1_16.noarch.rpm


Advertisement

Description

perl-Perl-Critic-More - Supplemental policies for Perl::Critic

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package filename perl-Perl-Critic-More-1.003-alt1_16.noarch.rpm
Package name perl-Perl-Critic-More
Package version 1.003
Package release alt1_16
Package architecture noarch
Package type rpm
Category Development/Other
Homepage -
License -
Maintainer -
Download size 59.97 KB
Installed size 59.97 KB
This is a collection of Perl::Critic policies that are not included in the
Perl::Critic core for a variety of reasons.

Alternatives

Package Version Architecture Repository
perl-Perl-Critic-More - - -

Requires

Name Value
/usr/share/perl5 -
perl(English.pm) -
perl(List/MoreUtils.pm) -
perl(Perl/Critic.pm) >= 1.098
perl(Perl/Critic/Policy.pm) -
perl(Perl/Critic/Utils.pm) -
perl(Perl/MinimumVersion.pm) >= 0.140
perl(Readonly.pm) >= 1.030
perl(base.pm) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Perl/Critic/More.pm) = 1.003
perl(Perl/Critic/Policy/CodeLayout/RequireASCII.pm) = 1.003
perl(Perl/Critic/Policy/Editor/RequireEmacsFileVariables.pm) = 1.003
perl(Perl/Critic/Policy/ErrorHandling/RequireUseOfExceptions.pm) = 1.003
perl(Perl/Critic/Policy/Modules/PerlMinimumVersion.pm) = 1.003
perl(Perl/Critic/Policy/Modules/RequirePerlVersion.pm) = 1.003
perl(Perl/Critic/Policy/ValuesAndExpressions/RequireConstantOnLeftSideOfEquality.pm) = 1.003
perl(Perl/Critic/Policy/ValuesAndExpressions/RestrictLongStrings.pm) = 1.003
perl-Perl-Critic-More = 1.003-alt1_16

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-Perl-Critic-More-1.003-alt1_16.noarch.rpm
Source Package perl-Perl-Critic-More-1.003-alt1_16.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Perl-Critic-More rpm package:
    # sudo apt-get install perl-Perl-Critic-More

Files

Path
/usr/share/doc/perl-Perl-Critic-More-1.003/Changes
/usr/share/doc/perl-Perl-Critic-More-1.003/LICENSE
/usr/share/doc/perl-Perl-Critic-More-1.003/README
/usr/share/doc/perl-Perl-Critic-More-1.003/TODO.pod
/usr/share/perl5/Perl/
/usr/share/perl5/Perl/Critic/More.pm
/usr/share/perl5/Perl/Critic/Policy/
/usr/share/perl5/Perl/Critic/Policy/CodeLayout/RequireASCII.pm
/usr/share/perl5/Perl/Critic/Policy/Editor/RequireEmacsFileVariables.pm
/usr/share/perl5/Perl/Critic/Policy/ErrorHandling/RequireUseOfExceptions.pm
/usr/share/perl5/Perl/Critic/Policy/Modules/PerlMinimumVersion.pm
/usr/share/perl5/Perl/Critic/Policy/Modules/RequirePerlVersion.pm
/usr/share/perl5/Perl/Critic/Policy/ValuesAndExpressions/RequireConstantOnLeftSideOfEquality.pm
/usr/share/perl5/Perl/Critic/Policy/ValuesAndExpressions/RestrictLongStrings.pm

See Also

Package Description
perl-Perl-Critic-Nits-1.0.0-alt1_24.noarch.rpm Policies of nits I like to pick
perl-Perl-Critic-OTRS-0.09-alt1.noarch.rpm A collection of handy Perl::Critic policies
perl-Perl-Critic-PetPeeves-JTRAMMELL-0.04-alt1_16.noarch.rpm Policies to prohibit/require my pet peeves
perl-Perl-Critic-Policy-BadStrings-1.000-alt1.noarch.rpm Search for bad strings in source files
perl-Perl-Critic-Policy-BuiltinFunctions-ProhibitDeleteOnArrays-0.02-alt1.noarch.rpm Do not use C<delete> on arrays
perl-Perl-Critic-Policy-BuiltinFunctions-ProhibitReturnOr-0.01-alt1.noarch.rpm Check for "return $x or ..."
perl-Perl-Critic-Policy-Catalyst-ProhibitUnreachableCode-0.02-alt1.noarch.rpm Don't write code after an unconditional Catalyst detach
perl-Perl-Critic-Policy-CodeLayout-ProhibitSpaceIndentation-1.02-alt1.noarch.rpm Use tabs instead of spaces for indentation
perl-Perl-Critic-Policy-CodeLayout-TabIndentSpaceAlign-1.1.0-alt1.noarch.rpm Use tabs for indenting, spaces for aligning
perl-Perl-Critic-Policy-CompileTime-0.03-alt1.noarch.rpm Find code that runs in compile-time blocks
perl-Perl-Critic-Policy-Documentation-RequirePod-0.005-alt1.noarch.rpm file requires POD
perl-Perl-Critic-Policy-Dynamic-NoIndirect-0.06-alt1.noarch.rpm Perl::Critic policy against indirect method calls
perl-Perl-Critic-Policy-HTTPCookies-0.53-alt1.noarch.rpm Avoid using HTTP::Cookies
perl-Perl-Critic-Policy-Modules-ProhibitUseLib-0.004-alt1.noarch.rpm Prohibit 'use lib' in modules
perl-Perl-Critic-Policy-Moo-ProhibitMakeImmutable-0.06-alt1.noarch.rpm Makes sure that Moo classes do not contain calls to make_immutable
Advertisement
Advertisement