perl-Perl-Lint-Git-1.1.0-alt1.noarch.rpm


Advertisement

Description

perl-Perl-Lint-Git - Connect git and Perl::Lint to blame the right people for violations

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package name perl-Perl-Lint-Git
Package version 1.1.0
Package release alt1
Package architecture noarch
Package type rpm
Installed size 29.61 KB
Download size 29.61 KB
Official Mirror ftp.altlinux.org
use Perl::Lint::Git;
_my $git_linter = Perl::Lint::Git->new(
__file => $file,
_);
_my $violations = $git_linter->report_violations(
__author => $author,                 # or undef for all
__since  => $date,                   # to lint only recent changes
_);

Alternatives

Package Version Architecture Repository
perl-Perl-Lint-Git - - -

Requires

Name Value
/usr/share/perl5 -
perl(Data/Dumper.pm) -
perl(File/Basename.pm) -
perl(Git/Repository.pm) -
perl(Perl/Lint.pm) >= 0.210
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Perl/Lint/Git.pm) = 1.001
perl-Perl-Lint-Git = 1.1.0-alt1

Download

Type URL
Binary Package perl-Perl-Lint-Git-1.1.0-alt1.noarch.rpm
Source Package perl-Perl-Lint-Git-1.1.0-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Perl-Lint-Git rpm package:
    # sudo apt-get install perl-Perl-Lint-Git

Files

Path
/usr/share/doc/perl-Perl-Lint-Git-1.1.0/Changes
/usr/share/doc/perl-Perl-Lint-Git-1.1.0/LICENSE
/usr/share/doc/perl-Perl-Lint-Git-1.1.0/README.md
/usr/share/doc/perl-Perl-Lint-Git-1.1.0/ignore.txt
/usr/share/doc/perl-Perl-Lint-Git-1.1.0/examples/examples.txt
/usr/share/perl5/Perl/
/usr/share/perl5/Perl/Lint/Git.pm

See Also

Package Description
perl-Perl-Maker-0.01-alt1.noarch.rpm Make a Custom Perl with Modules
perl-Perl-Maker-scripts-0.01-alt1.noarch.rpm Perl-Maker scripts
perl-Perl-Meta-0.03-alt1.noarch.rpm Extract metadata from perl/pod text
perl-Perl-Metric-Basic-0.31-alt1.noarch.rpm Provide basic software metrics
perl-Perl-Metrics-0.09-alt1.noarch.rpm The Perl Code Metrics System
perl-Perl-Metrics-Lite-0.08-alt1.noarch.rpm Pluggable Perl Code Metrics System
perl-Perl-Metrics-Lite-scripts-0.08-alt1.noarch.rpm Perl-Metrics-Lite scripts
perl-Perl-Metrics-Plugin-MinimumVersion-0.02-alt1.noarch.rpm Perl::Metrics plugin for Perl::MinimumVersion
perl-Perl-Metrics-Simple-0.18-alt1_12.noarch.rpm Count packages, subs, lines, etc. of many files
perl-Perl-Metrics2-0.06-alt1.noarch.rpm Perl metrics storage and processing engine
perl-Perl-Metrics2-scripts-0.06-alt1.noarch.rpm Perl-Metrics2 scripts
perl-Perl-Police-0.0.2-alt1.noarch.rpm Essentially a Code Review, on steroids
perl-Perl-PrereqScanner-Lite-0.28-alt1.noarch.rpm Lightweight Prereqs Scanner for Perl
perl-Perl-PrereqScanner-NotQuiteLite-0.97-alt1.noarch.rpm a tool to scan your Perl code for its prerequisites
perl-Perl-PrereqScanner-NotQuiteLite-scripts-0.97-alt1.noarch.rpm Perl-PrereqScanner-NotQuiteLite scripts
Advertisement
Advertisement