perl-Pod-Cpandoc-0.16-alt1_1.noarch.rpm


Advertisement

Description

perl-Pod-Cpandoc - Perldoc that works for modules you don't have installed

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package name perl-Pod-Cpandoc
Package version 0.16
Package release alt1_1
Package architecture noarch
Package type rpm
Installed size 13.45 KB
Download size 13.45 KB
Official Mirror ftp.altlinux.org
'cpandoc' is a perl script that acts like 'perldoc' except that if it would
have bailed out with 'No documentation found for "Uninstalled::Module"', it
will instead scrape a CPAN index for the module's documentation.
One important feature of 'cpandoc' is that it _only_ scrapes the live index
if you do not have the module installed. So if you use 'cpandoc' on a
module you already have installed, then it will just read the
already-installed documentation. This means that the version of the
documentation matches up with the version of the code you have. As a fringe
benefit, 'cpandoc' will be fast for modules you've installed. :)
All this means that you should be able to drop in 'cpandoc' in place of
'perldoc' and have everything keep working. See the /SNEAKY INSTALL manpage
for how to do this.

Alternatives

Package Version Architecture Repository
perl-Pod-Cpandoc - - -

Requires

Name Value
/usr/bin/env -
/usr/share/perl5 -
perl(File/Temp.pm) -
perl(HTTP/Tiny.pm) -
perl(JSON/PP.pm) -
perl(Pod/Perldoc.pm) -
perl(base.pm) -
perl-base -
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Pod/Cpandoc.pm) = 0.160
perl-Pod-Cpandoc = 0.16-alt1_1

Download

Type URL
Binary Package perl-Pod-Cpandoc-0.16-alt1_1.noarch.rpm
Source Package perl-Pod-Cpandoc-0.16-alt1_1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Pod-Cpandoc rpm package:
    # sudo apt-get install perl-Pod-Cpandoc

Files

Path
/usr/bin/cpandoc
/usr/share/doc/perl-Pod-Cpandoc-0.16/Changes
/usr/share/doc/perl-Pod-Cpandoc-0.16/META.yml
/usr/share/doc/perl-Pod-Cpandoc-0.16/README
/usr/share/man/man1/cpandoc.1.xz
/usr/share/perl5/Pod/Cpandoc.pm

See Also

Package Description
perl-Pod-Cpandoc-Cache-0.03-alt1.noarch.rpm Caching cpandoc
perl-Pod-Cpandoc-Cache-scripts-0.03-alt1.noarch.rpm Pod-Cpandoc-Cache scripts
perl-Pod-DocBook-1.2-alt1.noarch.rpm Convert Pod data to DocBook SGML
perl-Pod-DocBook-scripts-1.2-alt1.noarch.rpm Pod-DocBook scripts
perl-Pod-Elemental-MakeSelector-0.12-alt1.noarch.rpm Build complex selectors as a single sub
perl-Pod-Elemental-Transformer-ExampleRunner-0.002-alt1.noarch.rpm include/run examples scripts in your documentation without copy/paste
perl-Pod-Elemental-Transformer-Include-1.001-alt1.noarch.rpm include output via files and commands
perl-Pod-Elemental-Transformer-List-Converter-0.001-alt1.noarch.rpm Convert a list to... something else
perl-Pod-Elemental-Transformer-PPIHTML-0.093581-alt1.noarch.rpm convert "=begin perl" and shebang-marked blocks to XHTML
perl-Pod-Elemental-Transformer-Splint-0.1201-alt1.noarch.rpm Documentation from class metadata
perl-Pod-Elemental-Transformer-SynHi-0.101000-alt1.noarch.rpm a role for transforming code into syntax highlighted HTML regions
perl-Pod-Elemental-Transformer-Verbatim-0.001-alt1.noarch.rpm Transform :verbatim regions into verbatim paragraphs
perl-Pod-Elemental-Transformer-VimHTML-0.093582-alt1.noarch.rpm convert "=begin vim" regions to colorized XHTML with Vim
perl-Pod-Elemental-Transformer-WikiDoc-0.093004-alt1_3.noarch.rpm A transformer to replace "wikidoc" data regions with Pod5 elements
perl-Pod-Elide-0.003-alt1.noarch.rpm Elide POD lines from a string, with options
Advertisement
Advertisement