perl-Shell-POSIX-Select-0.08-alt1.noarch.rpm


Advertisement

Description

perl-Shell-POSIX-Select - The POSIX Shell's "select" loop for Perl

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package name perl-Shell-POSIX-Select
Package version 0.08
Package release alt1
Package architecture noarch
Package type rpm
Installed size 78.94 KB
Download size 78.94 KB
Official Mirror ftp.altlinux.org
=for comment
Resist temptation to add more spaces in line below; they cause bad wrapping for text-only document version
=for comment
The damn CPAN html renderer, which doesn't respond to
=for html or =for HTML directives (!), can't get the following
right!  It's showing the  codes!  Postscript and text work fine.
select
[ [ my | local | our ] scalar_var ]
( [LIST] )
{ [CODE] }
select [ [my|local|our] scalar_var ] ( [LIST] ) { [CODE] }
In the above, the enclosing square brackets *(not typed)* identify optional elements, and vertical bars separate mutually-exclusive choices:
The required elements are the keyword `select',
the *parentheses*, and the *curly braces*.
See the section on "SYNTAX" for details.

Alternatives

Package Version Architecture Repository
perl-Shell-POSIX-Select - - -

Requires

Name Value
/usr/share/perl5 -
perl(File/Spec/Functions.pm) >= 0.700
perl(Filter/Simple.pm) >= 0.840
perl(Text/Balanced.pm) >= 1.970
perl(re.pm) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Shell/POSIX/Select.pm) = 0.080
perl-Shell-POSIX-Select = 0.08-alt1

Download

Type URL
Binary Package perl-Shell-POSIX-Select-0.08-alt1.noarch.rpm
Source Package perl-Shell-POSIX-Select-0.08-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Shell-POSIX-Select rpm package:
    # sudo apt-get install perl-Shell-POSIX-Select

Files

Path
/usr/share/doc/perl-Shell-POSIX-Select-0.08/Changes
/usr/share/doc/perl-Shell-POSIX-Select-0.08/README
/usr/share/perl5/Shell/
/usr/share/perl5/Shell/POSIX/Select.pm

See Also

Package Description
perl-Shell-Parser-0.04-alt1.noarch.rpm Simple shell script parser
perl-Shell-Perl-0.004-alt1_2.noarch.rpm Dumpers for Shell::Perl
perl-Shell-Source-0.01-alt1.noarch.rpm perl module Shell-Source
perl-Shell-Tools-0.04-alt1.noarch.rpm Perl extension to reduce boilerplate in Perl shell scripts
perl-Shell-Verbose-0.4-alt1.noarch.rpm A verbose version of system()
perl-ShellCompleter-Util-0.030-alt1.noarch.rpm Utility routines for App::ShellCompleter::*
perl-ShellQuote-Any-Tiny-0.007-alt1.noarch.rpm Escape string for the Unix/Windows shell
perl-ShellScript-Env-0.4-alt1.noarch.rpm perl module ShellScript-Env
perl-ShiftJIS-CP932-Correct-0.06-alt1.noarch.rpm corrects a string in Windows CP-932
perl-ShiftJIS-Collate-1.10-alt1.noarch.rpm collation of Shift-JIS strings
perl-ShiftJIS-Regexp-1.03-alt1.noarch.rpm regular expressions in Shift-JIS
perl-ShipIt-0.60-alt1.noarch.rpm software release tool
perl-ShipIt-Step-ApplyYAMLChangeLogVersion-0.02-alt1.noarch.rpm apply version from YAML Changes file to modules and scripts
perl-ShipIt-Step-ChangeAllVersions-1.002-alt1.noarch.rpm Changes version information in all the modules
perl-ShipIt-Step-ChangePodVersion-0.04-alt1.noarch.rpm Keep VERSION in your Pod in sync with $VERSION
Advertisement
Advertisement