perl-Test-RequiredMinimumDependencyVersion-0.003-alt1.noarch.rpm


Advertisement

Description

perl-Test-RequiredMinimumDependencyVersion - Require a minimum version for your dependencies

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports noarch
Package filename perl-Test-RequiredMinimumDependencyVersion-0.003-alt1.noarch.rpm
Package name perl-Test-RequiredMinimumDependencyVersion
Package version 0.003
Package release alt1
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage -
License -
Maintainer -
Download size 16.25 KB
Installed size 16.25 KB
There are some modules where you'll always depend on a minimal version,
either because of a bug or because of an API change. A good example would be
Test::More where version 0.88 introduced `done_testing()' or
version which strongly urges to set 0.77 as a minimum in your code.
This test can be used to check that, whenever you use these modules, you also
declare the minimum version.
This test is an author test and should not run on end-user installations.
Recommendation is to put it into your xt instead of your t directory.

Alternatives

Package Version Architecture Repository
perl-Test-RequiredMinimumDependencyVersion - - -

Requires

Name Value
/usr/share/perl5 -
perl(Perl/PrereqScanner.pm) -
perl(Test/Builder.pm) -
perl(Test/XTFiles.pm) -
perl(version.pm) >= 0.770
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Test/RequiredMinimumDependencyVersion.pm) = 0.003
perl-Test-RequiredMinimumDependencyVersion = 0.003-alt1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-Test-RequiredMinimumDependencyVersion-0.003-alt1.noarch.rpm
Source Package perl-Test-RequiredMinimumDependencyVersion-0.003-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Test-RequiredMinimumDependencyVersion rpm package:
    # sudo apt-get install perl-Test-RequiredMinimumDependencyVersion

Files

Path
/usr/share/doc/perl-Test-RequiredMinimumDependencyVersion-0.003/CONTRIBUTING
/usr/share/doc/perl-Test-RequiredMinimumDependencyVersion-0.003/Changes
/usr/share/doc/perl-Test-RequiredMinimumDependencyVersion-0.003/LICENSE
/usr/share/doc/perl-Test-RequiredMinimumDependencyVersion-0.003/README
/usr/share/perl5/Test/RequiredMinimumDependencyVersion.pm

See Also

Package Description
perl-Test-Requires-Env-0.02-alt1.noarch.rpm Testing environments and skipping by result of the testing
perl-Test-Requires-Scanner-0.01-alt1.noarch.rpm retrieve modules specified by Test::Requires
perl-Test-Requires-Scanner-scripts-0.01-alt1.noarch.rpm Test-Requires-Scanner scripts
perl-Test-Rest-0.03-alt1.noarch.rpm Declarative test framework for RESTful web services
perl-Test-RestAPI-0.1.6-alt1.noarch.rpm Real mock of REST API
perl-Test-Retry-0.01-alt1.noarch.rpm Retry test functions on failure
perl-Test-Reuse-0.001-alt1.noarch.rpm Reusable Test::More tests in classes
perl-Test-Rinci-0.153-alt1.noarch.rpm Test Rinci metadata
perl-Test-Rinci-CmdLine-0.001-alt1.noarch.rpm Test Rinci metadata of Perinci::CmdLine scripts
perl-Test-Rinci-CmdLine-scripts-0.001-alt1.noarch.rpm Test-Rinci-CmdLine scripts
perl-Test-Rinci-scripts-0.153-alt1.noarch.rpm Test-Rinci scripts
perl-Test-Role-0.12-alt1.noarch.rpm perl module Test-Role
perl-Test-Roo-1.004-alt1.noarch.rpm Composable, reusable tests with roles and Moo
perl-Test-Roo-DataDriven-0.4.2-alt1.noarch.rpm simple data-driven tests with Test::Roo
perl-Test-Routine-0.027-alt1_4.noarch.rpm Composable units of assertion
Advertisement
Advertisement