libbtparser2-0.26-alt1_8.x86_64.rpm


Advertisement

Description

libbtparser2 - Libraries for reporting crashes to different targets

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports x86_64
Package filename libbtparser2-0.26-alt1_8.x86_64.rpm
Package name libbtparser2
Package version 0.26
Package release alt1_8
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage -
License -
Maintainer -
Download size 87.26 KB
Installed size 87.26 KB
Btparser is a backtrace parser and analyzer, which works with
backtraces produced by the GNU Project Debugger. It can parse a text
file with a backtrace to a tree of C structures, allowing to analyze
the threads and frames of the backtrace and work with them.
Btparser also contains some backtrace manipulation and extraction
routines:
- it can find a frame in the crash-time backtrace where the program
most likely crashed (a chance is that the function described in that
frame is buggy)
- it can produce a duplication hash of the backtrace, which helps to
discover that two crash-time backtraces are duplicates, triggered by
the same flaw of the code
- it can "rate" the backtrace quality, which depends on the number of
frames with and without the function name known (missing function
name is caused by missing debugging symbols)

Alternatives

Package Version Architecture Repository
libbtparser2-0.26-alt1_8.i586.rpm 0.26 i586 Autoimports
libbtparser2 - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libc.so.6(GLIBC_2.8)(64bit) -
libglib-2.0.so.0()(64bit) -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
libbtparser.so.2()(64bit) -
libbtparser2 = 0.26-alt1_8

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libbtparser2-0.26-alt1_8.x86_64.rpm
Source Package btparser-0.26-alt1_8.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus x86_64 autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libbtparser2 rpm package:
    # sudo apt-get install libbtparser2

Files

Path
/usr/lib64/libbtparser.so.2
/usr/lib64/libbtparser.so.2.2.2

See Also

Package Description
libcimcClientXML0-2.2.8-alt1_4.x86_64.rpm Standards Based Linux Instrumentation for Manageability
libcimcclient0-2.2.8-alt1_4.x86_64.rpm Standards Based Linux Instrumentation for Manageability
libclaw-1.7.4-alt1_26.x86_64.rpm C++ Library of various utility functions
libclaw-devel-1.7.4-alt1_26.x86_64.rpm Development files for Claw library
libclutter-imcontext-devel-0.1.6-alt1_12.x86_64.rpm Development files and headers for clutter-imcontext
libclutter-imcontext0.1_0-0.1.6-alt1_12.x86_64.rpm Runtime library for clutter-imcontext
libcmpiCppImpl0-2.0.3-alt1_19.x86_64.rpm CMPI C++ wrapper library
libcmpisfcc1-2.2.8-alt1_4.x86_64.rpm Standards Based Linux Instrumentation for Manageability
libcolorer-devel-0-alt1_0.beta513.x86_64.rpm Static library and header files for the colorer-take5 library
libcolorer0-0-alt1_0.beta513.x86_64.rpm Syntax highlighting and text parsing library
libconcord-1.3-alt1_10.x86_64.rpm Library to talk to Logitech Harmony universal remote controls
libconcord-devel-1.3-alt1_10.x86_64.rpm Development libraries for libconcord
libcssparser-devel-0.87-alt1_1.x86_64.rpm These are the css_parser libraries
libcssparser0-0.87-alt1_1.x86_64.rpm These are the css_parser development files
libdee-devel-1.2.7-alt3_15.x86_64.rpm Libraries and include files for developing with libdee
Advertisement
Advertisement