perl-RPi-GPIOExpander-MCP23017-1.00-alt1.1.x86_64.rpm


Advertisement

Description

perl-RPi-GPIOExpander-MCP23017 - Interface to the MCP23017 GPIO Expander Integrated Circuit over I2C

Property Value
Distribution ALT Linux Sisyphus
Repository Autoimports x86_64
Package filename perl-RPi-GPIOExpander-MCP23017-1.00-alt1.1.x86_64.rpm
Package name perl-RPi-GPIOExpander-MCP23017
Package version 1.00
Package release alt1.1
Package architecture x86_64
Package type rpm
Category Development/Perl
Homepage -
License -
Maintainer -
Download size 41.79 KB
Installed size 41.79 KB
This distribution allows you to interface with an MCP23017 (i2c based
communication) GPIO expander chip. It provides 16 GPIO digital pins.
There are two "banks" of pins, bank `0' (A) and bank `1' (B). Each bank
contains eight pins.
Pins can be accessed/modified individually, by bank, or all at once.
In this initial distribution, not all of the chip's functionality is included,
but the core functionality is. In upcoming releases, we'll add the remaining
functionality, particularly interrupts.

Alternatives

Package Version Architecture Repository
perl-RPi-GPIOExpander-MCP23017-1.00-alt1.1.i586.rpm 1.00 i586 Autoimports
perl-RPi-GPIOExpander-MCP23017 - - -

Requires

Name Value
/usr/lib64/perl5 -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libperl-5.28.so()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
perl(RPi/Const.pm) >= 1.040
perl(XSLoader.pm) -
perl(constant.pm) -
perl-base >= 1:5.10.0
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
perl(RPi/GPIOExpander/MCP23017.pm) = 1.0
perl-RPi-GPIOExpander-MCP23017 = 1.00-alt1.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-RPi-GPIOExpander-MCP23017-1.00-alt1.1.x86_64.rpm
Source Package perl-RPi-GPIOExpander-MCP23017-1.00-alt1.1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus x86_64 autoimports
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/autoimports/Sisyphus noarch autoimports
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-RPi-GPIOExpander-MCP23017 rpm package:
    # sudo apt-get install perl-RPi-GPIOExpander-MCP23017

Files

Path
/usr/lib64/perl5/RPi/
/usr/lib64/perl5/RPi/GPIOExpander/MCP23017.pm
/usr/lib64/perl5/auto/RPi/
/usr/lib64/perl5/auto/RPi/GPIOExpander/
/usr/lib64/perl5/auto/RPi/GPIOExpander/MCP23017/MCP23017.so
/usr/share/doc/perl-RPi-GPIOExpander-MCP23017-1.00/Changes
/usr/share/doc/perl-RPi-GPIOExpander-MCP23017-1.00/README
/usr/share/doc/perl-RPi-GPIOExpander-MCP23017-1.00/TODO

See Also

Package Description
perl-RPi-I2C-2.3608-alt1.x86_64.rpm Interface to the I2C bus
perl-RPi-RTC-DS3231-0.01-alt1.1.x86_64.rpm Interface to the DS3231 Real-Time Clock IC over I2C
perl-RPi-Serial-3.00-alt1.x86_64.rpm Basic read/write interface to a serial port
perl-RPi-SysInfo-1.00-alt1.x86_64.rpm Retrieve hardware system information from a Raspberry Pi
perl-RTF-HTMLConverter-0.05-alt4.1.x86_64.rpm Converter from RTF format to HTML
perl-Razor2-Client-Agent-2.86-alt1.x86_64.rpm Collaborative, content-based spam filtering network agent
perl-Razor2-Client-Agent-scripts-2.86-alt1.x86_64.rpm Razor2-Client-Agent scripts
perl-ReadDir-0.03-alt4.1.x86_64.rpm perl module ReadDir
perl-Redis-Fast-0.25-alt1.x86_64.rpm Perl binding for Redis database
perl-Redis-Jet-0.08-alt3.1.x86_64.rpm Yet another XS implemented Redis Client
perl-Redis-Parser-XS-0.02-alt5.1.x86_64.rpm unified redis protocol parser
perl-Redis-hiredis-0.11.0-alt4.1.x86_64.rpm interact with Redis using the hiredis client
perl-RedisDB-Parser-2.23-alt1.1.x86_64.rpm Redis protocol parser
perl-Ref-Store-0.20-alt4.1.x86_64.rpm Store objects, index by object, tag by objects - all without
perl-Regexp-Compare-0.31-alt1.x86_64.rpm partial ordering for regular expressions
Advertisement
Advertisement