gem-psych-3.1.0-alt1.i586.rpm


Advertisement

Description

gem-psych - A libyaml wrapper for Ruby

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename gem-psych-3.1.0-alt1.i586.rpm
Package name gem-psych
Package version 3.1.0
Package release alt1
Package architecture i586
Package type rpm
Category Development/Ruby
Homepage -
License -
Maintainer -
Download size 270.38 KB
Installed size 270.38 KB
Psych is a YAML parser and emitter. Psych leverages libyaml for its YAML parsing
and emitting capabilities. In addition to wrapping libyaml, Psych also knows how
to serialize and de-serialize most Ruby objects to and from the YAML format.

Alternatives

Package Version Architecture Repository
gem-psych-3.1.0-alt1.x86_64.rpm 3.1.0 x86_64 Classic
gem-psych - - -

Requires

Name Value
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3.4) -
libruby.so.2.5 -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -
ruby >= 2.2.2
ruby(2.5.0) -
rubygems >= 0

Provides

Name Value
gem(psych) = 3.1.0
gem-psych = 3.1.0-alt1:sisyphus+224856.1100.2.1
ruby-gem(psych) = 3.1.0
rubygem(psych) = 3.1.0

Download

Type URL
Mirror ftp.altlinux.org
Binary Package gem-psych-3.1.0-alt1.i586.rpm
Source Package gem-psych-3.1.0-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install gem-psych rpm package:
    # sudo apt-get install gem-psych

Files

Path
/usr/lib/ruby/gems/2.5.0/extensions/i586-linux/2.5.0/psych-3.1.0/gem.build_complete
/usr/lib/ruby/gems/2.5.0/extensions/i586-linux/2.5.0/psych-3.1.0/psych.so
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/.travis.yml
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/CHANGELOG.rdoc
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/Gemfile
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/Mavenfile
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/README.md
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/Rakefile
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/psych.gemspec
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych_jars.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/class_loader.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/coder.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/core_ext.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/exception.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/handler.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/nodes.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/omap.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/parser.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/scalar_scanner.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/set.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/stream.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/streaming.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/syntax_error.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/tree_builder.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/versions.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/visitors.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/y.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/handlers/document_stream.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/handlers/recorder.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/json/ruby_events.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/json/stream.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/json/tree_builder.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/json/yaml_events.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/nodes/alias.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/nodes/document.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/nodes/mapping.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/nodes/node.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/nodes/scalar.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/nodes/sequence.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/nodes/stream.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/visitors/depth_first.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/visitors/emitter.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/visitors/json_tree.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/visitors/to_ruby.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/visitors/visitor.rb
/usr/lib/ruby/gems/2.5.0/gems/psych-3.1.0/lib/psych/visitors/yaml_tree.rb
/usr/lib/ruby/gems/2.5.0/specifications/psych-3.1.0.gemspec

Changelog

2019-02-28 - Pavel Skrylev <majioa@altlinux.org> 3.1.0-alt1
- Initial build for Sisyphus, packaged as a gem with usage Ruby Policy 2.0.

See Also

Package Description
gem-puma-3.12.1-alt1.i586.rpm A Ruby/Rack web server built for concurrency (gem)
gem-rdiscount-2.2.0.1-alt3.i586.rpm Code for the rdiscount gem
gem-ruby-prof-0.17.0-alt2.i586.rpm Fast code profiler for Ruby
gem-thin-1.7.2-alt1.i586.rpm A very fast & simple Ruby web server
gem-unicorn-5.5.1-alt1.i586.rpm Library code for unicorn gem
gem-vte-3.3.6-alt1.i586.rpm Ruby/VTE is a Ruby binding of VTE
gemdropx-0.9-alt6_20.i586.rpm Falling blocks puzzlegame
gemrb-0.8.5-alt1_1.i586.rpm Port of the original Infinity (Game) Engine
generatorrunner-0.6.17-alt2.git20130522.i586.rpm Development of binding generators for C++ and Qt-based libraries
genext2fs-1.4.1-alt2.i586.rpm genext2fs creates a virtual ext2 file system in a single file
gengetopt-2.22.6-alt1.i586.rpm Tool to write command line option parsing code for C programs
genisoimage-1.1.11-alt1.qa1.i586.rpm A command line utility to create an ISO9660/Joliet/HFS filesystem
genius-1.0.24-alt2.i586.rpm Genius Calculator
genromfs-0.5.2-alt0.3.i586.rpm Utility for creating romfs filesystems
gens-gs-2.16.7-alt1.i586.rpm Sega Genesis, Sega CD, and Sega 32X emulator
Advertisement
Advertisement