ifplugd-0.28-alt5.i586.rpm


Advertisement

Description

ifplugd - Detect and perform actions when an ethernet cable is (un)plugged

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename ifplugd-0.28-alt5.i586.rpm
Package name ifplugd
Package version 0.28
Package release alt5
Package architecture i586
Package type rpm
Category System/Configuration/Networking
Homepage -
License -
Maintainer -
Download size 93.26 KB
Installed size 93.26 KB
ifplugd is a service which will automatically configure your ethernet device
when a cable is plugged in and automatically unconfigure it if the cable is
pulled.
This is useful on laptops with onboard network adapters, since it will only
configure the interface when a cable is really connected.
NB: not every Linux ethernet driver is capable of reporting link status.
Use ifplugstatus to find out.

Alternatives

Package Version Architecture Repository
ifplugd-0.28-alt5.x86_64.rpm 0.28 x86_64 Classic
ifplugd - - -

Requires

Name Value
/etc/rc.d/init.d -
/etc/rc.d/init.d(SourceIfNotEmpty) -
/etc/rc.d/init.d(failure) -
/etc/rc.d/init.d(msg_usage) -
/etc/rc.d/init.d(start_daemon) -
/etc/rc.d/init.d(status) -
/etc/rc.d/init.d(stop_daemon) -
/etc/rc.d/init.d(success) -
/etc/rc.d/init.d/functions -
/lib/ld-linux.so.2 -
/usr/sbin/post_service -
/usr/sbin/preun_service -
coreutils -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.15) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libdaemon -
libdaemon.so.0 -
network-config-subsystem -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -
service -
util-linux -

Provides

Name Value
ifplugd = 0.28-alt5

Download

Type URL
Mirror ftp.altlinux.org
Binary Package ifplugd-0.28-alt5.i586.rpm
Source Package ifplugd-0.28-alt5.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install ifplugd rpm package:
    # sudo apt-get install ifplugd

Files

Path
/etc/ifplugd/ifplugd.action
/etc/ifplugd/ifplugd.conf
/etc/rc.d/init.d/ifplugd
/usr/sbin/ifplugd
/usr/sbin/ifplugstatus
/usr/share/doc/ifplugd-0.28/NEWS
/usr/share/doc/ifplugd-0.28/README
/usr/share/doc/ifplugd-0.28/README.html
/usr/share/doc/ifplugd-0.28/SUPPORTED_DRIVERS
/usr/share/doc/ifplugd-0.28/style.css
/usr/share/man/man5/ifplugd.conf.5.xz
/usr/share/man/man8/ifplugd.8.xz
/usr/share/man/man8/ifplugstatus.8.xz

Changelog

2018-06-05 - Michael Shigorin <mike@altlinux.org> 0.28-alt5
- converted spec to ru_RU.UTF-8
- minor spec cleanup
2013-04-17 - Dmitry V. Levin (QA) <qa_ldv@altlinux.org> 0.28-alt4.qa1
- NMU: rebuilt for debuginfo.
2008-01-21 - Michael Shigorin <mike@altlinux.org> 0.28-alt4
- added Gentoo patch to fix build with current includes
- small spec cleanups

See Also

Package Description
ifrename-29-alt11.i586.rpm wireless-tools tool renames network interfaces
ifstat-1.1-alt1.qa1.i586.rpm InterFace STATistics
iftop-0.17-alt5.i586.rpm Display bandwidth usage on an interface
ifuse-1.1.3-alt4.i586.rpm Filesystem access for the iPhone and iPod Touch
igmpproxy-0.1-alt1.qa1.i586.rpm Dynamic Multicast Routing Daemon
ignoreflock-1-alt2.i586.rpm A small wrapper to disable flock function
iio-sensor-proxy-2.8-alt1.i586.rpm IIO sensors to input device proxy
ike-scan-1.9-alt2.1.i586.rpm IKE protocol tool to discover, fingerprint and test IPsec VPN servers
ilbc-devel-1.1.1-alt2.i586.rpm development files for ilbc
ilmbase-2.3.0-alt1.i586.rpm A high-dynamic-range image file library
ilmbase-devel-2.3.0-alt1.i586.rpm Headers for developing programs that will use ilmbase
ilmbase12-2.2.0-alt2.i586.rpm A high-dynamic-range image file library
ilmbase12-common-2.2.0-alt2.i586.rpm Common empty package for ilmbase12
ilmbase12-devel-2.2.0-alt2.i586.rpm Headers for developing programs that will use ilmbase12
ilmbase24-common-2.3.0-alt1.i586.rpm Common empty package for ilmbase
Advertisement
Advertisement