kumir-console-1.7.2-alt2.i586.rpm


Advertisement

Description

kumir-console - Console interpreter of Kumir programming language

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename kumir-console-1.7.2-alt2.i586.rpm
Package name kumir-console
Package version 1.7.2
Package release alt2
Package architecture i586
Package type rpm
Category Education
Homepage -
License -
Maintainer -
Download size 1.06 MB
Installed size 1.06 MB
Console interpreter of Kumir programming language. Useful for running
Kumir programs from command line. May be used in programming contest
control system, such as ejudge.

Alternatives

Package Version Architecture Repository
kumir-console-1.7.2-alt2.x86_64.rpm 1.7.2 x86_64 Classic
kumir-console - - -

Requires

Name Value
/lib/ld-linux.so.2 -
libQtCore.so.4 -
libQtScript.so.4 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3.4) -
libgcc_s.so.1(GCC_3.0) -
libm.so.6(GLIBC_2.0) -
libqt4-core -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
kumir-console = 1.7.2-alt2

Download

Type URL
Mirror ftp.altlinux.org
Binary Package kumir-console-1.7.2-alt2.i586.rpm
Source Package kumir-console-1.7.2-alt2.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install kumir-console rpm package:
    # sudo apt-get install kumir-console

Files

Path
/usr/bin/ckumir
/usr/share/kumir/
/usr/share/kumir/languages/english.keywords
/usr/share/kumir/languages/english.lang
/usr/share/kumir/languages/english.msg
/usr/share/kumir/languages/russian.keywords
/usr/share/kumir/languages/russian.lang
/usr/share/kumir/languages/russian.msg
/usr/share/kumir/pdscripts/00-common.rules
/usr/share/kumir/pdscripts/07-garbage.rules
/usr/share/kumir/pdscripts/09-wrong_switch.rules
/usr/share/kumir/pdscripts/10-open_keywords.rules
/usr/share/kumir/pdscripts/20-wrong_constructions.rules
/usr/share/kumir/pdscripts/91-extra_keywords.rules
/usr/share/kumir/pdscripts/92-extra_keywords.rules
/usr/share/kumir/pdscripts/pd_init.js

Changelog

2016-02-22 - Denis Kirienko <dk@altlinux.org> 1.7.2-alt2
- Build fix
2013-04-15 - Dmitry V. Levin (QA) <qa_ldv@altlinux.org> 1.7.2-alt1.qa1
- NMU: rebuilt for debuginfo.
2010-12-01 - Denis Kirienko <dk@altlinux.ru> 1.7.2-alt1
- Initial build for Sisyphus

See Also

Package Description
kumir2-2.1.0-alt7.gita3631abb.i586.rpm New version of Kumir - simple programming language and IDE for teaching programming
kumir2-devel-2.1.0-alt7.gita3631abb.i586.rpm Development files for Kumir
kuzya-2.1.12_rc20170720-alt1.qa1.i586.rpm Integrated Development Environment for students
kvmtool-3.18.0-alt2.git.fdd26ecb.i586.rpm Linux Native KVM Tool
kvpnc-0.9.6-alt5.i586.rpm KDE frontend for various vpn clients
kyotocabinet-utils-1.2.76-alt3.i586.rpm Command line tools for managing kyotocabinet databases
labcurves-20100709-alt5.i586.rpm L*a*b curves for GIMP
labplot-2.6.0-alt1.i586.rpm Function and Data Plotter
lacewing-1.10-alt2_31.i586.rpm Arcade-style shoot-em-up
ladspa-blop-plugins-0.2.8-alt2.qa1.i586.rpm Bandlimited LADSPA Oscillator Plugins
ladspa-caps-plugins-0.9.24-alt4_6.i586.rpm The C* Audio Plugin Suite
ladspa-dssi-vst-0.9-alt1.git20140805.i586.rpm LADSPA plugin wrapper for VST plugins
ladspa-flattendynamics-0.0-alt1.hg20140723.i586.rpm Crude pre-processing to flatten out the RMS level of a signal
ladspa-guitar-preamp-1.0-alt1.1.qa1.i586.rpm LADSPA plugin to simulate guitar preamp
ladspa-guitar-super-60-1.0-alt1.1.qa1.i586.rpm LADSPA plugin to simulate Fender Super 60 amp
Advertisement
Advertisement