libconfig-1.5-alt2.i586.rpm


Advertisement

Description

libconfig - C/C++ Configuration File Library

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename libconfig-1.5-alt2.i586.rpm
Package name libconfig
Package version 1.5
Package release alt2
Package architecture i586
Package type rpm
Category System/Libraries
Homepage -
License -
Maintainer -
Download size 76.78 KB
Installed size 76.78 KB
Libconfig is a simple library for manipulating structured configuration
files, like this one: test.cfg. This file format is more compact and
more readable than XML. And unlike XML, it is type-aware, so it is not
necessary to do string parsing in application code.
Libconfig is very compact thus well-suited for memory constrained
systems like handheld devices.
The library includes bindings for both the C and C++ languages. It works
on POSIX-compliant UNIX systems (GNU/Linux, Mac OS X, Solaris, FreeBSD)
and Windows (2000, XP and later).

Alternatives

Package Version Architecture Repository
libconfig-1.5-alt2.x86_64.rpm 1.5 x86_64 Classic
libconfig - - -

Requires

Name Value
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
rpmlib(PayloadIsLzma) -
rtld(GNU_HASH) -

Provides

Name Value
libconfig = 1.5-alt2
libconfig.so.9 -

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libconfig-1.5-alt2.i586.rpm
Source Package libconfig-1.5-alt2.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libconfig rpm package:
    # sudo apt-get install libconfig

Files

Path
/usr/lib/libconfig.so.9
/usr/lib/libconfig.so.9.2.0
/usr/share/doc/libconfig-1.5/AUTHORS
/usr/share/doc/libconfig-1.5/ChangeLog
/usr/share/doc/libconfig-1.5/NEWS
/usr/share/doc/libconfig-1.5/README
/usr/share/doc/libconfig-1.5/TODO

Changelog

2018-06-08 - Aleksei Nikiforov <darktemplar@altlinux.org> 1.5-alt2
- NMU: rebuilt to regenerate ABI.
2015-12-03 - Igor Vlasenko <viy@altlinux.ru> 1.5-alt1.1
- NMU: added BR: texinfo
2015-09-28 - Michael Shigorin <mike@altlinux.org> 1.5-alt1
- new version 1.5
2015-06-12 - Gleb F-Malinovskiy <glebfm@altlinux.org> 1.4.9-alt1.1
- Rebuilt for gcc5 C++11 ABI.
2014-06-19 - Michael Shigorin <mike@altlinux.org> 1.4.9-alt1
- new version 1.4.9
2011-10-08 - Michael Shigorin <mike@altlinux.org> 1.4.8-alt2
- whoops, forgot to commit the tested spec changes
2011-10-08 - Michael Shigorin <mike@altlinux.org> 1.4.8-alt1
- 1.4.8 (thx fedorawatch)
- dropped libconfig_tests from main subpackage
(no more installed by upstream makefile)
2011-04-18 - Michael Shigorin <mike@altlinux.org> 1.4.7-alt1
- 1.4.7 (thx led@)
2011-04-18 - Michael Shigorin <mike@altlinux.org> 1.4.6-alt4
- introduced conditional static library build, enabled by default
2011-03-21 - Michael Shigorin <mike@altlinux.org> 1.4.6-alt3
- fixed packaging soname links in c++ subpackage (closes: #25266)
+ thanks snejok@ for investigation/report

See Also

Package Description
libconfig-c++-1.5-alt2.i586.rpm C++ Configuration File Library
libconfig-c++-devel-1.5-alt2.i586.rpm Header files for libconfig++ library
libconfig-c++-devel-static-1.5-alt2.i586.rpm Static library files for libconfig++
libconfig-devel-1.5-alt2.i586.rpm Header files for libconfig
libconfig-devel-static-1.5-alt2.i586.rpm Static library files for libconfig
libconfuse-2.7-alt1.1.i586.rpm Dynamic libraries from confuse
libconfuse-devel-2.7-alt1.1.i586.rpm Files for developing applications that use confuse
libcontrol++-0.23.0-alt1.i586.rpm control++ common classes and functions library
libconvert3d-1.1.0-alt1.git61a9bf2.i586.rpm Convert 3D images between common file formats
libconvert3d-devel-1.1.0-alt1.git61a9bf2.i586.rpm Convert 3D images between common file formats
libcoredumper-1.2.1-alt2.3.i586.rpm Library to create core dumps of the running program
libcoredumper-devel-1.2.1-alt2.3.i586.rpm Development files of coredumper library
libcoredumper-devel-static-1.2.1-alt2.3.i586.rpm Static coredumper library
libcorosync-3.0.2-alt3.i586.rpm The Corosync Cluster Engine Libraries
libcorosync-devel-3.0.2-alt3.i586.rpm The Corosync Cluster Engine Development Kit
Advertisement
Advertisement