libcourier-authlib-devel-0.66.4-alt0.3.i586.rpm


Advertisement

Description

libcourier-authlib-devel - Development libraries for the Courier authentication library

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename libcourier-authlib-devel-0.66.4-alt0.3.i586.rpm
Package name libcourier-authlib-devel
Package version 0.66.4
Package release alt0.3
Package architecture i586
Package type rpm
Category Development/C
Homepage -
License -
Maintainer -
Download size 50.15 KB
Installed size 50.15 KB
This package contains the development libraries and files needed to compile
Courier packages that use this authentication library.  Install this
package in order to build the rest of the Courier packages.  After they are
built and installed this package can be removed.  Files in this package
are not needed at runtime.

Alternatives

Package Version Architecture Repository
libcourier-authlib-devel-0.66.4-alt0.3.x86_64.rpm 0.66.4 x86_64 Classic
libcourier-authlib-devel - - -

Requires

Name Value
libcourier-authlib = 0.66.4-alt0.3:sisyphus+224119.100.1.1
rpmlib(PayloadIsLzma) -

Provides

Name Value
libcourier-authlib-devel = 0.66.4-alt0.3:sisyphus+224119.100.1.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libcourier-authlib-devel-0.66.4-alt0.3.i586.rpm
Source Package courier-authlib-0.66.4-alt0.3.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libcourier-authlib-devel rpm package:
    # sudo apt-get install libcourier-authlib-devel

Files

Path
/usr/bin/courierauthconfig
/usr/include/courier-authlib/courier_auth_config.h
/usr/include/courier-authlib/courierauth.h
/usr/include/courier-authlib/courierauthdebug.h
/usr/include/courier-authlib/courierauthsasl.h
/usr/include/courier-authlib/courierauthsaslclient.h
/usr/include/courier-authlib/courierauthstaticlist.h
/usr/lib/libcourierauth.so
/usr/lib/libcourierauthcommon.so
/usr/lib/courier-authlib/libcourierauth.so
/usr/lib/courier-authlib/libcourierauthcommon.so
/usr/lib/courier-authlib/libcourierauthsasl.so
/usr/lib/courier-authlib/libcourierauthsaslclient.so
/usr/share/man/man3/auth_enumerate.3.xz
/usr/share/man/man3/auth_generic.3.xz
/usr/share/man/man3/auth_getoption.3.xz
/usr/share/man/man3/auth_getuserinfo.3.xz
/usr/share/man/man3/auth_login.3.xz
/usr/share/man/man3/auth_mkhomedir.3.xz
/usr/share/man/man3/auth_passwd.3.xz
/usr/share/man/man3/auth_sasl.3.xz
/usr/share/man/man3/auth_sasl_ex.3.xz
/usr/share/man/man3/authlib.3.xz

Changelog

2017-01-09 - L.A. Kostis <lakostis@altlinux.ru> 0.66.4-alt0.3
- .spec: cleanups:
+ fixed unowned dirs, added *config to -devel.
+ fixed include dir location.
+ fixed std plugins (leave *.so).
2017-01-05 - L.A. Kostis <lakostis@altlinux.ru> 0.66.4-alt0.2
- Rebuild with libidn.
- Added systemd service unit.
- Updated README.ALT
- Fixed -alt-makefiles patch.
2017-01-04 - L.A. Kostis <lakostis@altlinux.ru> 0.66.4-alt0.1
- Updated to 0.66.4.
- Re-diffed -alt patches.
- Enabled sqlite support.
2013-04-14 - Dmitry V. Levin (QA) <qa_ldv@altlinux.org> 0.63.0-alt0.2.qa1
- NMU: rebuilt with libmysqlclient.so.18.
2012-01-16 - L.A. Kostis <lakostis@altlinux.ru> 0.63.0-alt0.2
- rebuild for soname set-versions.
2010-10-13 - L.A. Kostis <lakostis@altlinux.ru> 0.63.0-alt0.1
- 0.63.0.
- rebuild with new libmysqlclient and libssl.
2009-08-31 - L.A. Kostis <lakostis@altlinux.ru> 0.62.4-alt0.1
- 0.62.4.
2009-05-15 - L.A. Kostis <lakostis@altlinux.ru> 0.62.2-alt0.1
- NMU:
+ new version 0.62.2.
+ remove obsoleted macros.
+ update -dat2db and -alt-makefiles patch.
2008-09-06 - Dmitry Lebkov <dlebkov@altlinux.ru> 0.61.0-alt1
- 0.61.0

See Also

Package Description
libcoverart-1.0.0-alt3.i586.rpm Cover Art Archive Client Library
libcoverart-devel-1.0.0-alt3.i586.rpm Development files for libcoverart
libcp_dbms_mysql0-0.1.12-alt1_15.1.i586.rpm MySQL (MariaDB) dbms driver for libcprops
libcp_dbms_postgres0-0.1.12-alt1_15.1.i586.rpm PostgreSQL dbms driver for libcprops
libcpath-20130809-alt1.i586.rpm Library for cross-platform C path functions
libcpath-devel-20130809-alt1.i586.rpm Development files for libcpath, a cross-platform C path library
libcpp-hocon-0.2.1-alt3.i586.rpm A C++ port of the Typesafe Config library
libcpp-hocon-devel-0.2.1-alt3.i586.rpm cpp-hocon development libraries
libcppkafka-0.3.1-alt1.i586.rpm high level C++ wrapper for rdkafka
libcppkafka-devel-0.3.1-alt1.i586.rpm Developmen environment for libcppkafka
libcpprest-2.10.14-alt1.i586.rpm C++ REST library
libcpprest-devel-2.10.14-alt1.i586.rpm Development files for cpprest
libcpptest-1.1.2-alt1.i586.rpm CppTest is a unit testing framework for handling automated tests in C++
libcpptest-devel-1.1.2-alt1.i586.rpm Header files for libcpptest
libcprops-devel-0.1.12-alt1_15.1.i586.rpm Development files for libcprops
Advertisement
Advertisement