libexiv2-0.27.2-alt1.i586.rpm


Advertisement

Description

libexiv2 - EXIF and IPTC metadata manipulation library

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename libexiv2-0.27.2-alt1.i586.rpm
Package name libexiv2
Package version 0.27.2
Package release alt1
Package architecture i586
Package type rpm
Category Graphics
Homepage -
License -
Maintainer -
Download size 2.83 MB
Installed size 2.83 MB
libexiv2 is a C++ library to access image metadata.

Alternatives

Package Version Architecture Repository
libexiv2-0.27.2-alt1.x86_64.rpm 0.27.2 x86_64 Classic
libexiv2 - - -

Requires

Name Value
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libexpat.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GLIBC_2.0) -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.27) -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.9) -
libz.so.1 -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
libexiv2 = 0.27.2-alt1:sisyphus+235858.100.1.1
libexiv2.so.27 -

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libexiv2-0.27.2-alt1.i586.rpm
Source Package exiv2-0.27.2-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libexiv2 rpm package:
    # sudo apt-get install libexiv2

Files

Path
/usr/lib/libexiv2.so.0.27.2
/usr/lib/libexiv2.so.27

Changelog

2019-08-10 - Yuri N. Sedunov <aris@altlinux.org> 0.27.2-alt1
- 0.27.2
2019-04-01 - Michael Shigorin <mike@altlinux.org> 0.26-alt3
- E2K: tweaked CVE-2017-17725 patch to fix ftbfs with lcc-1.23
2018-08-07 - Yuri N. Sedunov <aris@altlinux.org> 0.26-alt2
- applied set of fc/upstream patches (fixed CVE-2017-11683,
CVE-2017-14859, CVE-2017-14860, CVE-2017-14862,
CVE-2017-14864, CVE-2017-17669, CVE-2017-17723,
CVE-2017-17725, CVE-2018-10958, CVE-2018-10998,
CVE-2018-11531, CVE-2018-12264, CVE-2018-12265,
CVE-2018-14046, CVE-2018-5772, CVE-2018-8976,
CVE-2018-8977)
2017-05-07 - Yuri N. Sedunov <aris@altlinux.org> 0.26-alt1
- 0.26
2015-06-28 - Yuri N. Sedunov <aris@altlinux.org> 0.25-alt1
- 0.25
- explicitly enabled video files and WebReady support
2015-06-15 - Gleb F-Malinovskiy <glebfm@altlinux.org> 0.24-alt1.1
- Rebuilt for gcc5 C++11 ABI.
2013-12-02 - Yuri N. Sedunov <aris@altlinux.org> 0.24-alt1
- 0.24
2012-05-13 - Yuri N. Sedunov <aris@altlinux.org> 0.23-alt1
- 0.23
- fixed interpackage dependencies
- enabled LFS support
2012-02-02 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 0.22-alt1.1
- Removed bad RPATH
2011-09-22 - Yuri N. Sedunov <aris@altlinux.org> 0.22-alt1
- 0.22

See Also

Package Description
libexiv2-devel-0.27.2-alt1.i586.rpm Headers and links to compile against the exiv2 library
libexo-0.12.8-alt1.i586.rpm Extension library to Xfce
libexo-devel-0.12.8-alt1.i586.rpm Development files for libexo
libexo-gtk3-0.12.8-alt1.i586.rpm Extension library to Xfce (GTK+3 version)
libexo-gtk3-devel-0.12.8-alt1.i586.rpm Development files for libexo-gtk3
libexodusii-6.09.0-alt3.git20150119.i586.rpm Shared libraries of EXODUS II
libexodusii-devel-6.09.0-alt3.git20150119.i586.rpm Development files of EXODUS II
libexosip2-devel-5.0.0-alt1_2.i586.rpm Header files and static libraries from exosip
libexosip2_12-5.0.0-alt1_2.i586.rpm Dynamic libraries from exosip
libexpat-2.2.4-alt1.i586.rpm XML parser library
libexpat-devel-2.2.4-alt1.i586.rpm Development files for Expat, an XML parser library for C
libexplain-1.4-alt1.i586.rpm Library functions to explain system call errors
libexplain-devel-1.4-alt1.i586.rpm Development files for libexplain
libextractor-1.9-alt2.i586.rpm libextractor is a simple library for keyword extraction
libextractor-devel-1.9-alt2.i586.rpm libextractor development files and libraries
Advertisement
Advertisement