libflowcanvas-devel-0.7.1-alt2.i586.rpm


Advertisement

Description

libflowcanvas-devel - Headers for libflowcanvas

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename libflowcanvas-devel-0.7.1-alt2.i586.rpm
Package name libflowcanvas-devel
Package version 0.7.1
Package release alt2
Package architecture i586
Package type rpm
Category Development/C
Homepage -
License -
Maintainer -
Download size 31.97 KB
Installed size 31.97 KB
Headers for building software that uses libflowcanvas

Alternatives

Package Version Architecture Repository
libflowcanvas-devel-0.7.1-alt2.x86_64.rpm 0.7.1 x86_64 Classic
libflowcanvas-devel - - -

Requires

Name Value
/usr/lib/pkgconfig -
boost-devel-headers -
fontconfig-devel -
glib2-devel -
libart_lgpl-devel -
libatk-devel -
libatkmm-devel -
libcairo-devel -
libcairomm-devel -
libflowcanvas = 0.7.1-alt2
libfreetype-devel -
libgdk-pixbuf-devel -
libgio-devel -
libglibmm-devel -
libgnomecanvas-devel -
libgnomecanvasmm-devel -
libgtk+2-devel -
libgtkmm2-devel -
libpango-devel -
libpangomm-devel -
libsigc++2-devel -
rpmlib(PayloadIsLzma) -

Provides

Name Value
libflowcanvas-devel = 0.7.1-alt2
pkgconfig(flowcanvas) = 0.7.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libflowcanvas-devel-0.7.1-alt2.i586.rpm
Source Package libflowcanvas-0.7.1-alt2.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libflowcanvas-devel rpm package:
    # sudo apt-get install libflowcanvas-devel

Files

Path
/usr/include/flowcanvas/Canvas.hpp
/usr/include/flowcanvas/Connectable.hpp
/usr/include/flowcanvas/Connection.hpp
/usr/include/flowcanvas/Ellipse.hpp
/usr/include/flowcanvas/Item.hpp
/usr/include/flowcanvas/Module.hpp
/usr/include/flowcanvas/Port.hpp
/usr/include/flowcanvas/flowcanvas.hpp
/usr/include/flowcanvas/types.hpp
/usr/lib/libflowcanvas.so
/usr/lib/pkgconfig/flowcanvas.pc

Changelog

2015-10-07 - Andrey Cherepanov <cas@altlinux.org> 0.7.1-alt2
- Fix build with gcc5
2015-06-12 - Gleb F-Malinovskiy <glebfm@altlinux.org> 0.7.1-alt1.1
- Rebuilt for gcc5 C++11 ABI.
2014-08-07 - Michael Shigorin <mike@altlinux.org> 0.7.1-alt1
- NMU: 0.7.1 (NB: deprecated upstream)
- re-enabled graphviz-2.30+ support (thanks debian for libcgraph patch)
- dropped doc subpackage (argh, that waf is yet another NIH crap)
- dropped static subpackage (waf crap again, and was disabled anyways)
- buildreq
2014-04-24 - Michael Shigorin <mike@altlinux.org> 0.5.1-alt3
- NMU: rebuilt without graphviz support (cgraph migration in 2.30)
2011-09-25 - Michael Shigorin <mike@altlinux.org> 0.5.1-alt2
- NMU: rebuilt with current graphviz
2010-11-27 - Igor Vlasenko <viy@altlinux.ru> 0.5.1-alt1.qa1
- rebuild using girar-nmu to require/provide setversion
by request of mithraen@
2009-08-03 - Timur Batyrshin <erthad@altlinux.org> 0.5.1-alt1
- Initial build for sisyphus

See Also

Package Description
libfltk-devel-1.3.5-alt0.1.rc1.i586.rpm Development environment for multiplatform C++ GUI Fast Light ToolKit
libfltk13-1.3.5-alt0.1.rc1.i586.rpm Multiplatform C++ GUI Fast Light ToolKit
libfluidsynth-2.0.7-alt1.i586.rpm Shared libraries for fluidsynth
libfluidsynth-devel-2.0.7-alt1.i586.rpm Development environment for fluidsynth
libfm-devel-1.3.1-alt2.i586.rpm Development files for libfm
libfm-qt-0.14.1-alt2.i586.rpm Core library of PCManFM-Qt file manager
libfm-qt-devel-0.14.1-alt2.i586.rpm Development files for libfm-qt
libfm4-1.3.1-alt2.i586.rpm Core library of PCManFM file manager
libfmt-5.3.0-alt1.i586.rpm An open-source formatting library for C++
libfmt-devel-5.3.0-alt1.i586.rpm An open-source formatting library for C++
libfolderarchivesettings5-19.08.1-alt1.i586.rpm KF5 library
libfolks-0.13.1-alt1.i586.rpm GObject contact aggregation library
libfolks-devel-0.13.1-alt1.i586.rpm Development files for libfolks
libfolks-gir-0.13.1-alt1.i586.rpm GObject introspection data for the folks library
libfontenc-1.1.4-alt1.i586.rpm The fontenc Library
Advertisement
Advertisement