libgd3-2.2.5-alt3.i586.rpm


Advertisement

Description

libgd3 - A graphics library for drawing image files in various formats

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename libgd3-2.2.5-alt3.i586.rpm
Package name libgd3
Package version 2.2.5
Package release alt3
Package architecture i586
Package type rpm
Category System/Libraries
Homepage -
License -
Maintainer -
Download size 405.63 KB
Installed size 405.63 KB
Gd is a graphics library for drawing image files in various formats.  Gd
allows your code to quickly draw images (lines, arcs, text, multiple colors,
cutting and pasting from other images, flood fills) and write out the result
as a jpeg, png or wbmp file.  Gd is particularly useful in web applications,
where jpeg, png or wbmp files are commonly used as inline images.  Note,
however, that Gd is not a paint program.

Alternatives

Package Version Architecture Repository
libgd3-2.2.5-alt3.x86_64.rpm 2.2.5 x86_64 Classic
libgd3 - - -

Requires

Name Value
libXpm.so.4 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.11) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libc.so.6(GLIBC_2.7) -
libfontconfig.so.1 -
libfreetype.so.6 -
libjpeg.so.62 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libpng16.so.16 -
libpng16.so.16(PNG16_0) -
libtiff.so.5 -
libwebp.so.7 -
libz.so.1 -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
libgd.so.3 -
libgd3 = 2.2.5-alt3:sisyphus+226800.200.2.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libgd3-2.2.5-alt3.i586.rpm
Source Package gd3-2.2.5-alt3.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libgd3 rpm package:
    # sudo apt-get install libgd3

Files

Path
/usr/lib/libgd.so.3
/usr/lib/libgd.so.3.0.5
/usr/share/doc/libgd3-2.2.5/COPYING

Changelog

2019-04-07 - Michael Shigorin <mike@altlinux.org> 2.2.5-alt3
- Fix build on aarch64 (gdimagegrayscale/basic test fails alike to i586).
- Drop %ubt macro.
- Minor spec cleanup.
2018-05-04 - Aleksei Nikiforov <darktemplar@altlinux.org> 2.2.5-alt2
- Updated provides/conflicts/obsoletes.
2018-04-17 - Aleksei Nikiforov <darktemplar@altlinux.org> 2.2.5-alt1
- Updated to upstream version 2.2.5.
2013-04-18 - Vladimir Lettiev <crux@altlinux.ru> 2.0.35-alt6
- Fixed gdImageFill stack overflow comparison (libGD #177)
2012-09-27 - Dmitry V. Levin <ldv@altlinux.org> 2.0.35-alt5
- Check max colors while loading gd palette image (fixes CVE-2009-3546).
2011-03-09 - Dmitry V. Levin <ldv@altlinux.org> 2.0.35-alt4
- Rebuilt for debuginfo.
2010-10-25 - Dmitry V. Levin <ldv@altlinux.org> 2.0.35-alt3
- Rebuilt for soname set-versions.
2008-12-14 - Dmitry V. Levin <ldv@altlinux.org> 2.0.35-alt2
- Removed obsolete %post_ldconfig/%postun_ldconfig calls.

See Also

Package Description
libgd3-devel-2.2.5-alt3.i586.rpm Development library and header files for libgd3
libgda5-5.2.9-alt1.i586.rpm Library for writing gnome database programs
libgda5-bdb-5.2.9-alt1.i586.rpm GDA BerkleyDB Provider
libgda5-devel-5.2.9-alt1.i586.rpm Development libraries and header files for libgda
libgda5-gir-5.2.9-alt1.i586.rpm GObject introspection data for the GDA library
libgda5-ldap-5.2.9-alt1.i586.rpm GDA LDAP Provider
libgda5-mdb-5.2.9-alt1.i586.rpm GDA MS Access Provider
libgda5-mysql-5.2.9-alt1.i586.rpm GDA MySQL Provider
libgda5-postgresql-5.2.9-alt1.i586.rpm GDA PostgreSQL Provider
libgda5-providers-5.2.9-alt1.i586.rpm GDA service providers for libgda
libgda5-sqlite-5.2.9-alt1.i586.rpm GDA SQLite Provider
libgdal-2.2.3-alt3.1.i586.rpm Libraries required for the GDAL library
libgdal-devel-2.2.3-alt3.1.i586.rpm Development files for using the GDAL library
libgdamm-4.99.11-alt1_4.i586.rpm C++ wrappers for libgda
libgdamm-devel-4.99.11-alt1_4.i586.rpm Headers/Libraries for developing programs that use libgdamm
Advertisement
Advertisement