libgfortran6-devel-static-6.3.1-alt5.i586.rpm


Advertisement

Description

libgfortran6-devel-static - Static libraries for GNU Fortran development

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename libgfortran6-devel-static-6.3.1-alt5.i586.rpm
Package name libgfortran6-devel-static
Package version 6.3.1
Package release alt5
Package architecture i586
Package type rpm
Category Development/Other
Homepage -
License -
Maintainer -
Download size 6.08 MB
Installed size 6.08 MB
This is the GNU implementation of the standard GNU Fortran libraries.
This package includes the static library needed for GNU Fortran
development.

Alternatives

Package Version Architecture Repository
libgfortran6-devel-static-6.3.1-alt5.x86_64.rpm 6.3.1 x86_64 Classic
libgfortran6-devel-static - - -

Requires

Name Value
glibc-devel-static -
libgfortran6-devel = 6.3.1-alt5:sisyphus+235475.100.3.1
rpmlib(PayloadIsLzma) -

Provides

Name Value
libgfortran6-devel-static = 6.3.1-alt5:sisyphus+235475.100.3.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libgfortran6-devel-static-6.3.1-alt5.i586.rpm
Source Package gcc6-6.3.1-alt5.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libgfortran6-devel-static rpm package:
    # sudo apt-get install libgfortran6-devel-static

Files

Path
/etc/buildreqs/packages/substitute.d/libgfortran6-devel-static
/usr/lib/gcc/i586-alt-linux/6/libgfortran.a

Changelog

2019-08-05 - Gleb F-Malinovskiy <glebfm@altlinux.org> 6.3.1-alt5
- Added ppc64le support.
- Disabled gdb-plugin packaging in compat mode.
2019-04-12 - Dmitry V. Levin <ldv@altlinux.org> 6.3.1-alt4
- Fixed build with libtool 2.4.6.
2018-09-27 - Gleb F-Malinovskiy <glebfm@altlinux.org> 6.3.1-alt3.1
- Dropped redundant libcloog-isl-devel build dependency.
- doc: dropped libquadmath.info.
2018-01-10 - Gleb F-Malinovskiy <glebfm@altlinux.org> 6.3.1-alt3
- Built in gcc7 compatibility mode.
- Fixed build with glibc 2.26.
- Disabled java support.
- Dropped alternatives.
2017-02-01 - Gleb F-Malinovskiy <glebfm@altlinux.org> 6.3.1-alt2
- Updated to redhat/gcc-6-branch r244565.
- Synced with Fedora gcc 6.3.1-2.
- Fixed gnatmake's path to gcc (ALT#33003).
- Packaged buildreq substitution config for libmpx6-devel-static.
- Enabled java on aarch64.
2016-12-21 - Gleb F-Malinovskiy <glebfm@altlinux.org> 6.3.1-alt1
- Updated to redhat/gcc-6-branch r243852.
- Synced with Fedora gcc 6.3.1-1 and Debian gcc-6 6.2.0-13.
2016-11-10 - Gleb F-Malinovskiy <glebfm@altlinux.org> 5.3.1-alt4
- Updated to redhat/gcc-5-branch 234777.
2016-03-10 - Gleb F-Malinovskiy <glebfm@altlinux.org> 5.3.1-alt3
- Moved liblto_plugin.so back into %_libexecdir.
- Added executable bit to liblto_plugin.so.
- Backported upstram fix:
+ Enable frame pointer for TARGET_64BIT_MS_ABI when stack is
misaligned (ALT#31834).
2016-02-24 - Gleb F-Malinovskiy <glebfm@altlinux.org> 5.3.1-alt2
- Moved liblto_plugin.so into %_libdir.
2015-12-17 - Gleb F-Malinovskiy <glebfm@altlinux.org> 5.3.1-alt1
- Updated to redhat/gcc-5-branch 231358.
- Synced with Fedora gcc-5.3.1-2 and Debian 5.3.1-4.
- Added patch for aarch64 linker path.
- Changed compress_method to xz.

See Also

Package Description
libgfortran7-devel-7.3.1-alt9.i586.rpm Header files and library for GNU Fortran development
libgfortran7-devel-static-7.3.1-alt9.i586.rpm Static libraries for GNU Fortran development
libgfortran8-devel-8.3.1-alt5.i586.rpm Header files and library for GNU Fortran development
libgfortran8-devel-static-8.3.1-alt5.i586.rpm Static libraries for GNU Fortran development
libggi-2.2.2-alt3.1.i586.rpm A fast, simple, small and flexible user-space graphics library (General Graphics Interface)
libggi-devel-2.2.2-alt3.1.i586.rpm development part of libggi
libggi-devel-static-2.2.2-alt3.1.i586.rpm development part of libggi, static build
libghttp-1.0.9-alt6.qa1.i586.rpm GNOME HTTP client library
libghttp-devel-1.0.9-alt6.qa1.i586.rpm GNOME HTTP client development
libgiblib-1.2.4-alt0.4.qa1.i586.rpm Enlightened backgrounds manipulating library
libgiblib-devel-1.2.4-alt0.4.qa1.i586.rpm giblib headers and development libraries
libgibsonclient-1.0.0-alt1.git20140523.i586.rpm Gibson cache server native client library
libgibsonclient-devel-1.0.0-alt1.git20140523.i586.rpm Development files of libgibsonclient
libgif-4.1.6-alt3.i586.rpm A library for manipulating GIF format image files
libgif-devel-4.1.6-alt3.i586.rpm Development tools for programs which will use the libgif library
Advertisement
Advertisement